1. edurrell's Avatar
    I am a newbie and need help please!
    I have a 2g-8G itouch. I was recently trying to upgrade my software to 3.0 in order to download apps, but the upgrade didn't work, and I got a 1602 error msg.

    I ended up trying to restore it but when it gets to the end of the restore where it says "restoring ipod firmware", it gets stuck; it looks like it is loading but it goes on for hours. I have tried it several times and it does the same thing.

    I have tried it with another cable and on another computer but the same thing happens.

    Someone help me please!
    2010-07-08 06:51 AM
  2. kmmxracer's Avatar
    Try a DFU mode Restore
    -Plug it in to a computer
    -Turn it off (still plugged in)
    -Hold Power & Home button for 10 seconds
    -Then release Power button and continue to hold Home button for 10-15 seconds or until iTunes popes up asking to restore.
    2010-07-08 07:01 AM
  3. edurrell's Avatar
    Thank you. I have already attempted this, but it is during this restore that it actually gets stuck when "restoring ipod firmware".
    2010-07-08 07:27 AM
  4. kmmxracer's Avatar
    What version of iTunes are you on and what firmware are you trying to restore to?
    2010-07-08 07:30 AM
  5. Spudski's Avatar
    try upgrading to iTunes 9.2 if you haven't already done so. is your device jailbroken? if not an email to apple will never hurt if you can't find a solution elsewhere.
    2010-07-08 09:11 AM
  6. bobright's Avatar
    iTouch?

    LOL
    2010-07-08 09:16 AM
  7. edurrell's Avatar
    I am running itunes 9.2. Not sure about the firmware-how would i know that? Sorry-stupid question-Im a newbie

    No, my device is not jailbroken, but that is something that I would like to do as soon as I can get it fixed.

    iTouch?

    LOL
    Is that a question or was my post funny? Like I said, I'm a newbie.
    Last edited by edurrell; 2010-07-08 at 04:57 PM. Reason: Automerged Doublepost
    2010-07-08 04:57 PM
LINK TO POST COPIED TO CLIPBOARD