1. lamja's Avatar
    Ok heres what i need to ask and i will be happy if anyone help me,

    i have iphone 3gs 3.1.2 firm jailbroken, and unlocked, works fine at moment but i want to upgrade to 3.1.3, but i read some posts and now am scared to do anythink untill i ask whats wrong now or whats good... i tryed to save shsh dunno what happend but umbrella sad somethink like to late to save them...

    before this on cydia i didnt see anythink on the top screen, then when i click cydia i see "this device has a pending TTS request" and now after 1 day i see..........
    This device has SHSHs on file for iphone OS: 4.0 how can be this possible when am on 3.1.2 is this wrong or good? what shoud i do now, can i upgrade to 3.1.3.?

    tnx if anyone answer me
    2010-07-19 05:23 PM
  2. jkmonkey's Avatar
    Cydia can only save shsh's for the current firmware being signed by apple regardless of what firmware you have installed. If cydia only shows that you have 4.0 then that is the lowest fw you'll be able to restore to. In short no, you can't install 3.1.3
    2010-07-19 05:30 PM
  3. lamja's Avatar
    so for now best is to stay on 3.1.2 right? and wait.... or is there jailbrake for me for 4.0 and unlock or no? tnx this is my last question sry
    2010-07-19 05:45 PM
  4. Will01's Avatar
    You could get to iOS4 provided you have an old bootrom. Are you JB with Blackra1n or Spirit?

    If Blackra1n does the phone need to be connected to PC to boot or can it reboot on it's own? This indicated old iBoot.

    If Spirit, you need to identify bootrom. Go to iH8sn0w.com | Jailbreak your iPod touches and iPhones and download iDetector, it will talk you through it.

    If on New Boot, stay on 3.1.2.

    If on old AND JB with ra1n: Download a pwned 4.0 FW and shift+restore to it.

    If on old AND JB with Spirit: Add the iWooWiz repo (google it) and download spirit2pwn, reboot the device, and then upload your customer 4.0 fw.

    If any of this goes wrong however you will have to restore to un-jb 4.0 and will be unable to downgrade due to the SHSH problem so the risk is up to you.
    2010-07-19 06:08 PM
  5. lamja's Avatar
    i checked that with idetector and its on old bootrom so its possible now to make 3.1.3 or only 4.0 but if i make 4.0 can i jailbrake and unlock?
    2010-07-19 07:04 PM
  6. lamja's Avatar
    so ?
    2010-07-22 05:06 PM
  7. kaepora's Avatar
    2010-07-22 05:14 PM
  8. mael's Avatar
    i checked that with idetector and its on old bootrom so its possible now to make 3.1.3 or only 4.0 but if i make 4.0 can i jailbrake and unlock?
    Since you have no SHSH other than 4.0 you have no option of installing 3.1.3.

    Since you're JB'd (non-Spirit) on 3.1.2 and on old bootrom, you can JB and unlock with 4.0.

    Follow Will01's advice. Take special heed of the last sentence:

    If any of this goes wrong however you will have to restore to un-jb 4.0 and will be unable to downgrade due to the SHSH problem so the risk is up to you.
    Good luck.
    2010-07-22 05:33 PM
  9. Will01's Avatar
    i checked that with idetector and its on old bootrom so its possible now to make 3.1.3 or only 4.0 but if i make 4.0 can i jailbrake and unlock?

    Read my instructions.
    2010-07-22 05:51 PM
LINK TO POST COPIED TO CLIPBOARD