User Tag List

  1. Purk707's Avatar
    My iphone 3GS on ios 4.0 installs Mobile Terminal but when I try to run it it opens up for like 2 seconds then crashes. Ive tried reinstalling it a few times . I have tried restarting after install and nothing seems to be wowwwrking. Any help would be great. Also is it because mmi is being hit so hard that i get the error in cydia that i cant refresh data or something to that affect?
    I wish I had a Nikel for every time ive dropped my phone!!!
    2010-08-02 08:58 PM
  2. sublimespot's Avatar
    2010-08-02 10:57 PM
  3. mbeezy81's Avatar
    The cydia mobile terminal doesn't work. You have to either google it or I guess do what the person ^^^ above me said.
    2010-08-02 11:34 PM
  4. mj0528's Avatar
    I'd probably wait for the official, if you are worried about ssh being open. Close it in sbsettings and/or install Rock and it will prompt you to change the password.
    2010-08-03 12:27 AM
  5. i.Annie's Avatar
    Theres a mobileterminal out specifically for iOS 4.

    If you find downloading that and still have issues, PM me with your email address. I have the working version that I can send.
    2010-08-03 04:00 AM
  6. Purk707's Avatar
    Just installed rock and it let me change my passwd so im good thanx for the help.!! I do have another issue with Safari Download Manager . Is it free is my 1st question and 2nd it installs without errors but i go into settings and open it to see blank with a message on top that something went wrong with it ..lol.. i guess i could reinstall and give the apropriate message . Im just having a bunch of errors after installing certain things ! Its weird it just seems like ntheres something missing in this JB but maybe its just the fact that it was so easy to do . Driving home from work when it released and it was done before my light turned green ..lol... anyways thanks for the help with terminal issue much appreciated..
    I wish I had a Nikel for every time ive dropped my phone!!!
    2010-08-04 01:38 AM
  7. DEEPTHOUGHT@'s Avatar
    I installed ROCK and it just force closes the same as MOBILE TERMINAL. Can someone help?
    2011-05-20 02:11 AM
  8. i.Annie's Avatar
    Rock isn't supposed to work anymore.

    Mobileterminal you'll likely need an iOS 4 version.

    For mobileterminal add repo podzombie.com/repository and install it from that, and you should be fine.
    2011-05-20 02:40 AM
  9. SlimPickins's Avatar
    Here are the links for all mobile terminal downloads.

    using... iPhone4 , 5.0.1 (applies to multiple versions) - installing mobile terminal r510
    Ok... i had trouble downloading it from everywhere... but here is a manual way to do everything that I really like. the reason for that is that , with most tweaks is one time use effort. This however is a procedure you should know, and list of programs you should be using.

    Depending on the iOS version you are using you may need to manually install the file with a couple of quick steps.

    Solution A. )

    Try to Download the iCauseFX Repo, that fixed it for me on a 3Gs, with no hassle. 5.0.1 :

    Solution B. )

    By doing half the instructions below, with iFile installed, you can download from your mobile device, and bypass the use of a desktop / laptop. With that installed properly, it should say "open with iFile" in Downloads. From there you can click and install.

    Solution C. )

    First you will need to to SHH to your device ( the best feature of jailbreak)

    You will first need to install openSHH on your device.
    You will also need iFile installed on your device, to later browse for the file/s that you will be moving to your iPhone.

    After you have iFile , and openSHH installed on your phone, connect to your iPhone device with Cyberduck, in the SSH(sftp) mode. Here is another article on cyberduck and SHH if you have problems. You can download cyberduck for os X and all Windows ver. Here

    I could make many notes about Cyberduck but will just say if you are new to it, you really should be using it already.
    YOU MAY EXPERIENCE A PROBLEM once connected. While browsing files you may not see the right things there, as if you have no access. The problem is the directory browser bar, as default, goes into recursive depths. You may also have a PROBLEM when connecting, if it says "try again" you may need to click that a couple times.

    For example my version started on "private/var/root/" , I changed to bookmark to start on "/" so I don't get confused and work my way in.

    You should now be able to browse your file system on the phone. (as shown from previous linked post)
    Mobile Terminal keeps crashing! Help!!-cyberduck_iphone_connected.gif

    you can then navigate to the download page in your web browser for mobile terminal to select versions. (Download MobileTerminal here)

    Now that you have downloaded the file, ( for me using 5.0.1 iOS I needed to install "MobileTerminal_511-1_iphoneos-arm.deb"

    if you have mobile terminal installed already and its crashing, uninstall it now, and continue.

    Now you have that file in your downloads folder, or wherever it may be, drag it now to your desktop, as you will be dragging it into cyberduck.

    With the cyberduck window open and navigated to your "/" root file directory on your connected iPhone, drag the downloaded package into the window, so that it will copy.

    now that the file is in place, open "iFile" , on your device, from previous mention.

    once in iFile, you will see the package in your list of files that iFile is showing you. (ex. MobileTerminal_XXXXX_iphoneos-arm.deb) By touching the file you will activate the choices, " ZIP, Unarchiver, Installer" Press installer to install the package.

    return to cyberduck and you can now delete the package. it is now installed. I would suggest google for finding out what version you need for your iOS, but it is likely a mismatch that is causing the failed launch .

    respring or restart.


    If all else fails , consider disabling winter board, or switching between winter and summer board mode.

    Good luck.

    Here is the standard procedure.
    Last edited by SlimPickins; 2012-01-11 at 07:09 AM.
    2012-01-09 04:58 AM
LINK TO POST COPIED TO CLIPBOARD