1. modmyphonetoo's Avatar
    Hi

    just upgraded from 3.1.3 jb with spirit to iOS 4.0.1 (jb with jailbreakme.com)
    The upgrade was smooth.. everything (list of my apps, sms, photos etc) were as usual..
    Then i started to install a few cydia apps and suddenly i found out all of my apps (download from itunes) are all hone. The iCons are all gone but the file/directory are still there (I ssh into my phone).
    I checked POOF! (Hide Icons) from SBSettings as well, there isnt any app icons inside...
    Wondering what happened?
    I am suspecting MyWi or Rock App screw it up... as I have problem with them so i uninstalled them...
    Update: I am suspecting its Categories that caused the problem as I didnt uninstall it before upgrading to iOs 4.0.1
    I check my itunes's app tab, all of the apps are UNTICKED, if i tick, they will install the app into my phone. But it ended up with double folders in ssh (/private/var/mobile/applications)

    What should i do now..
    Last edited by modmyphonetoo; 2010-08-04 at 10:06 AM.
    2010-08-03 12:12 PM
  2. eldukie's Avatar
    I am having exactly the same problem with most of my apps. 24 hr after a perfect upgrade to 4.0.1 + jailbreakme ... Suddenly voila! Vanished
    2010-08-04 04:24 AM
  3. modmyphonetoo's Avatar
    Did u previously use Categories in 3.1.x?
    I didn't uninstall it before upgrading to 4.0.1, it might cause the problem..
    I ended up restore from my backup..
    2010-08-04 05:17 AM
  4. eldukie's Avatar
    Yes i did use Categories in previous vs. And remembered having a similar issue some time ago, as you say, related to Categories..

    Did the restore solve the issue?
    2010-08-04 09:45 AM
  5. modmyphonetoo's Avatar
    It solved with restore.
    After restore, there isnt any app in the phone. But once u sync, it will be like before together with the app's setting (e.g chat history of whatsapp stil there)
    2010-08-04 10:05 AM
  6. eldukie's Avatar
    Well i guess will have to try. Will let you know. Gracias
    2010-08-04 10:42 AM
  7. Sixfingered's Avatar
    I had this same problem. I was able to get into sbsetting and ad categories to the dock there and lauch categories from them. Once I did that my folders came back with my apps in them.
    2010-08-04 05:46 PM
  8. eldukie's Avatar
    Sixfingered, I guess you meant to say that you added Categories from Cydia ...

    I restored my iphone and all went well until I synchronized again the rest of my apps with itunes ... same situation, only a few visible ... all are actually there and you can access via spotlight, but invisible.

    To be continued...
    2010-08-04 07:31 PM
  9. modmyphonetoo's Avatar
    @eldukie: i believe you can solve by install categories..
    good luck
    2010-08-04 07:35 PM
  10. lopbird33's Avatar
    I have a similar problem that has happened after 2 restores now...3GS wasn't previously jailbroken (this happened once before new JB was released) and I woke up to all of my AppStore icons gone. Problem is that I cannot access them in Spotlight, but they still are on the phone somehow. Installing categories hasn't helped. Anyone else in the same boat?
    2010-08-04 07:51 PM
  11. thevmax's Avatar
    Did you have your apps hidden in sbsettings?
    2010-08-04 08:09 PM
  12. Poseidon79's Avatar
    If you have hidden icons or icons in categories and make a back-up in iTunes the phone saves this list so when you upgrade to another firmware and restore from a backup it THINKS all these apps are installed and hidden so that when you install them again the icon is still hidden.

    Moral of the story... never restore from backup.. always set up as a new profile in iTunes. This is also true for people having preference issues and battery issues.

    You can SSH or use iphone browser and delete the file located at /var/mobile/Library/Preferences/com.apple.SpringBoard.plist. Then reboot and this will reset the missing icons file.
    Last edited by Poseidon79; 2010-08-04 at 08:25 PM.
    2010-08-04 08:15 PM
  13. lopbird33's Avatar
    Did you have your apps hidden in sbsettings?
    Nope. No icons in spotlight/SBSettings/Categories. I just deleted the Applications folder and am gonna resync the apps to the phone and see if the settings merge...

    ...and nope, settings didnt merge. Hmm really weird. This happened to me on this phone before jailbreaking too (bought it with 4.0 installed so I couldn't JB until a few days ago). Don't think I had this problem on my 3G.
    2010-08-04 08:21 PM
  14. eldukie's Avatar
    My problem solved, through Categories.

    I had done a new install via iTunes ... Also sync Cydia apps with PkgBackup.

    Created a folder with Categories, added missing apps, respringed and later removed them from the ( trashed it ), respringed again and apps now back
    2010-08-05 03:17 AM
  15. Marcass86's Avatar
    If you just updated to ios4 but didnt restore first all the settings for Categories will stay, as soon as you reinstalled Categories(after re-jailbreaking) all those icons that were in your folders went back into hidden mode. Dumbed down version of what it does... they are never gone they are just hidden.

    FIX: Reinstall sbsettings, open it tap the more option on the bottom row and then select Hide Icons, un-hide all your icons. Its all still there as others have pointed out they are just hidden.

    Reinstalling categories just enabled it but without the ability to get to the folders you hid them in.

    Remember though ios4 creates its own folders now. Might be an easier option.

    If I'm wrong don't kill me.
    2010-08-09 08:26 AM
  16. lkats's Avatar
    Same problem. I had categories in 3.1.3, upgraded to 4.0.1, iphone worked ok for a week or so, and then I missed lots of icons of applications. I believe that these were the applications stored into categories folders.

    I tried everything described, nothing succeded

    I tried to unhide through sbsettings, no luck.

    I deleted springboard.plist, no luck

    I created a folder in categories, tried to add applications, and appeared some applications with a question-mask as icon. When I opened the folder again, it was empty. I finally unistalled categories.

    I have reinstalled missing applications through itunes. Ok for one day (except the fact that I had duplicate applications in /var/mobile/Applications), then the icons disappeared again.

    Any idea ? How I can create an icon and a link to the application that is stored in /var/mobile ...

    Is there any file that I have to delete so to unhide app icons?

    Thank you a lot.
    2010-08-10 02:18 PM
  17. Will01's Avatar
    Have you tried the old Restrictions trick?

    Settings>General>Restrictions

    Turn them on, then straight off again, reboot.
    2010-08-10 03:07 PM
  18. lkats's Avatar
    Yes I did tried the restrictions off / on. but it didn't helped.

    It somehow fixed by itself during the reinstallation of an application through ********** (all the icons appeared out of the blue!), by I have the bad feeling that the app icons will disappear again. So I am still trying to figure out the cause and the solution.

    Thanx anyway, I hope that I will come up with some solution!
    2010-08-10 05:15 PM
  19. Will01's Avatar
    I fixed the same problem before by reinstalling an AppStore app, or installing a new one.

    Did you restore your cydia apps using AptBackup by any chance? This can cause said issue.
    2010-08-10 05:20 PM
  20. lkats's Avatar
    I use Pkgbackup and Aptbackup, but I restored through Pkgbackup. Sometime in the past i fired the Aptbackup restore by mistake, but I believe it was before upgrade/JB to 4.0.1, and surely was enough days before the appearance of the missing icons problem.

    And I have to say that I had reinstalled 3 apps without fixing the problem, which happened at the reinstallation of the fourth app!
    2010-08-10 05:25 PM
24 12
LINK TO POST COPIED TO CLIPBOARD