1. dunlapface's Avatar
    Ok, so I jailbroke yesterday and everything was going just fine and then I tried adding sources to Cydia. Everytime I try and add a source it looks like it finishes but it hangs up at Downloading Packages and nothing happens after that and I have to close out of Cydia to get out of it.

    Is anyone else having this issue? I thought maybe it was a speciific source that I was adding but it does it for every source I try and add.

    Is there a fix for this?
    2010-08-03 03:14 PM
  2. skiptowncat's Avatar
    When you go back into cydia, after it has finished updating the packages, what errors does it give?
    2010-08-03 03:22 PM
  3. dunlapface's Avatar
    It says error downloading packages and I get a list of sources that says there were errors.
    2010-08-03 03:35 PM
  4. TheCake's Avatar
    Can you post up what the errors you see on the screen are?
    2010-08-03 03:42 PM
  5. skiptowncat's Avatar
    Can you post up what the errors you see on the screen are?
    That would help us!!
    2010-08-03 03:44 PM
  6. dunlapface's Avatar
    Ok will do. Working on getting some screen shots up for you guys.
    2010-08-03 03:47 PM
  7. Will13's Avatar
    Same here after I first jailbreaked, but after re-springing or rebooting they was there
    2010-08-03 03:47 PM
  8. dunlapface's Avatar
    In the meantime waiting for something to pop up, I am getting a continuous Error: Cashed Failure at the top where it usually shows download packages and stuff when you first open up Cydia. Don't know if this helps ...
    2010-08-03 03:48 PM
  9. skiptowncat's Avatar
    Cancel the refresh and tell us what it says.
    2010-08-03 03:52 PM
  10. jkmonkey's Avatar
    Is it any repo you try to add or just one?
    2010-08-03 03:59 PM
  11. dunlapface's Avatar




    It's any repo I try and add.
    Last edited by dunlapface; 2010-08-03 at 04:02 PM. Reason: Automerged Doublepost
    2010-08-03 04:02 PM
  12. skiptowncat's Avatar
    If you are ALWAYS getting errors about sources when opening Cydia (even when downloading things from WORKING repos). And Cydia wont let you delete the source, because its not there... This is the guide for YOU...

    If you dont complete all these steps, the "bad repo" will come back to haunt you later..so complete them all!
    (Some have been listed here before, but you need to do ALL the steps to get rid of it for good)

    Step 1:

    * Navigate to /private/etc/apt/sources.list.d and delete all files that contain the offending repo in the filename.
    * Open cydia.list for editing.
    * You will see lines that look like deb http://somerepo.url/ ./ Remove the line that has the offending repo url.
    * Save the file.

    Step 2:

    * Navigate to /private/var/lib/apt/list and delete all files that contain the offending repo in the filename.

    Step 3:

    * Navigate to /private/var/lib/apt/list/partial and delete all files that contain the offending repo in the filename.

    Step 4:

    * Navigate to /private/var/lib/cydia and open the metadata.plist for editing.
    * Ctrl+F (or similar) for your offending repo url and delete all instances of it (it may appear more than once in the file).
    * Save the file.

    And there you go, Nice Clean Cydia... With NO Errors.


    citric, on 14 May 2010 - 03:04 PM, said:
    Hey citric, I found a solution to your problem that might also help other people.

    SSH into your iPod
    1. navigate to /private/var/lib/apt/lists/.
    2. Delete all files except the folder "partial". If your on the computer you can back them up just in case.
    3. Open Cydia and refresh your sources.

    This does help, but the only SURE way is to do all the steps I have listed above.
    Last edited by skiptowncat; 2010-08-03 at 04:16 PM.
    2010-08-03 04:12 PM
  13. TheCake's Avatar
    I had to SSH into my 3GS to remove a miss-spelt repo which was causing similar errors.

    skiptowncat - your link has been ******* starred out?!

    Try this: http://tinyurl.com/2usr8vc
    Last edited by TheCake; 2010-08-03 at 04:15 PM. Reason: tinyurl added
    2010-08-03 04:14 PM
  14. dunlapface's Avatar
    Ok go through the steps in the link for EVERY SOURCE YOU HAVE TRIED TO ADD MANUALLY.
    I had one bad source that blocked the rest from downloading, it used to get right to the end then just nothing


    3rd post down

    http://*************/topic/66581-cydia-repo-removal/
    Hey can you contact me on gmail chat or something to let me know what the site is? I can't get to the link because it is censored.

    My gmail is [email protected]

    Thanks!
    2010-08-03 04:14 PM
  15. skiptowncat's Avatar
    Post updated, do steps 1 to 4. Worked for me.

    These steps should be a sticky tbh, I'm expecting more ofthe same question as the days go by!!

    IMPORTANT***
    only do it for the repos you have tried to add manually
    Last edited by skiptowncat; 2010-08-03 at 04:21 PM. Reason: Automerged Doublepost
    2010-08-03 04:21 PM
  16. dunlapface's Avatar
    Ok, I tried all the steps and I still get the freezing when trying to add sources. This is getting to be really annoying.
    2010-08-03 04:54 PM
  17. TheCake's Avatar
    What repo entries do you have in your cydia list at the moment? Can you copy/paste it in here or post a screen shot of it?
    2010-08-03 06:24 PM
  18. skiptowncat's Avatar
    How long are you waiting when adding repos?
    When the blue bar fills it takes about 20-30 seconds after that.
    2010-08-03 06:27 PM
  19. dunlapface's Avatar
    I took all the repos out of the list through the apt folder and partial like the directions said. But for some reason, everytime I go back and check through SSH the repos just come back again.

    Also, I've left it for a good 15 minutes and it still hasn't finished downloading packages. Trust me, I'd be able to wait a minute or two for it to work.

    What could be the issue? The only one in my list right now is the Sinful Repo.
    2010-08-03 06:30 PM
  20. skiptowncat's Avatar
    Did you change the metadata.plist? If you don't it just tries to reinstall them again and the cycle continies
    2010-08-03 06:32 PM
25 12
LINK TO POST COPIED TO CLIPBOARD