1. dark3lf1337's Avatar
    Hello all.
    I recently bought a used iphone 3G off of ebay so I can jailbreak and unlock for tmobile. When I got it, it showed the emergency call screen when I inserted my sim (as expected, it's tmobile). For some reason I restored to 4.0.1 firmware because I didn't know (and couldn't figure out) what firmware was on the device, since I couldn't get to the springboard to check. Now, I have tried many methods for jbing this thing:

    A) Tried using redsnow and pointing to a 4.0 ipsw file even though im running 4.0.1 (like many guides say). This works fine until I get to the "Downloading jailbreak data" screen, at which point it stays on this screen forever until finally rebooting and bringing me back to the emergency call screen.

    B) I've also tried restoring with a custom, activated ios 4.0 ipsw to jb and get past the emergency call screen, but since I didn't back up shsh blobs I can't downgrade from 4.0.1 to 4.0

    Are there any other jbing + hacktivation techniques out there that I can use given my current situation? What should I do now? Do I have to wait for a new hack or I'm I screwed forever? Thanks in advance for any help, I really need it!!

    Other potentially useful details:
    Firmware: 4.0.1
    Model: IPhone 3G
    Space: 8GB
    Model #: A1241
    Baseband: ?

    Thanks again, guys!
    2010-08-08 03:50 AM
  2. i.Annie's Avatar
    Downgrade to 3.1.2. iOS 4 isnt good for 3G phones.

    Download 3.1.2 ipsw
    Download Redsn0w 0.9.3
    Download Recboot

    Shift+restore to 3.1.2
    Get error 1015 (or any variation of error 101x)
    Kick out of recovery mode w/ Recboot
    Jailbreak with Redsn0w 0.9.3 (select only Cydia when prompted if you dont know what the other options mean)

    All done

    Unlocl if necessary w/ Ultrasn0w in Cydia.
    2010-08-08 07:14 AM
  3. piston597's Avatar
    Did you try jailbreakme lol? Umm activation might be some trouble though.
    2010-08-08 08:05 AM
  4. i.Annie's Avatar
    Sure, jailbreakme would be fine. I still dont recommend a 3G being on 4.0. Too many complaints on the lags and freezes. I myself downgraded back to 3.1.3. It just doesnt run well on 4.0 regardless that jailbreakme will jailbreak 4.0.
    2010-08-08 08:07 AM
  5. piston597's Avatar
    Ok if you don't want 4.0 then do this, jailbreak via jailbreakme.com then go to Cydia, see if you have 3.1.2 or 3.1.3 SHSH files on it, it will say on top, if you do then your in luck just search up a guide how to downgrade iPhone 3G, if there is no SHSH/ECID files backed up then I suggest you get used to 4.0.1.
    2010-08-08 08:12 AM
  6. i.Annie's Avatar
    Its a 3G. You dont need SHSHs for 3.1.x restores. The SHSHs are only for 4.0 and up.
    2010-08-08 08:21 AM
  7. piston597's Avatar
    Oh really? My bad lol, I thought you needed it, don't iPods need it?
    2010-08-08 08:22 AM
  8. i.Annie's Avatar
    You only need SHSHs for 3GS and for 3G to get to iOS 4. 3G phones can go down to 3.1.x without SHSHs.

    iPod Touch 2G and 3G need SHSHs.
    2010-08-08 03:26 PM
  9. dark3lf1337's Avatar
    Well that would be nice, but I can't use jailbreakme.com because my device isn't activated (meaning I can't get into the springboard to open up safari and go to the website). I'm stuck at the emergency call screen.
    2010-08-08 03:30 PM
  10. i.Annie's Avatar
    Ok, then follow the instructions I gave you.
    2010-08-08 03:34 PM
  11. dark3lf1337's Avatar
    Is it also possible to say downgrade to 3.1.x (because you said you don't need shsh to do this) and then just simply run spirit or something? Thanks for the quick replies btw!
    2010-08-08 03:35 PM
  12. i.Annie's Avatar
    The reason why I told you to use redsn0w is cuz then you wont have to go out and get an AT&T SIM to activate. Redsn0w hacktivates, meaning it bypasses activation. Spirit requires activation which means you have to get a SIM.
    2010-08-08 04:24 PM
  13. dark3lf1337's Avatar
    Ah of course. Let me try this out and see how it works.

    Ok, I followed your instructions up to the part where I use redsn0w (restored to 3.1.2 with error 1015, kicked out of recovery), but when I run redsn0w, it gets stuck at "Waiting for reboot" after the white screen flashes, and then just shows the emergency call screen again. Any suggestions?
    Last edited by dark3lf1337; 2010-08-08 at 05:57 PM. Reason: Automerged Doublepost
    2010-08-08 05:57 PM
LINK TO POST COPIED TO CLIPBOARD