1. diannarose's Avatar
    I recently jailbroke my iPhone 3G with JailBreakMe. One of the first apps I downloaded was iPhoneModem. It worked great! I was so excited that I would not have to purchase internet service. But then I periodically started getting "no service" that day. I had gotten periods of "no service" before, so I didn't worry about it too much. That is, until it lasted for a whole day. I finally broke down and restored, and unfortunately had to upgrade to iOS4 to do it. But still... NO SERVICE! I got "waiting for activiation, this may take some time" and then "no service" still. "Some time" turned out to be never. So I had to get on the phone to AT&T who transferred me to Apple. My phone is waaay out of warranty but I was able to finally talk to someone after being on hold for about 20 minutes. I had to call back today and speak to the activation department and finally was able to talk to a SENIOR support representative, who actually seemed to know what he was talking about.

    Anyway here's how we fixed it:

    * Reset all phone settings (Settings-->General-->Reset Settings)
    * As soon as the home screen comes back up turn off the phone--immediately.
    * Turn the phone back on.
    * Turn airplane mode on.
    * Turn airplane mode off.
    * Say a little prayer and wait.


    And.. voila! iPhone Activated!

    I asked the support guy what he did, and he said I did everything, there was no activation or any other stuff going on on his end, which is good for anyone else in this situation who might not be able to call support.

    So now, the question is, was it JailBreakMe that caused all this? Or iPhoneModem? I suspect iPhoneModem, because it screwed up my internet connection on my computer as well. Very glad I didn't fork out ten bucks for the app, but sad too, I still don't know if I should jailbreak the phone again, the support guy said there was a fix for speeding up 3G in iOS4, so maybe I will just try and be content with a working phone for a while.
    2010-08-09 06:31 PM
LINK TO POST COPIED TO CLIPBOARD