1. NOYB111's Avatar
    I recently jailbroke my 3Gs 4.0.1 iphone. I am trying to get SSH to work so I installed Mobile Terminal from Cydia and every time I try to open it, it crashes. I assume it doesnt work with 4.0.1 firmware? Is there something I am missing or a different version somewhere? Cydia shows Mobile Terminal as version 364.1-10.

    Thanks
    2010-08-13 05:59 PM
  2. Hyperextension's Avatar
    That version is not compatible with 4.0.1. If you search Google, there is a version 426 I believe that somewhat works.

    I tried it and it does work, but it causes SafeMode crashes and I also noticed that my push notifications did not work when I had it installed.

    I will simply wait.
    2010-08-13 06:03 PM
  3. devilpupv's Avatar
    There is a new MobileTerminal being worked on by Saurik (creator of Cydia) and he has released a Beta version. So hang on tight. You can also use CyberDuck to use terminal on your Mac (dont know if you have one) to run commands for now.
    2010-08-13 06:27 PM
  4. NOYB111's Avatar
    Thanks im a PC.... I can wait, not a big deal. I can use iphone browser with it connect to my PC anyway. I just wanted the wifi option with SSH.
    2010-08-13 07:32 PM
  5. devilpupv's Avatar
    If you want Wifi option go download WinSCP it is great. Youtube the instructions on how to!
    2010-08-13 08:09 PM
  6. NOYB111's Avatar
    I did and that is how I ended up needing Mobile Terminal. I thought I needed to get into my root on my device and change the password or something. Maybe I will dig deeper. I fired up that app and couldnt connect. Time to google! thanks
    2010-08-13 08:18 PM
  7. devilpupv's Avatar
    Well if my memory serves ne right just open winscp and make sure you are ssh ready on your device and that you are on a wifi connection. In the log on make sure you are using the right connection option on winscp and you find your devices wifi address that you will need. If you haven't changed your password lig in with root as user name and alpine password. You should be set. I think winscp let's u change your password.
    2010-08-13 08:26 PM
  8. Hyperextension's Avatar
    I did and that is how I ended up needing Mobile Terminal. I thought I needed to get into my root on my device and change the password or something. Maybe I will dig deeper. I fired up that app and couldnt connect. Time to google! thanks
    Use WinSCP and run Putty. Putty will let you change the password, etc and pretty much everything you run on MobileTerminal.
    2010-08-13 08:29 PM
  9. BoctorBill's Avatar
    I had the same errors with MobileTerminal, but I already owned TouchTerm from before I jailbroke (fantastic software, btw - totally worth every penny).

    I installed OpenSSH and then used TouchTerm to ssh to localhost. Bang, I'm good to go. Changed my passwords and am happy as a clam.

    Now if SBSettings swiping wasn't broken, I'd be as happy as 2 clams.
    2010-08-17 07:16 PM
  10. gabster508's Avatar
    Does anybody know how to install Lang Pack since it requires mobile terminal to execute it?
    I'm on 4.0.1, Cydia's mobile terminal keeps crashing...
    2010-08-22 09:55 PM
  11. korin125's Avatar
    1) For Terminal on iOS 4 you will need version 426, add the repo: Index of /repository and it'll be there

    2) Does Cydia not ask you to change your SSH passwords automatically, mine always does after installing OpenSSH.

    If you don't know what to type to change your password in terminal it is mentioned in an article on my site here, check out my other great posts as well.
    2010-08-23 03:37 AM
  12. Fhsjaagshs's Avatar
    My repo has a Lang2.2 with no dePendancy on mobileterminal. It Aldo has the latest mobileterminal.
    iDevices: Lots, most jailbroken
    Computers: MPB 13" i7 mid 2011, MacBook Air "11 256GB Samsung SSD i7, 4GB RAM, both OSX 10.7.3

    I'm a iPhone hacker and Twitter API master.
    2011-05-29 03:43 PM
LINK TO POST COPIED TO CLIPBOARD