User Tag List

  1. stream41's Avatar
    Have a iPhone 3G running 3.0 so I could keep the tethering hack that came out. Getting tired of the sluggish response on the 3G so I'm wanting to upgrade to an iPhone 4. But I absolutely need tethering, so I'm going to have to jailbreak it and install MyWi4.

    I've been doing a ton of reading, and I think I'm clear on what to do, but I just want to make sure before I make a $200 mistake. Here's the plan:

    1: Buy iPhone 4, and let them transfer over contacts, photos, etc to new phone from the old one at the store
    2: Make sure I'm on 4.0 or 4.0.1
    3: Go home, and use www.jailbreakme.com to jailbreak

    I understand I need to save my SHSH blobs before I jailbreak, but from what I read, when you use the JailbreakMe method, you don't need to do anything other than go to the website. Is this true? Does the "Let Cydia make my life easier" thing take care of the SHSH's?

    Finally, how likely is it that I end up with a brick? If I end up with a $200 brick that's stuck on contract for the next 2 years, I'm going to flip.

    Thanks!
    2010-08-21 02:24 AM
  2. Will13's Avatar
    Yes all you need to do is go to jailbreakme.com, and yes the make my life easier thing in cydia does save your shsh blobs, except it now can't save your 4.0.1 blobs because apple stopped signing anything under 4.0.2, another thing, you pretty much cannot brick a iPhone any more, so your safe that way

    Edit: I'm pretty sure the iPhone 4 will have the same tethering option as the 3GS, so if it does you won't need MyWi
    Last edited by Will13; 2010-08-21 at 02:44 AM.
    2010-08-21 02:39 AM
  3. stream41's Avatar
    Cool, thanks. Now I'm reading that it will be pretty difficult to find a new iPhone 4 that doesn't already have 4.0.2 It will probably be several months until we see 4.1, I guess.
    2010-08-21 02:42 AM
  4. Will13's Avatar
    I think 4.1 will be out sooner then 7 month
    2010-08-21 02:45 AM
  5. stream41's Avatar
    So if I have a problem after the jailbreak and I do need to restore, where do I get the 4.0.1 ipsw? Is that what the "make my life easier" option does?
    2010-08-21 02:48 AM
  6. Will13's Avatar
    Well you could get it from here, but since you don't have your shsh blobs you can't restore to 4.0.1, only 4.0.2, and no that option just saves your shsh blobs for you
    2010-08-21 02:52 AM
  7. stream41's Avatar
    Ahh okay, I get it now. Thanks for the help. If I buy an iPhone 4 from a store I wonder if they'd find it suspicious if I told them it has to be a 4.0.1 phone
    2010-08-21 02:56 AM
  8. Will13's Avatar
    Lol probably, would be even worse if you asked in the apple store
    2010-08-21 03:01 AM
  9. ukhellfire's Avatar
    Personally id wait a couple of months. In my opinion, if u have lived with the 3g this long, a little longer wont hurt. U can either get the iphone4 and use it normally, and just use the 3g purely for tethering. Or, find a store that anyone hardly ever uses, and possibly get an older iphone4.... Just my thoughts on the matter.
    2010-08-21 03:07 AM
LINK TO POST COPIED TO CLIPBOARD