1. Simon's Avatar
    2010-10-18 04:45 AM
  2. janekua's Avatar
    I want to upgrade from 3.1.2 to 4.0.1
    I've done a little research, and almost done everything to do a safe upgrade...but i need a lil bit help.
    I have 3gs on 3.1.2 jailbraked (blackra1n) and unlocked, old bootroom, and done saving SHSH with tinyumbrella. I must say that when I start cydia it does not tells me anything about do i have SHSH, and used tinyumbrella 4.1.11 (newest), SHSH are saved on my comp (everyone to 4.1), and the files are around 60kb and 63kb.
    The last host is ( here's copy paste from the last lines)

    # 127.0.0.1 localhost
    # ::1 localhost
    74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com

    (have not modified anything, i think tiny umbrella has done everything here)

    I have downloaded iPhone2,1_4.0.1_8A306_Restore it is about 377 MB. What should I do now? Can someone tell me the right steps to upgrade to 4.0.1?
    My phone was locked to T-Mobile, but now i'm on another carrier and i don't have the original sim card the iphone was activated, but i have other t-mobile sim card (will be this working for activating again). Thanks
    P.S. I must have unlocked iPhone.
    2010-10-21 04:46 PM
  3. Simon's Avatar
    If you dont have a sim to activate your only option is to use sn0wbreeze (windows) or pwnage tool (mac) and create a custom 4.1 firmware. This will preserve your baseband and activate for you so that you can unlock again. Once you make the custom firmware you just shift-click restore to that.
    2010-10-21 05:02 PM
  4. janekua's Avatar
    I have another T-Mobile sim card, but not the one the phone was activated with. Before i unlocked it it was working on my other t-mobile sim card. Can i do that with this card?
    Last edited by janekua; 2010-10-21 at 05:24 PM. Reason: can't i just use the itunes and shift+restore to upgrade to 4.0.1 ?
    2010-10-21 05:14 PM
  5. Simon's Avatar
    Only if it is the same carrier the phone is locked to. I assume it is not a US iPhone then right?
    2010-10-21 05:23 PM
  6. janekua's Avatar
    No it is bought in T-Mobile Macedonia (locked only for T-Mobile), and i have another T-mobile sim card (also T-Mobile Macedonia), but not the one that the phone is activated with. Is this a problem or i can use any card from that carrier?

    And tell me, if this is ok, what method to use for update.
    I see you helped a lot of people here, so before i do any crap would like to ask you if i'm doing everything right.
    2010-10-21 05:48 PM
  7. Simon's Avatar
    As long as it is the same carrier it should activate it just fine. So you can use either the method to go to 4.0.1 in my original post of this thread or use sn0wbreeze/pwnage tool to go to 4.1.
    2010-10-21 06:19 PM
  8. janekua's Avatar
    So i would like to go with your method, i've done everything with tiny umbrella as i sad before, but i would like to ask (because i do not understand well all the thing about the SHSH blobs) is it OK that Cydia does not show the message that i have SHSH, but when i run tinyumbrella it saved my SHSH on my computer.
    Can you tell me if everything is ok with my hosts, and what else should i take care of.
    Thank you and sorry for my bothering
    2010-10-21 09:51 PM
  9. Simon's Avatar
    If tiny umbrella says you have the SHSH then you are fine. Cydia isn't showing them right now because of all the recent jailbreaks that just came out (server getting hit hard with requests) but they are still there.
    2010-10-21 09:53 PM
  10. janekua's Avatar
    Later i'll try the update, and hope it will go smoothly, and if i have any problem i'll post it here, hope you will help me again
    Thanks a lot for your patience, and answering my stupid questions
    2010-10-21 10:01 PM
  11. Simon's Avatar
    2010-10-21 10:03 PM
  12. janekua's Avatar
    I have 1 more question. Can you tell me are my hosts OK.

    The last host is ( here's copy paste from the last lines)

    # 127.0.0.1 localhost
    # ::1 localhost
    74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com

    these are the last lines of the hosts. Do i have to change something?
    2010-10-21 10:25 PM
  13. Simon's Avatar
    You are pointed to cydia right now so you are fine. Your restore would work with or without tiny umbrella.
    2010-10-21 11:46 PM
  14. janekua's Avatar
    thanks again
    2010-10-22 12:47 AM
  15. johny5's Avatar
    Has anyone had an issue with ejecting the TinyUmbrella DMG? My Macbook Pro will not eject the application. I receive an error stating

    "The disk "TinyUmbrella" cannot be ejected because other users ("System Administrator", "System Administrator" and others) are using it."

    Has anyone else experienced this and does anyone have a solution? I have tried force ejecting from disk utility and terminal both.

    I appreciate any advice,

    Thanks
    J5
    2010-10-22 04:38 AM
  16. Simon's Avatar
    Make sure you close tiny umbrella first. Also make sure you are not running it from within the dmg. Move it to your desktop or applications folder first.
    2010-10-22 04:41 AM
  17. janekua's Avatar
    YUuuuhuuuuu!!!! Done the update/restore, as you mentioned, and everything run so smooth. No erorrs, nothing at all. Next step is jailbrake.

    Jailbrake with: jailbrakeme.com
    unlock: ultrasn0w 9.1-1

    So far everything works great
    Last edited by janekua; 2010-10-22 at 03:19 PM.
    2010-10-22 11:46 AM
  18. Simon's Avatar
    2010-10-22 12:42 PM
  19. janekua's Avatar
    got my old address book (copy it with iFile), got my old messages( iFile did that too), installing my old favorite apps.
    Any suggestions for some interesting app for 4.0?
    Thanks again for the help
    2010-10-22 06:39 PM
  20. Simon's Avatar
    None that I can think of off the top of my head. I do love the multitasking and folders though.
    2010-10-22 06:47 PM
1,465 ... 891011122060 ...
LINK TO POST COPIED TO CLIPBOARD