1. Simon's Avatar
    Nowadays it is almost impossible to brick it beyond repair. Yes pwnage tool is mac only, snowbreeze provides a similar function on windows.
    2011-01-10 03:13 AM
  2. Syllinger's Avatar
    Yeah, from what I've read it seem that any software brick is as easy as booting to the DFU bootrom and restoring the phone using iTunes. That is, unless there is some kind of hardware malfunction.

    Aside from hardware malfuncitons, are there any other instances where you can brick the phone beyond repair? The only article I've read where a phone was unbrickable was when some guy hacked linux onto it and it damaged the internal power supply.
    2011-01-10 03:19 AM
  3. Simon's Avatar
    Pulling the iphone out when the phone is restoring the baseband can do the trick sometimes. Thats a definite no no.
    2011-01-10 03:22 AM
  4. Syllinger's Avatar
    So, I'm in Canada and I'm on the Bell network. I'm on a contract, so I don't think I'm going to be changing carriers any time soon.

    This means that there is no reason for me to worry about baseband, right? I won't be unlocking the phone, as there is really no point in me doing so.

    Also, do you know where I can read more about this baseband SHSH thing? I would be interested to find out how it works. I know that regular SHSH blobs are attached to the ECID, but if baseband SHSHs are randomized on restore, I don't know how you can't spoof a server for that too. Or maybe it's just not implemented in the TinyUmbrella software yet.

    This is why I dislike Apple products, they put in all this effort to restrict users. I mean, MS does it too, but not to this extent. I can't wait until I can make the switch to Android, open source is the way to go. Now they just need hardware as well built as the iPhone to make it a staple in the mobile community.
    2011-01-10 03:34 AM
  5. Simon's Avatar
    No you dont have to worry about unlocking then.

    Just google it I guess to find out more info. I think it was looked into at first but if it is randomized every time then there must be a key that is used to determine the random SHSH. I am sure only a select few at Apple have that key, and it is probably almost impossible to brute force it.
    2011-01-10 03:37 AM
  6. Syllinger's Avatar
    Yeah, I wonder how they were able to sniff out how the firmware SHSH blobs work.

    So finally, one last major question. When I jailbreak, since I'm not trying to unlock the phone, the baseband shouldn't change. Is this correct? If the phone ends up bricking in the middle of the jailbreaking process, will it be just as simple as booting into DFU mode and restoring thorough iTunes from the apple servers?

    In any case, from what I've read this is a common source of confusion. A lot of people mix up jailbreaking and unlocking to be the same thing. But from what I understand you have to jailbreak first, which does not affect the baseband at all. Once the phone is jailbroken, you then have the ability to unlock it, and this is what casuses the baseband to change. Is this correct?
    2011-01-10 03:49 AM
  7. Simon's Avatar
    unlocking doesnt change the baseband. Updating firmware does. Since you are not worried about unlocking then it doesnt matter if your baseband gets updated when updating.
    2011-01-10 03:56 AM
  8. niklpl8dpokets's Avatar
    my girlfriend wanted to sync some songs onto my iphone 4 and when she did that she updated it from 4.1 to 4.2.1 thinking she was helping me. i have all my blobs saved and when i try to do a restore/downgrade in itunes to 4.1 with tinyum server running i get an error in itunes saying 'the iphone "iphone" could not be restored because the firmware file is not compatible'

    i tried downloading a few different ipsw so there cant be something wrong with all of them. anybody have any ideas?

    i dont care about unlocking i just want to downgrade so i can jb
    2011-01-11 07:05 AM
  9. Simon's Avatar
    If you have 4.1 SHSH it should work. Are you putting it in dfu when restoring?

    Also what is the filename of the firmware you are trying to restore to?
    Last edited by Simon; 2011-01-11 at 03:13 PM. Reason: Automerged Doublepost
    2011-01-11 03:13 PM
  10. niklpl8dpokets's Avatar
    I tried it in dfu mode and it didnt work either. the file name is iPhone3,1_4.1_8B117_Restore.ipsw and i have an iphone 4. i have the newest version of itunes istalled and i am using tinyumbrella-4.21.02. in tiny umbrella i have every ios blob saved including iPhone4 4.1(8B117)
    2011-01-12 01:55 AM
  11. Simon's Avatar
    Does the file have a white cube like icon?
    2011-01-12 02:04 AM
  12. niklpl8dpokets's Avatar
    the ipsw file has a white sheet of paper icon, its the icon for file types with no default program to open them
    2011-01-12 02:15 AM
  13. Simon's Avatar
    Try downloading the firmware again with firefox
    2011-01-12 02:19 AM
  14. asif_cbse's Avatar
    i need to even unlock...but i get 1646 error
    2011-01-12 01:57 PM
  15. niklpl8dpokets's Avatar
    Try downloading the firmware again with firefox
    Thanks alot! it worked! I figured google chrome would be fine since it still saves as a ipsw file and not a zip but firefox did the trick.
    2011-01-13 01:46 AM
  16. Simon's Avatar
    2011-01-13 01:50 AM
  17. Flyer92's Avatar
    Guys I have a serious problem and I really hope someone can help me. Please...

    Here's the story:
    I have an iPhone 4 running 4.0.1 with baseband 1.59. I simply wanted to update to 1.4.2 while simply retaining the baseband.

    I followed the instructions on this website Update iPhone 4 on iOS 4.1 Without Upgrading 1.59.00 Baseband to 2.10.4 [Guide] | Redmond Pie and now my phone is stuck in recovery mode.

    I tried to exiting from recovery mode using tiny umbrella and recboot, but still no luck. Ideally I'd like to be at F/W 4.2.1 but I don't mind reverting back to 4.0.1 just to get a work iphone. I'm new to the iPhone and need help or instructions on how to fix it. Help!
    2011-01-15 02:12 AM
  18. Simon's Avatar
    If you have shsh for 4.0.1 I suggest going back there for now. 4.2.1 is a tethered jailbreak right now. Wait until it is untethered.
    2011-01-15 02:23 AM
  19. Flyer92's Avatar
    I don't have the shsh for 4.0.1.

    The saved shsh I have is 4.2.1. I never saved the 4.0.1 apparently. How do I unloop myself out of recovery with no saved shsh?
    Last edited by Flyer92; 2011-01-15 at 02:37 AM. Reason: Automerged Doublepost
    2011-01-15 02:36 AM
  20. Simon's Avatar
    Without SHSH your only option is to make a custom 4.2.1 with a unofficial pwnage tool.
    2011-01-15 02:49 AM
1,465 ... 816171819202868 ...