1. Simon's Avatar
    Make sure you find one that specifically says it will.
    2011-02-13 04:30 AM
  2. dariusdpd's Avatar
    found everything i need to ugrade to 4.2.1
    [
    Thank you

    found everything i need to ugrade to 4.2.1

    Thank you
    just finished upgrading,works like a charm
    if anybody else have same problem:

    no links to custom firmware
    Last edited by Simon; 2011-02-13 at 04:41 PM. Reason: Automerged Doublepost
    2011-02-13 06:09 AM
  3. dikman's Avatar
    Wouldn't work for me. Kept returning error 13.
    2011-02-13 11:12 AM
  4. Simon's Avatar
    Wouldn't work for me. Kept returning error 13.
    Update Your iTunes.
    2011-02-13 04:15 PM
  5. dikman's Avatar
    Using latest versions of everything.
    2011-02-13 10:47 PM
  6. Simon's Avatar
    I'm not sure what you are trying to do. Your first post wasn't very clear.
    2011-02-13 10:52 PM
  7. dikman's Avatar
    Hmm, I was trying to avoid writing a long story.

    GS3, had passcode lock in place, so neither itunes or TinyUmbrella could see it. Couldn't bypass lock, so needed to replace firmware and start from scratch. After starting/restarting/changing computers, TinyU suddenly came up with an ECID. SHSH were recovered, including 2,1_4.1. TinyU still couldn't see the device but I ran the TSS server and it installed the 4.1 firmware (the phone displayed the loading process and I have the updater log which appears to indicate that it was installed). However, at the end of the installation it stayed in DFU mode and all attempts to get it out have failed. iTunes reports a phone in recovery mode every time it is connected.

    What is curious is where that original ECID came from, because when I ran USBview it shows a different ECID, and although it shows the device neither TinyU or iTunes can see any device connected.

    Whether I use RedSn0w or iREB any attempt to run a custom 4.2.1 fails (I have downloaded the file from several different locations, makes no difference). During this process the phone goes to a white screen, while it says "preparing phone for....." but then returns an error.
    I have tried running tethered, makes no difference.
    Re-directing the Hosts file back to the Apple server and trying a restore/update from there fails (message is "not eligible for this build", or words to that effect).

    Because TinyU can't see the device, I can't use that to "kick" it out of recovery mode. Recboot doesn't work either.

    All this was tried, over the last two weeks, using 3 different computers - 2 desktops running XP and a laptop using Win7.

    As I said, no-one has been able to tell me how to get this phone out of DFU. I have, thus far, been unable to find anyone else who has had the same issue, and unfortunately I suspect it is beyond the abilities of this forum to resolve.
    2011-02-14 11:31 AM
  8. Simon's Avatar
    Restore it to 4.2.1 without using tiny umbrella. Just use iTunes.
    2011-02-14 01:29 PM
  9. dikman's Avatar
    As I mentioned, I've tried that (numerous times). Process is -
    - says verifying restore with Apple (screen goes white)
    - says preparing iphone for restore
    - returns error 13
    - unplug phone, screen eventually goes black

    I've tried this on 3 computers, different usb ports, no firewall all with the same result.
    2011-02-14 11:20 PM
  10. Simon's Avatar
    I don't see where you mentioned anywhere that you tried restoring to a regular 4.2.1 firmware.

    Just to confirm what version of itunes are you running?
    2011-02-14 11:22 PM
  11. dikman's Avatar
    From previous post "Re-directing the Hosts file back to the Apple server and trying a restore/update from there fails". My apologies, I assumed it would be logical that I wouldn't be using a custom firmware if I was re-directing to the Apple server.

    This particular PC has iTunes v9 (I reverted to an earlier one to see if it made any difference). The laptop is running the latest, downloaded last week, but gives the same results.

    Someone has suggested trying to install an iPad baseband. Is this likely to have any effect? My knowledge of jailbreaking hasn't (yet) extended to the implications of using an iPad baseband.
    2011-02-14 11:33 PM
  12. Simon's Avatar
    It isnt logical to think your hosts should be pointed to Apple for regular firmware. You can restore custom and regular firmware just as easily with your hosts pointed at cydia or Apple as long as you have SHSH.

    iTunes is your problem, at least on the itunes 9 one. You need the latest version of iTunes which is 10.1.2.

    Are you still getting error 13 when using itunes 10.1.2?
    Last edited by Simon; 2011-02-14 at 11:42 PM.
    2011-02-14 11:40 PM
  13. dikman's Avatar
    Sorry if I came across as sounding harsh, it wasn't my intention. I was just under the impression, from everything I've read, that to use custom firmware it had to be pointed at Cydia and if pointing at Apple's server then only official firmware would work.

    I've just tried it on the laptop, iTunes 10.1.2.17, and it downloaded the software from the server, started the restore and came back with error 28.
    2011-02-15 12:02 AM
  14. Simon's Avatar
    It's cool

    Ok, now we are getting somewhere. Try to run greenpoison rc6 on it after getting that error 28.

    btw have you ever changed the battery in it?
    Last edited by Simon; 2011-02-15 at 12:11 AM. Reason: Automerged Doublepost
    2011-02-15 12:11 AM
  15. dikman's Avatar
    No to the battery (bearing in mind my wife found this thing). Indications are that it's less than 12 months old, so the battery should be fine. I did disconnect it in the early days, so to speak, in the hope it might clear the passcode (!) but this was before I installed the 4.1 firmware or tried anything software-wise.

    Having trouble finding a link to download RC6, they keep saying can't find server!!! Still looking. What makes you think this might work?

    Edit: this could take a while, none of the download links seem to be working, their server doesn't seem to exist!!
    Last edited by dikman; 2011-02-15 at 12:34 AM.
    2011-02-15 12:24 AM
  16. janekua's Avatar
    just download greenpois0n from their web greenpois0n.comm there is the latest greenpois0n rc6, and you're good with it
    greenpois0n run smooth on my phone

    Servers looking good, downloaded it for a second
    2011-02-15 01:46 AM
  17. dikman's Avatar
    Had to go out for a while (wife doesn't understand how important this is!). Got RP6, ran it but it comes back with (quit, restart to retry) and jailbreak failed.

    3rd attempt it said "jailbreak complete" and left the phone with a white screen. Ran TinyU, still can't see any device. Phone eventually reverts to black screen.

    If I'm right in believing that it has 4.1 installed, and the updates have failed, then that would explain why RC6 can't jailbreak it (wrong firmware?).

    Still have the same problem, phone in permanent DFU and TinyU can't see the device.

    Next day. Tried it on a different computer, same software/versions, returned error 28 but RC6 just hung when I ran "jailbreak".

    Got any more ideas?
    Last edited by dikman; 2011-02-15 at 11:12 PM. Reason: Automerged Doublepost
    2011-02-15 11:12 PM
  18. Simon's Avatar
    Error 28 is normally a hardware issue I believe.
    2011-02-16 12:13 AM
  19. dikman's Avatar
    According to Apple, yes, that's why I tried a different computer. Another thread had similar issues, and they found that disconnecting the battery apparently cleared some corrupted data? Anyhow, just tried that and it came back with error 1600 this time.
    2011-02-16 01:29 AM
  20. Simon's Avatar
    Another hard error to get around. Not having much luck unfortunately.
    2011-02-16 01:48 AM
1,465 ... 17252627282937 ...
LINK TO POST COPIED TO CLIPBOARD