1. Mysterion's Avatar
    How I downgrade using shsh blob for 4.2.8 saved on Cydia on my iPhone 4 Verizon? Tiny Umbrella not opening up on computer. My iPhone currently on 4.2.9 not jailbroken.
    2011-07-23 11:32 AM
  2. Simon's Avatar
    Why isn't tiny umbrella opening? Do you have Java installed?
    2011-07-23 05:10 PM
  3. heuij's Avatar
    I've gone through the last 20 pages of this thread, but am stuck and would appreciate any help.
    I have an AT&T iPhone 4, running 4.2.1, jailbroken. Wanted to upgrade to 4.3.3. Checked Cydia, saw I had 4.3.3 blobs stored, used TU to save locally. Downloaded from Redmondpie the stock 4.3.3 fw.
    Tried to restore to 4.3.3 in iTunes, with TU running and NOT pointing to Cydia. Got 1013 error. Tried it with TU pointing to Cydia. Same error. Tried it without TU running. Same error. Manually edited Hosts file to comment out all gs.apple redirects. Same 1013.
    Went into DFU mode and started TU and tried "Fix Recovery". No joy.
    Found a FAQ that suggested I needed fixrecovery43.exe to break out of this loop. Downloaded, extracted, but it won't run because zlib1.dll is missing?
    I'm on a Windows 7 (64 bit) machine and I do not care about preserving my baseband as I do not need/want the unlock.
    Thanks in advance for any help/enlightenment!

    UPDATE: OK, found a site (jaxov.com) that explained my situation exactly and pointed to a link to download the missing .dll file. Once downloaded (and placed in the same folder as fixrecover43.exe), I was kicked out of the loop and had an iPhone updated to 4.3.3 and ready for restoring my backup. Hope that helps anyone else having the same problem

    I am trying the exact same thing on a mac, but keep getting 1013 error with iphone 4. I do have SHSH in TU. Started TU and then restored in DFU in itunes. Have removed the gs.apple.com line in hosts file (keeps coming back BTW), but so far only 1013 error. Any help would be greatly appreciated!
    2011-07-23 06:39 PM
  4. Simon's Avatar
    That error is normal. You need to use tiny umbrellas fix recovery button after getting that error.
    2011-07-23 07:53 PM
  5. Mysterion's Avatar
    Why isn't tiny umbrella opening? Do you have Java installed?
    yeah the newest update of it. It says some words in a black box then it doesnt open up.
    2011-07-23 10:33 PM
  6. hurstolds83's Avatar
    Ok I'm way behind on restoring. This is first time I needed to restore to a firmware that wasn't still being singed. I'm trying to restore 4.3.3 I have shsh on cydia also from TU. My baseband is already 4.11 I don't need to preserve the baseband. So if I make a custom IPSW with snowbreeze then shift+restore in iTunes in a pwned dfu, do I need to mess with hosts file or TU? Any help here for a noob at these restores. Thanks in advance.
    2011-07-24 01:04 AM
  7. Simon's Avatar
    Ok I'm way behind on restoring. This is first time I needed to restore to a firmware that wasn't still being singed. I'm trying to restore 4.3.3 I have shsh on cydia also from TU. My baseband is already 4.11 I don't need to preserve the baseband. So if I make a custom IPSW with snowbreeze then shift+restore in iTunes in a pwned dfu, do I need to mess with hosts file or TU? Any help here for a noob at these restores. Thanks in advance.
    Yes, you still need to either set your hosts to cydia or use tiny umbrella.
    2011-07-24 03:27 AM
  8. Mysterion's Avatar
    I didnt save shsh blobs for 4.2.8 on TinyUmbrella. I used Cydia app iSHSHit to save the shsh before I upgraded to 4.2.9. How do I get TinyUmbrella to pick up the .shsh file?
    2011-07-24 10:01 AM
  9. Simon's Avatar
    I have never used that app so not too sure but I am guessing it uploads your SHSH to cydia assuming it wasn't too late to save 4.2.8 SHSH when you did it. If that is the case then you should just need to set your hosts to cydia and you should be able to dfu restore to 4.2.8.
    2011-07-24 04:30 PM
  10. hurstolds83's Avatar
    Yes, you still need to either set your hosts to cydia or use tiny umbrella.
    Worked flawlessly. Thank you so much. Used snowbreeze to make custom ipsw. Some reason stock firmware would go fine get the 1013 or 1015 error but tinyumbrella doesn't play nice with vista x64. Custom firmware in a pwned dfu gave no errors restored all the way through.
    I thought I would get blobs from iFaith make a stock ipsw but it doesn't seem to like vistax64 either. I hate vista blah
    2011-07-24 06:07 PM
  11. Tylus's Avatar
    I've got 2 of the iphone 4's (GSM) that were on 4.1.2 jailbroken.

    I upgraded 1 phone to 4.3.3 and jailbroke again no problems.

    the 2nd phone refuses to update the 4.3.3. Itunes errors out with Error code 19. I turned off AVG and tried again. No luck. I eventually gave up and just did the full upgrade to 4.3.4 since I don't care about Unlock and saving the baseband.

    Both phones have SHSH blobs saved from 4.1 through 4.3 (according to TU). I am now trying to Downgrade the phone to 4.3.3 from 4.3.4...but it keeps giving me the Error code 20, or code 3194. Any help?
    iPhone 4G 32 GB (2 of them)
    OS 5.0.1
    JB Utility: redsn0w 0.9.10b1
    2011-07-25 07:46 AM
  12. Mohirockz's Avatar
    It showed error 1013!
    help me out!
    2011-07-28 10:07 PM
  13. acheung456's Avatar
    Great writeup! I was just downgrading my 6.15bb/4.3.5 to 4.1, had the blob and followed the instruction. Got error (20), TU picked up a recovery device, so I clicked 'Exit Recovery' and the device seems to be booting, it has the apple boot logo. But it's been booting for quite some time now, about a half hour and at one point flashed, and came back on to the boot screen. Looks like its stuck in a boot cycle, any ideas?
    2011-08-04 11:21 PM
  14. Simon's Avatar
    Make sure that tiny umbrella is registering that you have the 4.1 SHSH saved. After that I would suggest using a custom 4.1 firmware made with pwnage tool or snowbreeze and restore to that.
    2011-08-04 11:32 PM
  15. acheung456's Avatar
    Make sure that tiny umbrella is registering that you have the 4.1 SHSH saved. After that I would suggest using a custom 4.1 firmware made with pwnage tool or snowbreeze and restore to that.
    I tried entering DFU mode, then 'Fix Recovery' which brought me to the limera1n exploit and initialized greenpoison which hung after not locating a few files. I entered DFU mode and tried the restore, which made it to the end then gave me the 1015, I tried TU to exit recovery and RecBoot but neither work, the device just reconnects in recovery mode.

    And TU does recognize the 4.1 SHSH. I suppose I will try making a cfw with pwnage/snowbreeze
    2011-08-04 11:49 PM
  16. Simon's Avatar
    Open tiny umbrella
    Click on advanced
    deselect the box that says "set hosts to cydia on exit"
    Close tiny umbrella and try restoring to the custom 4.1 firmware made with pwnage tool or snowbreeze.
    2011-08-04 11:55 PM
  17. acheung456's Avatar
    Open tiny umbrella
    Click on advanced
    deselect the box that says "set hosts to cydia on exit"
    Close tiny umbrella and try restoring to the custom 4.1 firmware made with pwnage tool or snowbreeze.
    I started over clean and put the phone into DFU before starting the restore to stock 4.1 in iTunes, it did the trick ran through with a 1015 and TU was able to kick it out, phone finished the restore and im up on 4.1. Thanks for all the help, you are truly a saint =D
    2011-08-05 12:17 AM
  18. Simon's Avatar
    2011-08-05 12:22 AM
  19. doctorvik's Avatar
    Hey wondering if anyone can help me out ... I have 2 iPhone 4's both were jailbroken - one on 4.32 and one on 4.31. One went through a safe mode cycle so I had to restore and one was having battery issues so I had to restore -- I have my blobs saved (they show on tinyumbrella - but was unable to restore following the instructions provided -- kept getting error 1013 on both phones and had to update (after a vicious dfu loop that would not kick out with tiny umbrella fix recovery -- I had to use a diff computer to trick apple to update my ios to 4.35 for both phones) - now I am stuck on 4.35 but afraid to try anything because of the problems I had getting out of the loop.
    I am using a mac and have the latest iTunes and Tiny Umbrella installed -- any thoughts or help would be appreciated ...
    2011-08-09 02:35 PM
  20. Simon's Avatar
    2011-08-09 03:38 PM
1,465 ... 34424344454654 ...
LINK TO POST COPIED TO CLIPBOARD