User Tag List

  1. Simon's Avatar
    This guide is for people wanting to use tiny umbrella to restore to firmwares Apple is no longer signing.

    Currently Apple is signing:

    Using tiny umbrella is mainly for iPhone 3GS/4, ipod touch 3G, and iPad since you do not need SHSH for previous devices (although there is a soft SHSH being done on iPhone 3G for 4.0 and up firmwares now but that can be easily avoided by using redsn0w then pwnage tool). For this to work you NEED to have your SHSH for the firmware you are trying to restore to. If you do not then tiny umbrella will not help you restore to that firmware.
    If you have never saved your SHSH before just give tiny umbrella a try, you may find you have SHSH after all, it doesn't hurt to check

    A new version of tiny umbrella is available from the link below. The developer has added a lot of new features and overhauled the UI. Click the link to check the changes and get the latest version. You can also read about the changes here:

    Also for anyone looking to use tiny umbrella to preserve baseband, that feature only works on iPhone 4. It cannot preserve baseband for iPhone 3G/3GS. Use pwnage tool or sn0wbreeze for them.

    If you are trying to preserve baseband on iPhone 4 going to 4.2.1 see here:!/notcom/status/33338499377659904

    1. Do a backup in iTunes first.

    2. Download the latest tiny umbrella from: The Firmware Umbrella . I would recommend you reading what the developer has written on there and in his readme file about his tool. It is very informative and he explains what is going on and any errors that you may come across when using tiny umbrella.

    3. Run tiny umbrella (on windows right click then choose run as administrator). Tiny umbrella will not show your SHSH automatically, you have to download them from cydia first. To do this click "Save my SHSH", this will download all available SHSH for your device from cydia. You should save your SHSH twice, once with the box under advanced that says "Request SHSH from cydia" checked and once with it unchecked. If you never used tiny umbrella when apple was signing that specific firmware or pressed the "make my life easier" button in cydia then it may come back with an error saying there is no SHSH, if that is the case I am sorry but that means that you will not be able to restore to that firmware. You can check what SHSH you have on file with cydia by opening cydia, the first page at the top will tell you what firmwares your device can restore to. As far as SHSH go it does not matter what firmware is on the device itself. It only matters as to what firmware apple was still signing at the time you pressed “make my life easier” in cydia or saved your SHSH with tiny umbrella. Even if you are still on 3.1.3 you cannot get your SHSH now since Apple is not signing that firmware anymore. Likewise even if you are on 3.1.3 you can get your SHSH for the current firmware now since that is the firmware Apple is currently signing.

    4. To restore simply press “Start TSS Server” then open itunes, hold down shift(windows) or option(mac) then press restore (tiny umbrella only supports restore not update). A window will open where you can choose the firmware that you want to restore to. You can download firmwares from here: IPhone Firmware Download Links - ModMyi - Wiki or here iPod, iPhone and iPad Firmware Download
    It is best to use a browser like firefox to download the file as other browsers may download it as a .zip file when it is supposed to be .ispw. If that happens simply rename the extension from .zip to .ipsw. Firefox and other browsers do not have this issue. Also if you get a 3002 error put the iphone in dfu mode first then try the restore. To put it in dfu mode: plug in the iphone, then hold the power button and home button together for exactly 10 seconds, then release the power button while continuing to hold the home for an additional 10 seconds or until your computer and itunes recognizes it. iTunes will see it as being in restore mode, the screen of the iphone should be all black.

    5. If near the end of the restore process you get error 1004 or 1015 do not panic it is expected. Just use the “Exit recovery” button if you restored to firmware 4.1 or lower or use the "Fix Recovery" button for firmware 4.2.1 or higher, and your device should boot up. If that doesn’t work you can download recboot from here to boot your device: Fix iPhone Recovery Mode Loop - Works On iPhone 4 & Windows 7

    If you are unable to get out of recovery with tiny umbrella's "exit recovery" or "fix recovery" then I suggest restoring to custom firmware made with pwnage tool or snowbreeze to get around error 1004/1013/1015.

    6. From here you should be good to use your jailbreak of choice. There is a link below that can tell you what options you have to jailbreak depending on what firmware and what device you are on.


    Tiny umbrella seems to sometimes have issues on windows 64-bit so if you are getting unexplained errors, try a different computer that has windows 32-bit or use a Mac.

    If you are getting error 13 it is because you don't have at least itunes 9.2 installed. iTunes 10 will also work just fine for this guide.

    Tiny umbrella needs port 80 to work, skype uses port 80 which can cause some problems. So close skype when using Tiny Umbrella (Thanks packman911 for the info)

    To check what other things might be using port 80 go here: How to Check and Identify Which Application is Listening or Opening Port 80 and 443 on Windows My Digital Life if you find other things running that are using port 80 close those processes for now in task manager then try running the tiny umbrella server again and restoring. The newer versions of tiny umbrella will actually tell you when you open it if there is something blocking port 80.

    If you are having trouble using tiny umbrella's TSS server to restore you can always just click on advanced, select the box that says "set hosts to cydia on exit" and then close tiny umbrella. This will set your hosts to cydia so that itunes will get your SHSH from there allowing you to restore to a firmware that you have SHSH for.

    More info about SHSH can be found here: and
    A quick reference guide to let you know if you are jailbreakable can be found here:

    To check if you can unlock see here:

    How to find your ECID manually if you are stuck in DFU and need to manually input your device into tiny umbrella: Windows Mac

    Since 5.0 Apple is using a new nonce based SHSH for iDevices. What this means is that to restore to 5.X firmware using SHSH you cannot simply run the TSS server anymore. Now you have to pre-stitch your SHSH into the firmware you want to restore to. iFaith or redsnow can both do this (Redsnow under extras/SHSH/Stitch). Once you make the stitched firmware you need to enter pwned DFU with redsnow or iFaith and then shift/option restore to that firmware in iTunes.

    IMPORTANT: If tiny umbrella is unable to save your SHSH then you can try iFaith or redsnow to extract your SHSH from whatever firmware you are currently on. So if your device is on 5.0.1 you can get those SHSH with iFaith or Redsnow. This currently only works for the A4 and lower devices (no 4S or iPad 2).
    Any feedback on what I may have left out is appreciated.
    Last edited by Simon; 2014-09-26 at 03:13 PM.
    2010-08-22 07:19 PM
  2. Simon's Avatar
    As Packman911 said in another thread it is probably a good idea to do a backup in iTunes first.
    Last edited by Simon; 2010-09-04 at 03:41 PM.
    2010-08-25 07:18 PM
  3. Soki's Avatar
    I'm receiving a 1603 error no matter how many times I try. I used custom firmware and normal firmware. i tried in recovery mode and normal. ipod won't even turn on...

    Oh, nvm...Itunes finally recognized it after 5 minutes and its back to normal...

    So, how do I go about fixing the issue with the 1603 error?

    I've also tried this:
    Go to this site to download the 3gs 4.0 ipsw :
    iClarified - iPhone - Where To Download iPhone Firmware Files From
    If you are using pc, go to | Jailbreak your iPod touches and iPhones to download snowbreeze 1.7.
    Build your custom firmware.
    Put your Iphone into recovery mode
    Shift + Restore to the created cfw
    Once restored, you are already jailbroken, activated iphone.
    Install Ultrasn0w to unlock again.
    That is it.
    For all future upgrades and downgrades , always use custom firmware. Remember when restoring to custom firmware, you must always put your iphone into recovery mode , so no error will pop out.
    The benefits of old bootrom is you do not need to edit your hosts file because cfw bypasses all shsh file and you can customize your build when creating cfw.
    I currently have a jailbroken (using Spirit) Ipod Touch 3g with 3.1.3 firmware and trying to get it to 4.0 firmware. I do have the MC model if this means anything. I do believe I have SHSH saved just as stated above in which I have no idea what this does and Snowbreeze tells me that the firmware is invalid when trying in Simple Mode, but works in Advanced Mode. I also tried different ports on my Windows Vista, but receiving the same 1603 error code.
    Last edited by Soki; 2010-08-26 at 01:51 PM.
    2010-08-26 01:45 PM
  4. Simon's Avatar
    You cannot load a custom firmware onto an ipod touch 3g. If you are currently jailbroken open cydia and tell me what SHSH it says you have.
    2010-08-26 01:56 PM
  5. Soki's Avatar
    Oh, I had no idea, but gives me the same error using the Apple 4.0 firmware...

    I have 3.1.3, 4.0, and 4.0.2 SHSH

    File name is: iPod3,1_4.0_8A293_Restore
    2010-08-26 09:30 PM
  6. Simon's Avatar
    You are getting a 1603 error when trying to restore to stock 4.0? Are you running the tiny umbrella server when you are trying? Have you tried from dfu mode?
    2010-08-26 09:54 PM
  7. Soki's Avatar
    I'm trying to upgrade to 4.0fw...nothing fancy...

    I've tried using the tiny umbrella.
    I turned on tiny umbrella and had the TSS server running and obviously it works since I was stuck in recovery mode due to the error (causing Itunes to doing nothing to the ipod touch) and it can kick me out with that button, but nothing happens to my ipod touch and it goes back to the way it was before I put it in Recovery Mode.

    It worked! :]

    How do I get my SHSH back up?

    Thanks for the help!
    Last edited by Soki; 2010-08-26 at 10:17 PM.
    2010-08-26 10:03 PM
  8. Backslash786's Avatar
    Why can't irestore from 3.1.3 to 4.0? I have shsh and everything, using this method as soon as I get to the bit where it does verification with apple or something from iTunes the restore fails?get an error and phone is still 3.1.3? Also does not work in dfu mode too . Can anybody help me please?
    Last edited by Backslash786; 2010-08-27 at 07:46 PM.
    2010-08-27 07:44 PM
  9. Simon's Avatar
    what error are you getting?
    2010-08-27 08:06 PM
  10. Backslash786's Avatar
    I don't know it was error 1015 I think can't remember
    2010-08-27 08:42 PM
  11. Simon's Avatar
    And did it happen near the end of the restore process or right at the beginning?
    2010-08-27 08:55 PM
  12. Welshy1969's Avatar
    thanks bud for the tutorial , helped me out big time .. thanks again
    2010-08-27 10:01 PM
  13. Backslash786's Avatar
    And did it happen near the end of the restore process or right at the beginning?
    Beginning when it verifies with apple.
    It's a mc model if that makes a difference
    2010-08-28 12:00 AM
  14. Simon's Avatar
    Hmmm.... Strange error to get at beginning of a restore. I see you have a iphone 3G is this the one you are trying to do this on?
    2010-08-28 12:03 AM
  15. Backslash786's Avatar
    Hmmm.... Strange error to get at beginning of a restore. I see you have a iphone 3G is this the one you are trying to do this on?
    Nope 3gs

    I edited hosts and tried it that way didn't work too

    do you have to do it in dfu mode? I tried that too
    2010-08-28 12:29 AM
  16. burnout399's Avatar
    its trying to verify the OS install with the apple servers.

    if you have the SHSH on the cydia server.
    edit the host file and add this:

    now do the restore through itunes(put the ipod in DFU mode, not recovery mode)

    at the end, you will get an error in itunes, but it did install the new OS. Then use tiny umbrella button, to kick the device out of recovery mode.

    the ipod will boot, and should be all good
    2010-08-28 12:48 AM
  17. Backslash786's Avatar
    It does not get past the verification bit still
    2010-08-28 02:11 PM
  18. Simon's Avatar
    Try to use a different computer if you can
    2010-08-28 02:26 PM
  19. Backslash786's Avatar
    Il try on laptop tonight see if it makes a difference
    2010-08-28 02:30 PM
  20. MindGem's Avatar
    STILL NOT F*CKING WORKING! I do as you say, have SHSH saved on 3.1.2 and try to downgrade but then i get error 3194!
    2010-08-28 03:20 PM
1,465 1231151 ...