1. Jas169's Avatar
    Hey guys.. I hit the erase content on my jailbroken unlocked iPhone 3GS 4.0.1 and now it's stuck at apple logo . If I restore from iTunes it will go to 4.1 and that is not good as no unlock..
    I tried tinyumbrella but they save SHSH option is greyed out n I edited host file also to restore from my previous 4.0.1 version by doing shift+ restore but error 3194 keeps comin up.. I tried a lot if things.. I need help .. Please
    2010-09-15 02:45 AM
  2. Hokman's Avatar
    put into DFU mode and shift restore the 4.0.1 original firmware you can download from modmyi

    did you save your shsh blobs on cydia before?
    2010-09-15 05:12 AM
  3. Jas169's Avatar
    I already have 4.0.1 firmware and I did shift restore but it gives error 3194 .. Plus I also did the host file edit..
    And I dint save SHSH ever before n now in tinyumbrella the save SHSH option is greyed out!
    2010-09-15 05:21 AM
  4. iYeow's Avatar
    Grab it from Cydia to see if you can get any shsh, click Advance option to so that
    2010-09-15 06:12 AM
  5. Jas169's Avatar
    Went to advance options but ECID column is blank.. What do I put there or where do I get that from?? Thanks
    2010-09-15 06:23 AM
  6. iYeow's Avatar
    You have to plug in your iphone
    2010-09-15 06:31 AM
  7. Jas169's Avatar
    Lol.. It's plugged in but ECID ain't showing..
    2010-09-15 06:37 AM
  8. iYeow's Avatar
    If you iphone is not in bootable state then TU cannot see it. Alright you can find out yourself, download USBview, run it as your state of iphone in recovery/DFU mode. Click option and select config decriptor and hit refresh.
    Then scroll down to see the apple device connected and click right pane, search over there , you will find your ECID 16 digis.
    Write it down , it is the ECID for your iphone, always the same.
    2010-09-15 06:50 AM
  9. Jas169's Avatar
    I got the ECID code and put it in TU.. Now when I hit save SHSH.. it gives error that I am too late. Any way out of this ??
    2010-09-15 07:28 AM
  10. eyeRobot's Avatar
    Did you go into advanced options and try to grab 3GS 4.0.1 from cydia? If it says you are too late then you are too late.

    Did you check for other SHSH for other firmwares? Which ones have you got stored?
    2010-09-15 07:46 AM
  11. iYeow's Avatar
    Yeah, if after Westoben's guide, you still cannot grab any shsh , then you are right, you are too late.
    2010-09-15 07:55 AM