1. i.Annie's Avatar
    UPDATE 8/1/12: FINISHED (for now).

    *Redsn0w for iOS 5 can create custom firmwares. If you need to preserve your baseband, make a custom firmware to restore/upgrade and jb simultaneously. Custom firmwares can also be made with alternative tools such as Sn0wbreeze (for Windows) and PwnageTool (for Mac). Redsn0w is available for both Mac and Windows.*

    NOTE:
    Restoring/upgrading/downgrading to any iOS 5 fw versions that are not currently being signed by Apple either with stock of custom firmware requires stitching the fw with available SHSHs (this does mean TinyUmbrella is not needed) is required. You can do so with Redsn0w or iFaith.


    iPhone 4S
    iOS 5.1.1 Untethered; Absinthe/Redsn0w/Rocky Raccoon in Cydia if already JB as tethered
    iOS 5.1 Tethered; Absinthe
    iOS 5.0.1 Untethered; Absinthe
    iOS 5.0 Untethered; Absinthe

    iPhone 4 GSM
    iOS 5.1.1 Untethered; Redsn0w/Absinthe
    iOS 5.1 Tethered; Sn0wbreeze/Redsn0w
    iOS 5.0.1 Untethered; Sn0wbreeze/Redsn0w (Corona in Cydia will untether w/o restore and reJB if already on tethered JB)
    iOS 4.3.4/4.3.5 Tethered; Sn0wbreeze/PwnageTool/Redsn0w
    iOS 4.3.3/4.3.2/4.3.1/4.3 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version: Redsn0w/Jailbreakme
    iOS 4.2.1 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/recent version of Greenpois0n/Limera1n
    iOS 4.1 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/Older version of Greenpois0n/Limera1n
    iOS 4.0.2/4.0.1/4.0 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/Limera1n

    iPhone 4 CDMA (Verizon)
    *Note: There are some extra steps necessary with PwnageTool (Mac) including downloading the right bundles and whatnot, you could do so and follow guides (Google!) to do so but I won't put them in the list just bc it isn't so "noob-friendly" for now.*
    iOS 5.1.1 Untethered; Redsn0w/Absinthe
    iOS 5.1 Tethered; Sn0wbreeze/Redsn0w
    iOS 5.0.1 Untethered; Sn0wbreeze/Redsn0w (Corona in Cydia will untether w/o restore and reJB if already on tethered JB)
    iOS 5.0 Tethered; Redsn0w; Sn0wbreeze
    iOS 4.2.10/4.2.9 Tethered; Sn0wbreeze (need SHSHs)/Redsn0w (already on fw version)
    iOS 4.2.8/4.2.7 Untethered; Sn0wbreeze (need SHSHs)/Redsn0w or Jailbreakme (already on fw version)
    iOS 4.2.6 Untethered; Sn0wbreeze (need SHSHs)/Redsn0w or Jailbreakme or Greenpois0n (already on fw version)

    iPhone 4 CDMA (Sprint)
    iOS 5.1.1 Untethered; Redsn0w/Absinthe

    iPhone 3GS (old boot is never tethered)
    iOS 5.1.1 Untethered; Redsn0w/Absinthe
    iOS 5.1 Tethered; Sn0wbreeze/Redsn0w
    iOS 5.0.1 Untethered; Sn0wbreeze/Redsn0w (Corona in Cydia will untether w/o restore and reJB if already on tethered JB)
    iOS 5.0 Tethered; Sn0wbreeze/Redsn0w
    iOS 4.3.4/4.3.5 Tethered; Sn0wbreeze or PwnageTool (need SHSHs)/Redsn0w (already on fw version)
    iOS 4.3.3/4.3.2/4.3.1/4.3 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version: Redsn0w/Jailbreakme
    iOS 4.2.1 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/recent version of Greenpois0n/Limera1n
    iOS 4.1 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/Older version of Greenpois0n/Limera1n
    iOS 4.0.2/4.0.1/4.0 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/Limera1n
    iOS 3.1.3/3.1.2 Sn0wbreeze/Pwnagetool/Redsn0w/Spirit/Jailbreakme
    *Note: I'm stopping here. If you have a device with an even older fw version than this, you should upgrade if you have SHSHs saved for 4.2.1+. If you don't, you can achieve jailbroken 4.1 without SHSHs. Also, if you have the old boot (359.3) you can go to iOS 5 untethered. If you have new boot, you can have a tethered (semi-tethered with the Cydia tweak) iOS 5.*

    iPhone 3G
    iOS 4.2.1 Untethered; custom FW - Sn0wbreeze/PwnageTool; already on FW version - Redsn0w/recent version of Greenpois0n/Limera1n
    iOS 4.1 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/Older version of Greenpois0n/Limera1n
    iOS 4.0.2/4.0.1/4.0 Untethered; custom FW - Sn0wbreeze/PwnageTool (need SHSHs); already on FW version - Redsn0w/Limera1n
    iOS 3.1.3/3.1.2 Sn0wbreeze or Pwnagetool/Redsn0w/Spirit/Jailbreakme
    *Note: I'm stopping here. If you have a device with an even older fw version than this, you should upgrade to 3.1.3. You may want 4.2.1 which is also doable without SHSHs, just like 3.1.3. 4.2.1 may be a bit laggy compared to 3.1.3, but it is doable (for some people, depending on preference and app dependency).*

    iPhone 2G
    *Note: You should be on 3.1.3 (max fw version available for this device) so anything lower isn't worth it, IMO. So upgrade if you haven't already. *
    iOS 3.1.x Sn0wbreeze/Pwnagetool/Redsn0w/Spirit/Jailbreakme

    --------

    For specific steps on how to upgrade/downgrade/restore, view my other guide. It's located HERE.

    This is a fantastic write-up of jailbreak terms that you should understand and be aware of anyway, and it will certainly help you understand the jb world better.

    PLEASE READ THIS! CLICK HERE!
    Last edited by i.Annie; 2012-08-02 at 12:15 AM.
    2010-09-18 07:46 PM
  2. kyteflyer's Avatar
    Nice work. Hopefully it will stop a lot of the questions which occur...
    2010-09-18 11:41 PM
  3. i.Annie's Avatar
    That's the goal
    2010-09-19 12:34 AM
  4. kromix's Avatar
    I have a question for you.... Thanks alot for this, helps us new guys....

    I have: iphone 3GS 3.1.3 (Oldbootroom)

    Unlocked/Jailbroken using Jailbreakme.com + ultrasn0w

    It says on your guide, Restore without SHSH custom firmwares can be used, but only if already jailbroken.

    Would this then apply to me? can I use a custom firmware to restore to 4.0.1 or even restore to what im already on 3.1.3 ?? If so, how?
    2010-09-19 02:30 AM
  5. Simon's Avatar
    You cannot use a custom firmware if jailbroken by jailbreakme.com. It has to be from a bottom jailbreak such as redsn0w, blackra1n, pwnage tool, sn0wbreeze.
    2010-09-19 03:11 AM
  6. kromix's Avatar
    Here's another question then, since im on 3.1.3 and sn0wbreeze works on it, can I re-jailbreak with sn0wbreeze or is it a 1 time deal since I used jailbreakme.com I'm stuck with it?
    2010-09-19 03:14 AM
  7. Simon's Avatar
    If you have SHSH then you can restore to 3.1.2 use blackra1n then you can use a custom ipsw. It all depends on what SHSH your device has as to what you can do.
    2010-09-19 03:21 AM
  8. iYeow's Avatar
    I can answer this, I wouldn't call myself an expert but i have been using Custom Firmware all along. If you can jailbreak with Snowbreeze, then you can always use Snowbreeze or Pwnage tools as long as you stay away from Stock Firmware.
    Custom Firmware will not flash your Baseband and therefore, as the Baseband is not touched everytime you do a restore, you can restore as many times as you want.
    If your Baseband somehow gets corrupted, like losing signal or No signal, then you will have to restore to Stock Firmware again and then do the respective jailbreak before proceeding to Custom Firmware.
    Last edited by iYeow; 2010-09-19 at 03:37 AM.
    2010-09-19 03:30 AM
  9. Bo Troxell's Avatar
    Nice job Annie. I have stuck this thread so it will be easy for members to find and view.
    2010-09-19 03:37 AM
  10. kromix's Avatar
    Nope, I don't have any SHSH's saved (well except for the current 4.1...)
    2010-09-19 03:51 AM
  11. slambo's Avatar
    I just got my new iPhone 4 FW 4.1 (posting with it right now) and according to the guide I'm jailbreakable on jailbreakme.com, but according to the site nothing past 4.0.1 is doable yet. Thoughts?
    2010-09-19 04:18 AM
  12. i.Annie's Avatar
    I just got my new iPhone 4 FW 4.1 (posting with it right now) and according to the guide I'm jailbreakable on jailbreakme.com, but according to the site nothing past 4.0.1 is doable yet. Thoughts?
    That's correct. Jailbreakme works only up to 4.0.1.
    2010-09-19 06:14 AM
  13. koooomar's Avatar
    Your PDF shows iphone4 4.0.2 is jailbreakable by jailbreakme.com !!

    Is it ? I'v iPhone 4 4.0.2 waiting for jailbreak.
    2010-09-19 07:01 AM
  14. i.Annie's Avatar
    Sorry, must've been a mistake. I'll fix it.

    Edit: everything under the 4.0.2-4.1 for iPhone 4 is "NO". So sorry again, you can't JB or unlock.
    Last edited by i.Annie; 2010-09-19 at 07:09 AM. Reason: Automerged Doublepost
    2010-09-19 07:09 AM
  15. slambo's Avatar
    Sorry, must've been a mistake. I'll fix it.

    Edit: everything under the 4.0.2-4.1 for iPhone 4 is "NO". So sorry again, you can't JB or unlock.
    Awesome, thanks so much. I did a quick check before buying and trusted your pinned tread.

    Oh well, guess I get to wait now, wonder how long.
    2010-09-19 07:47 AM
  16. Simon's Avatar
    Nice post Annie, very quick guide for new people to see what options they have. If you wouldn't mind I would like to put a link to this in the post I put up a couple days ago.
    2010-09-19 02:34 PM
  17. i.Annie's Avatar
    Ok, the file has been updated. The mistake has been removed.

    Nice post Annie, very quick guide for new people to see what options they have. If you wouldn't mind I would like to put a link to this in the post I put up a couple days ago.
    I don't mind at all
    Last edited by i.Annie; 2010-09-20 at 12:28 AM. Reason: Automerged Doublepost
    2010-09-20 12:28 AM
  18. iYeow's Avatar
    Congrats Annie, you made it to the top, Sticky..
    2010-09-20 12:30 AM
  19. korin125's Avatar
    Great thread to be stickied, but shouldn't all stickied threads from 2 years ago be un-stuck by now?
    2010-09-20 12:36 AM
  20. i.Annie's Avatar
    Great thread to be stickied, but shouldn't all stickied threads from 2 years ago be un-stuck by now?
    Or updated at least... I plan to update this with new FW and jailbreak releases
    2010-09-20 01:34 AM
566 12311 ...
LINK TO POST COPIED TO CLIPBOARD