1. ch3w84cc4's Avatar
    Hi everyone,

    First of all I have tried reading through the stickies and I am left scratching my head a little so apologies first of all if this is a really stupid question.

    I have 3.0 on my system which was jb with Blackra1n when it first came out. I have cydia backed up from 3 - 4.1.

    I was told that first I need to update to 3.12 before I can go up to 4, however when I try and upgrade to 3.12 Itunes wont let me.

    So I added the line in my host file and tried again and the problem I have is that itunes only gives the option to restore and update. That was with Itunes 10, so I tried reverting back to 9.1 and I still have the same problem.

    So is the solution the same as with downgrading? Or is there an easier way?

    The 3.12 is a custom IPW I have downloaded.

    So once again apologies for my N00bness but at least I tried to look at the different posts.
    2010-09-19 02:23 PM
  2. Simon's Avatar
    Since you are already jailbroken with a custom ipsw, you just need a custom 4.0 and you should be able to shift-click restore to that. You can use sn0wbreeze to create a custom 4.0 on windows.

    edit: Sorry read that wrong, you are on 3.0 jailbroken with blackra1n right? Do you have to run blackra1n every time you reboot (I doubt you do because I dont think the new bootrom 3GS came out untikl 3.1 was released). If you don't have to run blackra1n every time you reboot then you should be good to restore to a custom 4.0. It is always best to make your own custom ipsw, there may be something wrong with that 3.1.2 one you downloaded.
    Last edited by Simon; 2010-09-19 at 03:23 PM.
    2010-09-19 03:18 PM
  3. ch3w84cc4's Avatar
    Thanks for the reply. I used blackra1n without a custom ipsw. I did it pretty much when it first came out. The problem I have is that Itunes wont let me do a click and restore. It only lets me do a restore and update and of course I don't want 4.1
    2010-09-19 03:53 PM
  4. Simon's Avatar
    So holding down shift while clicking restore doesn't bring up a window where you can choose your custom firmware?
    2010-09-19 04:14 PM
  5. ch3w84cc4's Avatar
    Exactly! I have tried three different versions of itunes. 10 - 9.1 and all of them only give me the option to restore and update. I can't select anything else.
    2010-09-19 04:21 PM
  6. Simon's Avatar
    You have to click restore while holding down Shift. There isn't a third button. If a window doesn't come up when you do that just unplug your phone before it starts the process or cancel the download.
    2010-09-19 04:32 PM
  7. ch3w84cc4's Avatar
    I didn't say there was a third button. I hold on to shift and click restore and there is only the update and restore option. I have uninstalled and installed three different versions of itunes now and in each case there isn't the option

    Ok it looks like it is an issue with the laptop I was using as I just used my desktop and the option is there. I will try and use sn0wbreze and see how I get on. Thanks for the input
    Last edited by ch3w84cc4; 2010-09-19 at 04:47 PM. Reason: Automerged Doublepost
    2010-09-19 04:47 PM
  8. Simon's Avatar
    Hmm.. that is stange why that is happening on your laptop.
    2010-09-19 05:22 PM
  9. ch3w84cc4's Avatar
    I actually think it is a driver problem. Sods law really as I have now been able to upgrade to 3.12 and will go to 4.01 next. Thanks for the replies though
    2010-09-19 05:25 PM
  10. Simon's Avatar
    2010-09-19 05:35 PM
LINK TO POST COPIED TO CLIPBOARD