1. Kahnbigsby's Avatar
    I have a jailbroken 3Gs with 4.0.1 firmware. It got stuck into restore mode with black screen. My SHSH blobs are saved into cydia as 4.0. I would like to restore my phone without having to upgrading it. I tried the tiny umbrella method as well as the hosts method, but wasn't working. Anyone know how to get it back running?
    2010-09-24 01:24 AM
  2. Simon's Avatar
    http://modmyi.com/forums/general/725...e-restore.html

    You can try my guide here.
    There are a few troubleshooting things you can do down the bottom if you cant get it working first time.
    2010-09-24 01:35 AM
  3. Kahnbigsby's Avatar
    Which FW should I download to restore my phone?
    2010-09-24 01:37 AM
  4. Simon's Avatar
    It doesn't matter, if you have 4.0 SHSH you should have 4.0.1 as well
    2010-09-24 01:40 AM
  5. Kahnbigsby's Avatar
    Tiny umbrella isn't connecting to my phone. Only itunes picks up my phone and says it is in restore mode. The screen is completely black, no apple logo or USB connect to itunes logo either.
    2010-09-24 01:50 AM
  6. Simon's Avatar
    It sounds like you are in dfu mode. Try to kick it out by plugging it in then holding the home and power button until you see the apple logo. It can take up to 30 seconds sometimes.
    2010-09-24 02:27 AM
  7. Kahnbigsby's Avatar
    That doesn't work either.
    2010-09-24 03:02 AM
  8. Simon's Avatar
    Try this to get your ecid manually and type it in tiny umbrella to save your SHSH:
    iClarified - iPhone - How to Find Your iPhone ECID [Windows]
    2010-09-24 03:05 AM
  9. Kahnbigsby's Avatar
    The furthest that gets me is a white screen on my phone, prepare for restore - verified by apple then prepare for restore and verify by apple again and gives me error 28.
    2010-09-24 03:25 AM
  10. Simon's Avatar
    So did you get your ecid using that method and were you able to save your SHSH?
    2010-09-24 03:28 AM
  11. Kahnbigsby's Avatar
    I got my ecid and was able to save my SHSH.

    09/23/2010 21:25:23.252 Asking CYDIA for SHSH blobs for iPhone3GS 4.0.1 (8A306)... 09/23/2010 21:25:33.621 SHSH SUCCESSFULLY saved! [Click Here to Open] 09/23/2010 21:25:33.787 You have saved your SHSH locally and the request was sent to CYDIA. This means that CYDIA DOES have your SHSH. Do NOT bug semaphore about the Cydia home page showing this version. 09/23/2010 21:25:33.991 Caching shsh files... 09/23/2010 21:25:34.178 Found [1] shsh files to cache... 09/23/2010 21:25:34.343 Cached [1] shsh files 09/23/2010 21:26:22.753 TSS Server Started! 09/23/2010 21:26:22.853 Killing iTunes... Restart it to restore your device... 09/23/2010 21:26:22.948 Starting TSS service on port 80 09/23/2010 21:26:23.118 TSS Accepting connections... 09/23/2010 21:27:07.659 TSS Accepting connections... 09/23/2010 21:27:07.765 Received Blob request...
    Last edited by Kahnbigsby; 2010-09-24 at 03:51 AM.
    2010-09-24 03:30 AM
  12. Simon's Avatar
    Wow ok, didn't really need all that pasted .

    Try using another usb slot to restore or even another computer if you can.
    2010-09-24 03:41 AM
  13. iYeow's Avatar
    Wow, I had to scroll until my finger gets tired.
    2010-09-24 03:47 AM
  14. Simon's Avatar
    Some major scrolling huh Not too bad with a magic mouse though.
    2010-09-24 03:49 AM
  15. Kahnbigsby's Avatar
    Lol sorry fellas, I tried with different USB ports. Same error. I'm trying it on a different computer now. Thanks for your help
    2010-09-24 03:52 AM
  16. iYeow's Avatar
    Reboot your pc again .
    Do you have tiny umbrella ? If you do run it , click display shsh to see. If you see that there is 4.0.1 shsh saved in umbrella.
    Click Advanced tab, under device /version : highlight 4.0.1 shsh for 3gs
    If you are in DFU /Recovery mode , that is OK
    click Start Tss Server : It will say connecting.
    Itunes will close , open itunes again, a message will pop up saying you need to restore. Click OK and OK
    Do the Shift + Restore to 4.0.1 ipsw which you must download too .
    You must leave tss server running while you are restoring.

    Get back to me on your progress here
    Last edited by iYeow; 2010-09-24 at 04:06 AM.
    2010-09-24 03:56 AM
  17. Simon's Avatar
    No prob, hope you can get it working. Much easier to read this thread since you edited that post
    2010-09-24 03:56 AM
  18. iYeow's Avatar
    No prob, hope you can get it working. Much easier to read this thread since you edited that post
    I see what I can do for him, he PM me for help.
    2010-09-24 04:03 AM
  19. Kahnbigsby's Avatar
    I need all the help I can get. I am going to reset my comptuer right now, I'm trying it on my desktop now. But yeow, my info doesn't pop up on tiny umbrella when i connect my phone to it. I have to go to advance and stick in my info from there.
    2010-09-24 04:12 AM
  20. iYeow's Avatar
    No, open up tiny umbrella and click display shsh , tell me what you see there. Get back to me after you reboot your pc.

    You have two thread, just use this one, alright. It is very confusing for me to jump back and forth.
    Last edited by iYeow; 2010-09-24 at 04:20 AM.
    2010-09-24 04:17 AM
47 123
LINK TO POST COPIED TO CLIPBOARD