1. hemi_0539's Avatar
    I currently have a iPhone 3GS, running 3.1.3. I used Spirit to jb the phone back in June, and it works fine. i would like to upgrade to 4.x (or 4.1 if the jb works for this newly released firmware). I have been reading online for weeks now and am really confused. Some sites say to use spirit 2 pwn and then use another app to jb, or other say redsn0w, or even the phone based one jailbreakme dot com. what would be the best process to upgrade my phone to a 4.x firmware load and have it jailbroken? Any ideas would help out. Thanks.
    2010-09-24 04:03 AM
  2. Simon's Avatar
    First you need to determine if you have old bootrom or new 3GS. Download iDetector iH8sn0w.com | Jailbreak your iPod touches and iPhones
    This will tell you what bootrom you have and you can go from there.
    2010-09-24 04:09 AM
  3. hemi_0539's Avatar
    i looked at the ih8snow page, but it only shows a windows based program and i have a mac. is there a mac version of that software? or is there another way to determine my boot rom version? thanks for your help.
    2010-09-24 04:16 AM
  4. Simon's Avatar
    2010-09-24 04:19 AM
  5. hemi_0539's Avatar
    Here is my info,

    Apple Mobile Device (DFU Mode):

    Product ID: 0x1227
    Vendor ID: 0x05ac (Apple Inc.)
    Version: 0.00
    Serial Number: CPID:8920 CPRV:15 CPFM:03 SCEP:03 BDID:00 ECID:000003F18618A32E SRTG:[iBoot-359.3.2]
    2010-09-24 04:27 AM
  6. Simon's Avatar
    Ok, that means you have new bootrom. You cannot use spirit2pwn on new bootrom or custom firmware. Your only chance to go to 4.0/4.0.1 and use jailbreakme.com is if you have SHSH for those firmwares. You can use my guide here to see, and if you do to restore and jailbreak: http://modmyi.com/forums/general/725...e-restore.html

    Or just stay where you are and wait for the new jailbreak to come out.
    2010-09-24 04:31 AM
  7. hemi_0539's Avatar
    i ran that tiny umbrella program and below is what was displayed:

    09/23/2010 20:39:32.931 Processing SHSH Request...
    09/23/2010 20:39:32.948 Asking CYDIA for SHSH blobs for iPhone3GS 4.1 (8B117)... 0
    9/23/2010 20:39:38.490 SHSH SUCCESSFULLY saved! [Click Here to Open]
    09/23/2010 20:39:38.539 You have saved your SHSH locally and the request was sent to CYDIA. This means that CYDIA DOES have your SHSH. Do NOT bug semaphore about the Cydia home page showing this version.

    with that said, would i be able to use the 4.1 update that itunes keeps asking me, then run jailbreakme.com? if not, you mentioned to wait for another jailbreak to come out, which one would you be referring to, or wait for a new one to come out? Thanks for your help.
    2010-09-24 04:46 AM
  8. Simon's Avatar
    No, do not update to 4.1, it cannot be jailbroken on your device yet.
    Click advanced in tiny umbrella and change the firmware to 4.0.1 for a 3GS then click save my SHSH and see what it says.
    2010-09-24 04:55 AM
  9. hemi_0539's Avatar
    I tried this and it showed this:

    09/23/2010 20:55:43.097 Processing SHSH Request...
    09/23/2010 20:55:43.121 Asking CYDIA for SHSH blobs for iPhone3GS 4.0.1 (8A306)...
    09/23/2010 20:55:45.737 SHSH SUCCESSFULLY saved! [Click Here to Open]
    09/23/2010 20:55:45.755 You have saved your SHSH locally and the request was sent to CYDIA. This means that CYDIA DOES have your SHSH. Do NOT bug semaphore about the Cydia home page showing this version. 09/23/2010 20:55:45.776 Caching shsh files...
    09/23/2010 20:55:45.818 Found [2] shsh files to cache... 09/23/2010 20:55:45.856 Cached [2] shsh files

    ok, with that said, would the next step be to download the ipsw for 4.0.1 for the 3gs, run tiny umbrella, then run the tss server and then restore it via itunes restore process?
    2010-09-24 05:01 AM
  10. j3st3r's Avatar
    correct, once the restore is done jailbreak with jailbreakme
    2010-09-24 05:05 AM
  11. hemi_0539's Avatar
    thanks for all your help.
    2010-09-24 05:07 AM
  12. Simon's Avatar
    You may have to put it in dfu if still getting errors, but yes that is correct as j3st3r3 said.
    2010-09-24 05:07 AM
  13. hemi_0539's Avatar
    the "start tss server" button is greyed out in tiny umbrella. is there anything that i am missing, does the phone have to be in recovery mode, or dfu mode, or something else?
    2010-09-24 05:24 AM
  14. Simon's Avatar
    Are you running tiny umbrella as admin? When opening it you should right click on it and select run as administrator.
    2010-09-24 05:32 AM
  15. hemi_0539's Avatar
    when i open tiny umbrella in spotlight on mac, it asks for my admin password, then starts up, but says:

    09/23/2010 21:42:08.637 NOT running as administrator OR your hosts file is not editable - Cannot listen on port 80! TSS Server will not work!

    i searched google for the "tss server not working" and found a page saying that i had to add this to my existing host file, 74.208.105.171 gs.apple.com. tried it and rebooted my mac, but it still shows tss server greyed out, is there another ip & host name i need to add?

    nevermind, i read the FAQ on the tiny umbrella site and what i was doing was double clicking on the tiny umbrella icon from the dmg file and running it. it says to drag the dmg file to your desktop or app folder, and it worked. its doing the restore now and looks like its almost done. thanks for the help again.
    Last edited by hemi_0539; 2010-09-24 at 06:09 AM. Reason: Automerged Doublepost
    2010-09-24 06:09 AM
LINK TO POST COPIED TO CLIPBOARD