1. Fmyjob's Avatar
    Trying to help my brothers girlfriend She has a iPhone that I unlocked almost a year ago she wants to upgrade the fw. I'm not sure what the best route to go is

    She has a iphone 3G running fw 3.0(7A341)
    Model MB702LL.
    she has a new computer it has windows 7 64bit
    She has not installed iTunes yet.
    It's is currently jailbroken and unlocked.
    Ssh blobs? I don't know what to do? Don't know what they are?
    2010-10-12 03:50 AM
  2. iYeow's Avatar
    Download Snowbreeze 2.0.2 from iH8sn0w.com | Jailbreak your iPod touches and iPhones and download the official 3g 4.1 ipsw. Download Ireb 4.1 too.
    Build your custom firmware, use Expert mode and under General : uncheck the activate my iphone.
    Build it and it will be placed on your Desktop named Snowbreeze_4.1.ipsw.
    Start your Ireb 4.1 and follow the instruction, online mode, it will help you to put it in DFU mode.
    Now Do the Shift + Restore to Snowbreeze_4.1.ipsw
    Once restored, put your official sim in to trigger to Home Screen.
    Now you are jailbroken at 4.1
    Unlock with Ultrasn0w again .
    2010-10-12 04:07 AM
  3. bellyfrog's Avatar
    Well firstly you will always lose an unlock if you upgrade. But you can just reinstall it from Cydia. Here's what you need to do to get to 4.1 jailbroken and unlocked:

    First upgrade to 3.1.2 stock firmware here: http://appldnld.apple.com.edgesuite....1_Restore.ipsw

    Open iTunes and SHIFT + Restore to that file. If it's an iPhone 3G you don't need SHSH blobs.

    Now jailbreak using redsn0w. Instructions here: Tutorial: Jailbreak iPhone 3.1.2 with RedSn0w 0.9

    Next use snowbreeze to do a custom firmware upgrade to 4.1, instructions here: How to Jailbreak iOS 4.1 with Snowbreeze 2.0.1 [Tutorial]

    You may also need to use iREB to bypass any errors you get from iTunes during the upgrade. Download from iH8sn0w.com | Jailbreak your iPod touches and iPhones

    Finally once you are on 4.1 and jailbroken, open Cydia, do the "essential upgrade" when it asks, then hit search, type ultrasn0w, install that package and voila.

    Good luck

    EDIT - yeows explanation might be better, possibly you don't need to upgrade to 3.1.2 on an iPhone 3G, might only be for 3GS that you need to do this
    2010-10-12 04:07 AM
  4. Bo Troxell's Avatar
    Yup, follow as yeow202 stated, it's the easiest way.
    2010-10-12 04:26 AM
LINK TO POST COPIED TO CLIPBOARD