User Tag List

  1. dustin942000's Avatar
    I jailbroke my iPhone 3G on iOS 4.1 a couple of months ago with sn0wbreeze. Now I would like to upgrade to 4.2.1 but whenever I updated sn0wbreeze it says that the ipsw is invalid but everwhere I look it says sn0wbreeze 2.1 will jailbreak iOS 4.2.1? I don't wanna use redsn0w because my phone goes slower for some reason. Please help
    2010-11-24 05:57 AM
  2. iYeow's Avatar
    Snowbreeze 2.1 is meant to jailbreak ios 4.1 not 4.2.1. You have to go with Redsn0w 0.9.6b4 to jailbreak ios 4.2.1
    2010-11-24 06:13 AM
  3. dustin942000's Avatar
    Snowbreeze 2.1 is meant to jailbreak ios 4.1 not 4.2.1. You have to go with Redsn0w 0.9.6b4 to jailbreak ios 4.2.1
    But I didn't jailbreak with that specific version lol. sorry I am just confused. I know what I'm doing and all that but don't know why it isn't working. I was just going by everyone else saying it could jailbreak 4.2 :P
    2010-11-24 03:30 PM
  4. iYeow's Avatar
    You should downgrade back to 4.1 and even if you can jailbreak successful, all the stuffs in Cydia will not work. The mobile substrate is not updated yet
    2010-11-24 06:42 PM
LINK TO POST COPIED TO CLIPBOARD