1. aleicgrant's Avatar
    I have an iphone 4 on bb 1.59. For the most part, every new firmware and JB has been like a charm for me. But the last few has caused some really weird situations.

    4.3.1 after JB and unlock, phone will operate fine for a few weeks and then suddenly I am not able to get any data with 3g. I spoke to att an all is fine on my account. After a ton of network resets, general resets and reinstall of firmware via tiny umbrella and Redsnow it came back to life.

    Upgrade to 4.3.2. All is good for a little while then today boom, the phone just pukes and no longer can transmit or receive data unless its via wifi. So I go through the same motions and this time no matter what I do I cannot get the 3g back.

    So I decided to try 4.3.3 using tiny umbrella to preserve and of course as with each time the latest version of ultrasn0w

    and as of right now, nothing I have done has been able to restore data. My wife has a Windows 7 phone with 3g and has no issue.

    This is beyond odd. Could I actually have a hardware issue????

    Please help. I would love to hang onto my 1.59 bb phone and not run the genius bar lottery
    2011-05-13 04:39 AM
  2. i.Annie's Avatar
    Could it be something you installed in Cydia? Whenever you restored did you set up as new or you restored from a backup?
    2011-05-13 04:43 AM
  3. aleicgrant's Avatar
    restore from back up. I dont want to lose all my pics, music and videos
    2011-05-13 04:45 AM
  4. i.Annie's Avatar
    Restoring from back up could very well be the culprit. Do you not want to set up as new if you could just back up your photos and videos into your computer and resync them in as a new folder? Of course you can't delete them from your phone anymore as they won't be in the camera roll anymore, but setting up as new and syncing them back in could fix your problem.

    You might want to also double check what you're installing in Cydia every time you've restored to see if anything is causing the block.
    2011-05-13 04:48 AM
  5. aleicgrant's Avatar
    well a restore from new did not solve the problem........I am officially stumped. Only one bar before JB and no 3g svc. After JB, five bars and also no 3g svc.
    2011-05-13 05:56 AM
  6. i.Annie's Avatar
    I'm stumped too. You installed ultrasn0w right?

    Edit: sorry I saw you said bb 1.59.00 and assumed you needed unlock but you said you're on AT&T.

    Now that is weird.

    You install anything with Cydia?
    Last edited by i.Annie; 2011-05-13 at 06:00 AM. Reason: Automerged Doublepost
    2011-05-13 06:00 AM
  7. aleicgrant's Avatar
    nothing just ultrasnow
    2011-05-13 06:01 AM
  8. i.Annie's Avatar
    Hm. You tried it without jailbreaking?
    2011-05-13 06:07 AM
  9. aleicgrant's Avatar
    yep, same result. 1 bar of service, no data. I can get text and make calls

    do you think its possible the 3g radio on the phone has simply gone bad?
    Last edited by aleicgrant; 2011-05-13 at 06:11 AM. Reason: Automerged Doublepost
    2011-05-13 06:11 AM
  10. i.Annie's Avatar
    Well the 1 bar is expected. Just a cosmetic issue for 4.3.x and a preserved baseband. I don't believe that contributes to this issue.

    No data still...that's really weird. Your data and 3G is turned on yes?

    I am thinking you might have to exchange the phone out if AT&T can't figure it out either.

    Let's try an APN. go on safari on your phone and go to unlockit.co.nz and install an APN.
    2011-05-13 06:12 AM
  11. aleicgrant's Avatar
    data and 3g is on for sure.

    what do I do with the APN?
    2011-05-13 06:14 AM
  12. i.Annie's Avatar
    yep, same result. 1 bar of service, no data. I can get text and make calls

    do you think its possible the 3g radio on the phone has simply gone bad?
    That's a possibility. If all these restores and whatnot aren't working and if an APN doesn't work, I am all outta ideas man.

    data and 3g is on for sure.

    what do I do with the APN?
    Nothing really. Just go thru the site and follow the instructions. It'll ask you if you want to install it (you can uninstall later if it doesn't work) and select to install. It'll put the APN into your settings and it's supposed to work on its own. If it doesn't work then that's a real bummer.
    Last edited by i.Annie; 2011-05-13 at 06:16 AM. Reason: Automerged Doublepost
    2011-05-13 06:16 AM
  13. aleicgrant's Avatar
    I may have to give up the JB and just do a direct firmware update in itunes. Stinks but I dont see any other option. really wanted to hold onto my 1.59 bb :-(

    well I tried for almost 8 hours to get this fixed to no avail. I guess its time to go to the apple store. How do I wipe the phone and install firmware so they dont know its been JB. Do I also need to alter my host file to remove the Saurik server so it doesnt error out during the restore
    Last edited by aleicgrant; 2011-05-13 at 04:05 PM. Reason: Automerged Doublepost
    2011-05-13 04:05 PM
  14. i.Annie's Avatar
    That's no good

    Yeah that baseband is pretty darn good right now. I mean maybe wait and see if someone else has another solution? I'd recommend starting a new thread, state everything that we have done so far and maybe someone else can deduce from what we've done and come up with something new.
    2011-05-13 04:08 PM
  15. aleicgrant's Avatar
    perhaps I am going to try this one more time. Should I JB with Redsnow or ultrabreeze? should I use a custom firmware?

    I cant believe that doing a restore doesnt solve the problem... ODD
    2011-05-13 04:11 PM
  16. A3gOwner's Avatar
    Have you tried the old toggle airplane mode trick? Just an idea not that I think it'll work. Has the phone been dropped by chance? Just maybe the 3G antena came loose since you can call/txt and have 5 bars and no 3G unjailbroken.

    Edit: by airplane toggle I mean toggle airplane mode on wait a few seconds and toggle it back off.
    2011-05-13 04:15 PM
  17. aleicgrant's Avatar
    yep sure have... Phone has never been dropped or even a light bump for that matter :-)

    truly scratching my head
    2011-05-13 04:38 PM
  18. A3gOwner's Avatar
    The only other thing I can think of is maybe call AT&T and have them reset the vlr and resend the ota on your phone. That will clear old connections and start a new session with the tower. They will have you reboot your phone so dont call from it If they act like they don't know what your talking about ask to speak to tier 2 tech support they'll get it done for you. With all this and what you guys did earlier if it still has no data I'd assume you have a hardware or baseband issues and it's time for a replacement phone. Which is unfortunate since your on 1.59.
    2011-05-13 04:53 PM
  19. aleicgrant's Avatar
    I am going to give that a try. Thank you.

    Now one question in case that doesnt work. How can I restore my iphone so that when I go to apple they dont know its been JB. I remember I had an issue a long time ago and when I just did the regular restore it gave me an error. Do I need to modify my host file and remove any saurik reference?

    thank you
    2011-05-13 05:05 PM
  20. A3gOwner's Avatar
    Yep then just restore or upgrade to stock firmware. I say stock because if it has 1.59 and is on 4.3.3 it's a dead give away even if it's not jailbroken.
    2011-05-13 05:10 PM
39 12
LINK TO POST COPIED TO CLIPBOARD