1. Zeruel's Avatar
    Hi,

    I'm kind of new to this all, so forgive me if I sound dumb. I've done a lot of reading on here, trying to figure out what's best for me to do.

    So, I successfully jailbroke my iPhone 3Gs with Redsn0w 0.9.6rc16, and unlocked it with Ultrasn0w. I'm running iOs 4.2.1 and I had to upgrade to the iPad baseband. I'm running on T-mobile. So, far, everything works great, really. The only problem is, I have I have to boot tethered with Redsn0w. I'm not sure if that's something I did wrong or what. As far as I know, it didn't do that untill I ran Ultrasn0w. It's not really a big issue, but It'd be nice to know that if my phone got turned off, I could turn it back on again without being at a computer. Everything works great though, other than that, so I'm torn between "don't fix what isn't broken" and "mess with it untill it's perfect."

    I see there's a new version of Redsn0w out, but I'm not sure if there's something special I have to do to use the new version other than just...running it. Any advice will be much appreciated.
    2011-05-25 04:05 AM
  2. Orby's Avatar
    Unless I've lost my mind, iOS 4.2.1 is an untethered jailbreak, but I don't know if that version of redsn0w (which is made for iOS 4.3.x) will provide the untether.

    I do know greenpois0n RC6.1 (greenpois0n.com) will untether you, and should be okay to run on top of your existing jailbreak (key word "should," but I'd recommend restoring and re-jailbreaking with greenpois0n personally).

    EDIT: It looks like the greenpois0n.com front page is down.

    Windows direct download: http://cache.greenpois0n.com/dl/gp_win_rc6.1.zip
    Mac: http://cache.greenpois0n.com/dl/gp_mac_rc6_1.zip
    Last edited by Orby; 2011-05-25 at 04:26 AM.
    2011-05-25 04:20 AM
  3. Zeruel's Avatar
    Yeah, that's why my mind is boggled on this one. I tried GreenPoison, but...it didn't do squat. I don't know why, and I'm too new to this to really figure out and explanation. From the digging I did, it has something to do with the bootroms and the specific weeks my Iphone was made. It's a relatively new iPhone 3Gs from what I understand. I didn't buy it new though, so I'm not sure how new. The only thing I can think of is that maybe it has something to do with Ultrasn0w? Once I ran that, it started just showing the apple logo when I'd boot it, unless I did it with Redsn0w.
    2011-05-25 05:16 AM
  4. bondkt's Avatar
    go to 4.3.3 and use redsn0w. works fine, untethered
    2011-05-25 05:20 AM
  5. Orby's Avatar
    Yeah, that's why my mind is boggled on this one. I tried GreenPoison, but...it didn't do squat. I don't know why, and I'm too new to this to really figure out and explanation. From the digging I did, it has something to do with the bootroms and the specific weeks my Iphone was made. It's a relatively new iPhone 3Gs from what I understand. I didn't buy it new though, so I'm not sure how new. The only thing I can think of is that maybe it has something to do with Ultrasn0w? Once I ran that, it started just showing the apple logo when I'd boot it, unless I did it with Redsn0w.
    You can usually tell what bootrom a 3GS has by the first five characters of its serial number--xx940 and lower are old, xx945, xx0(any) and xx1(any) are the new one--anything in between xx940 and xx945 is a coin flip. Based on your tethered status, however, I'd bet you've got the new bootrom.

    Placing your iPhone in DFU and running greenpois0n didn't do anything? Did you see scrolling white text on your iPhone as it ran the greenpois0n payload?

    What may end up happening is we'll have you restore your iPhone to a custom 4.3.3 (or 4.2.1 if you've got SHSH blobs) firmware--it may be less brain damage that way, and you'll have your untethered jailbreak that way.
    2011-05-25 05:21 AM
  6. Zeruel's Avatar
    It's most definitely the latest bootrom. When I ran greenpois0n, it looked like it was working, but then it just flashed a white screen and rebooted. I thought I did something wrong, but then Redsn0w worked right the first time. It seems pretty hard to brick one of these things these days, so I'll give something a shot tomorrow and see where it goes. I don't like messing with things before bed, I end up staying up until it's working right again. I'm kind of afraid to change firmwares while having the upgraded baseband. Thanks for the help so far!
    Last edited by Zeruel; 2011-05-25 at 05:44 AM.
    2011-05-25 05:40 AM
  7. RefreshingData's Avatar
    just saying, don't try restoring using itunes because it won't work, just go grab the newest redsn0w and jb it 4.3.3. when you have the ipad baseband, you have to cook your own ipsw's.
    WHY AREN'T YOU JAILBROKEN?!?!!?
    2011-05-29 06:23 PM
  8. Zeruel's Avatar
    Yay, it works! I'm untethered, jailbroken, and unlocked on 4.2.1, now. I tried Greenpois0n again and that worked. I might try and update the firmware to 4.3.3 eventually, but at least I don't have to worry about my phone dying when I don't have my laptop with me.
    2011-05-30 12:50 AM
LINK TO POST COPIED TO CLIPBOARD