User Tag List

  1. Remix919's Avatar
    This error 1015 is driving me crazy. So, long story short, my dad got my iphone jailbroken and unlocked in China, problem is...all the crap was in chinese, so, I tried to do a iTunes restore and I got error 1015. I have done a crap of research and have tried tinyumbrella, 1015 fixer, and all that other stuff. I have NO IDEA what firmware it is currently running (didn't bother to check before I started the iTunes restore). Anyone have any idea how to restore this?
    2011-06-21 01:42 AM
  2. iYeow's Avatar
    Restore to custom firmware of 4.3.3 created by Snowbreeze 2.7.3 or Pwnage tools
    2011-06-21 04:01 AM
  3. made2kil's Avatar
    your kinda lucky, my baseband is 6.15.00 and I get 1015 no matter what because of that and it's impossible for me to update/restore to 5.0 Beta 1 from 4.3.3

    When ever I try to use 'Exit Recovery' programs they get stuck at boot screen, or 'FixRecovery43' Gets an error in it... so im screwed.
    2011-06-21 04:43 AM
  4. Remix919's Avatar
    Restore to custom firmware of 4.3.3 created by Snowbreeze 2.7.3 or Pwnage tools
    I used Snowbreeze and created a custom 4.3.3 firmware for my 3GS, but when I shift-click to load it in iTunes, it gives me a firmware not compatible error?
    2011-06-25 02:43 PM
  5. Simon's Avatar
    You sure you have a 3GS. If so are you sure you gave snowbreeze the correct firmware for your device? What was the filename of it?
    2011-06-25 03:15 PM
  6. Remix919's Avatar
    Yea, I'm positive the phone is a 3GS, it's got the rounded back and camera on the back as well. I used snowbreeze to make a file for the 4.3.3 firmware and the new file is called "sn0wbreeze_iPhone 3GS-4.3.3.ipsw". I'm not sure what firmware is currently on the phone though, as I had mentioned above, I did the apple restore without checking the firmware and now it's stuck on the iTunes connect screen. Is there anyway to check to see what firmware it has on it?
    2011-06-25 05:35 PM
  7. Simon's Avatar
    Is the writing on the back where it says iPhone dark grey or bright silver?
    2011-06-25 05:41 PM
  8. Remix919's Avatar
    Dark Grey
    2011-06-25 06:18 PM
  9. Simon's Avatar
    That's a iPhone 3G you have then there. Not a 3GS.
    2011-06-25 06:19 PM
  10. Remix919's Avatar
    That's a iPhone 3G you have then there. Not a 3GS.
    O I feel real dumb...I thought it was a 3GS this whole time Well, lemme try with the right firmware this time and I'll let you know how it goes. Thanks a lot!

    When I try to use snowbreeze with the 4.2.1 firmware for 3G it says not a valid ISPW?
    2011-06-25 06:32 PM
  11. Simon's Avatar
    You will need a older version of snowbreeze to make a custom 4.2.1 firmware. Version 2.2 maybe? I dont use snowbreeze very often so a little unsure.
    2011-06-25 06:39 PM
  12. Remix919's Avatar
    ok, got snowbreeze to work and custom ipsw, but when i did the restore in itunes with the custom ipsw, i got error 1604 now?
    2011-06-25 07:12 PM
  13. Simon's Avatar
    You need to enter pwned DFU first with either redsnow or iReb before you can restore to a custom firmware. Otherwise you will get those 16XX errors.
    2011-06-25 07:14 PM
  14. Remix919's Avatar
    Ok, so I did the iREB thing, got the iphone in DFU mode, showed the green screen, then the snowflake. After that I tried doing the custom restore with shift+click and selected the snowbreeze IPSW I had made earlier, but now at the Preparing Iphone for Restore part, it gives me an error 1603?
    2011-06-25 07:45 PM
  15. iYeow's Avatar
    Do a reboot of your PC, make sure you are pointing ur host file towards apple server or try it on a different PC or you can create another one from SnowBreeze 2.2.1 of Cfw 4.2.1
    2011-06-25 07:54 PM
  16. Simon's Avatar
    Redsnow is much more reliable for entering pwned DFU too.
    2011-06-25 08:02 PM
  17. Remix919's Avatar
    Ok, I used Redsnow with just the regular restore IPSW since the snowbreeze one wouldn't work with it. I used just the default options of cydia and battery percentage. Everything looks like it works and it finishes on the Redsnow end and says the rest is up to iphone, but then once iphone finishes, it just goes back to the itunes connect screen?

    Woot, finally got it to work! I just used Redsnow to get it into DFU, then used iTunes to restore the Snowbreeze custom IPSW So, is this a "real" iphone firmware or still jailbroken? And if jailbroken, is there anyway to get to the "real" firmware ever?
    Last edited by Remix919; 2011-06-25 at 11:57 PM.
    2011-06-25 11:41 PM
  18. i.Annie's Avatar
    If by "real" you mean unjailbroken/stock firmware then yes. If with the iPad baseband, it must be 4.1 or below to do so as 4.2.1 doesn't support exit recovery option from TU. If without the iPad baseband then all fw 4.2.1 stock is possible just as well as 4.1, 3.1.x, etc.
    2011-06-26 12:01 AM