1. anthonyb77's Avatar
    my 3gs was unlocked and jailbroken when i bought it from ebay, said its 4.3.3 firmware. i plugged my phone in today to sync my music and it said i can update my phone. i did...and i got a 1015 error and my phone is stuck on a usb--->itunes screen. ive tried a few things on here but i couldnt get them to work. i r newb so i might have been doing them wrong? any help is much appreciated, just need to be pointed in the right direction :P
    2011-07-16 09:09 PM
  2. xtacy's Avatar
    U did a terribly wrong thing.
    Download tiny umbrella and save your shsh blobs fast.
    Do it as soon as you read this.
    http://cache.firmwareumbrella.com/do...la-5.00.05.exe
    Download it. Click on fix recovery.
    U will have to put the phone in dfu mode.
    Then save blobs FAsT.
    Next time don't update .
    2011-07-16 09:47 PM
  3. anthonyb77's Avatar
    i did that and im pretty sure it didnt save anything, it also wouldnt let me click on fix recovery only exit
    2011-07-16 10:42 PM
  4. i.Annie's Avatar
    1) If a device is bought jb and unlocked, you should never ever hit upgrade in iTunes. If it was on 4.3.3 it wouldn't have even told you to upgrade though.

    2) You're probably on 4.3.3 now (very high chance of that) and you've lost the unlock.

    3) You need to check the baseband if possible. If it has the iPad baseband, good news: you can still unlock, bad news: the GPS is broken when the previous owner used the 6.15.00 baseband.

    4) Seeing as how you're stuck in recovery mode, it's likely because of the iPad baseband (I could be wrong)

    5) Download Sn0wbreeze and a stock 4.3.3 ipsw. Open Sn0wbreeze, select the ipsw, go into expert mode, go to general, make sure "activate" is checkmarked, then click next. Build the custom firmware.

    6) Download Redsn0w, browse to stock 4.3.3, checkmark only "DFU MODE" and nothing else, follow the instructions/timer.

    7) Open iTunes, hold shift, click restore, select CUSTOM 4.3.3 you built with Sn0wbreeze.

    8) When iTunes finishes you should get no errors and be able to access the springboard.

    9) Go to Cydia and install Ultrasn0w to unlock it.

    10) If the device does not have the iPad baseband as I am predicting, you'll have to install it yourself. Find out what the baseband (aka modem firmware) is in Settings when you get access and let me know.
    2011-07-16 10:49 PM
  5. xtacy's Avatar
    @Annie I think he updated to 4.3.4 :-/
    @Anthony u need to b in dfu to fix recovery. But I guess if u on 4.3.4 chances of that working are low.
    Can you run f0recast and tell what it shows?
    Last edited by xtacy; 2011-07-16 at 11:13 PM.
    2011-07-16 11:09 PM
  6. i.Annie's Avatar
    You can still downgrade to 4.3.3 with the steps I included. It's the same steps, Apple is likely still signing 4.3.3.
    2011-07-16 11:18 PM
  7. iYeow's Avatar
    +1, correct. It is possible Apple is still signing 4.3.3 and he has the ipad bb, restoring to custom firmware of 4.3.3 will be his best choice to get it going.

    @Annie I think he updated to 4.3.4 :-/
    @Anthony u need to b in dfu to fix recovery. But I guess if u on 4.3.4 chances of that working are low.
    Can you run f0recast and tell what it shows?
    Fix recovery will not kick out this error if this is Ipad bb.
    2011-07-16 11:31 PM
  8. xtacy's Avatar
    Ahh well yeah.. Din consider bb
    2011-07-17 12:11 AM
  9. anthonyb77's Avatar
    alright annie, i did what you said but when i got to download the ipsw it brings it to winrar and i extract it but it doesnt save where i can choose it from snowbreeze..i downloaded it from diffrent sites and am getting the same thing so i know its something im not doing right


    EDIT:im not all techy swavy with computers and stuff lol
    2011-07-17 12:28 AM
  10. iYeow's Avatar
    Do not extract the firmware, just rename .zip or .rar to .ipsw.

    If it doesn't allow you to change the extension, go to folder option in Control Panel and allow the hide extension.
    Last edited by iYeow; 2011-07-17 at 12:52 AM.
    2011-07-17 12:50 AM
  11. i.Annie's Avatar
    If you're having a hard time putting it all back together to rename, redownload it with Firefox or Chrome. Those browsers will download it in the ipsw format, not zip.
    2011-07-17 02:31 AM
  12. anthonyb77's Avatar



    it gives me that message when i try to create the firmware. and the firefox thing worked
    2011-07-17 03:45 AM
  13. i.Annie's Avatar
    Apparently it doesn't support "bold" for the font Arial... I don't know what that means.

    Try it after shutting off any antivirus and instant messaging programs. Also close off iTunes if it is opened.
    2011-07-17 03:48 AM
  14. anthonyb77's Avatar
    yea it still gives me the error message.
    2011-07-17 04:34 AM
  15. i.Annie's Avatar
    Try another computer if possible.
    2011-07-17 04:40 AM
  16. anthonyb77's Avatar
    i tried my dads computer and everything worked till i went to restore the phone, it gave me a 1015 error again...
    2011-07-17 07:00 AM
  17. i.Annie's Avatar
    Did you set your device into pwned dfu with redsn0w before restoring to the custom fw
    2011-07-17 07:41 AM
  18. anthonyb77's Avatar
    yup i did everything your first post said to do

    EDIT:as a matter of fact i did it 3 times just to make sure i did it right =/
    Last edited by anthonyb77; 2011-07-17 at 07:59 AM.
    2011-07-17 07:50 AM
  19. xtacy's Avatar
    Run f0recast as I said dude . Am pretty sure u updated to 4.3.4
    2011-07-17 10:26 AM
  20. i.Annie's Avatar
    Right... But even on 4.3.4 the same steps apply to downgrade to 4.3.3.

    When you creates the custom firmware, you did not include the iPad baseband into it right? You've also never used TinyUmbrella right?
    2011-07-17 04:37 PM
25 12
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.