1. SideCharacter's Avatar
    Hi,

    I am trying to figure out what to do in order to start using a new phone I got, and I'm very confused as to what firmware and everything to install so maybe someone can tell me what is best.

    I have an Iphone 3G, Jailbroken at 4.0.1, which is slow as hell, which is why I want to upgrade. It's also a bit buggy.

    I also have an Iphone 3GS, which is what I want to transfer all the files to, which is NOT jailbroken, and is currently at 3.1.3 firmware.

    Basically I want to jailbreak the second phone, and transfer everything from the first phone to the second phone, while not screwing up anything and hopefully retaining all my jailbroken apps. Also if the second phone could be at 4.x firmware while jailbroken and not screw anything up, that would be nice.

    Can someone tell me how to do this, or refer me to the right resources? Thanks
    Last edited by SideCharacter; 2011-07-26 at 05:25 AM.
    2011-07-26 05:22 AM
  2. iYeow's Avatar
    If the 3gs is not jailbroken, then you may not have any shsh blob. Run tiny umbrella, plug 3gs in and click save shsh . See what you have .
    2011-07-26 05:26 AM
  3. SideCharacter's Avatar
    Ok, did it, it says I have 4.1, 4.3.4, and a bunch of the 5.0b firmwares, for the 3GS

    I'm assuming that I would update the 3GS to 4.1 first, and then jailbreak it?
    Last edited by SideCharacter; 2011-07-26 at 06:16 AM.
    2011-07-26 05:38 AM
  4. iYeow's Avatar
    Right, if you want to preserve your unlockable bb, then restore to custom firmware of 4.1 from Snowbreeze . Use Redsn0w to put your iphone into pwned dfu prior to restoring to custom firmware.

    Use Snowbreeze 2.1 to create , from here : Hotfile.com: One click file hosting: sn0wbreeze-2.1.zip
    Redsn0w to put your iphone into dfu from here : MEGAUPLOAD - The leading online storage and file delivery service
    Last edited by iYeow; 2011-07-26 at 06:23 AM.
    2011-07-26 06:20 AM
  5. SideCharacter's Avatar
    I tried putting the IPSW that Snowbreeze created into Redsn0w and it says "Unable to recognize specified IPSW"

    It says "Please select the corresponding IPSW for your CURRENT firmware"
    2011-07-26 07:26 AM
  6. xtacy's Avatar
    U sure u tried on 2.1?
    2011-07-26 07:28 AM
  7. SideCharacter's Avatar
    Yeap. I did it in "Simple" mode if that makes any difference.

    BTW, Where does TinyUmbrella and the SHSH blobs come into this? Do they need to be "signed"/put in the firmware?
    Last edited by SideCharacter; 2011-07-26 at 07:35 AM.
    2011-07-26 07:31 AM
  8. xtacy's Avatar
    Try the alternate Mode . Are u selecting 4.1 ipsw?
    2011-07-26 07:36 AM
  9. SideCharacter's Avatar
    Just did it in the Expert mode ... yeap, same thing. This time snowbreeze offered to patch it through greenpoison, I just closed it...

    Yeah in snowbreeze I'm selecting the 4.1 ipsw I got out of the downloads section here...

    Hmm, in this thread, Simon is saying:

    You use regular firmware with redsnow, not custom.
    and

    You dont need to use redsnow to install cydia after when using a custom firmware. Custom firmware has cydia pre-installed normally.

    You would install ultrasnow to unlock after.
    This is so confusing lol ...

    By the way I don't 100% need the carrier unlock. Right now I'm with AT&T, so I personally don't plan to use it, I was just doing it because it seems like it might make the phone more marketable later on -- or, if I really wanted to, I could switch to T-Mobile


    Edit -- Also there might be some useful info in this thread.
    Last edited by SideCharacter; 2011-07-26 at 08:16 AM.
    2011-07-26 07:51 AM
  10. iYeow's Avatar
    I tried putting the IPSW that Snowbreeze created into Redsn0w and it says "Unable to recognize specified IPSW"

    It says "Please select the corresponding IPSW for your CURRENT firmware"
    You browse to stock 4.1 firmware when running redsn0w to only put iphone into pwned dfu mode.
    Once you are in DFU mode, run itunes and shift + restore to your custom firmware of 4.1
    2011-07-26 08:51 AM
  11. xtacy's Avatar
    Yeah an unlockable baseband makes phone more marketable ..try on another pc.. U won't need redsn0w if u use sn0wbreeze
    2011-07-26 08:52 AM
  12. SideCharacter's Avatar
    You browse to stock 4.1 firmware when running redsn0w to only put iphone into pwned dfu mode.
    Once you are in DFU mode, run itunes and shift + restore to your custom firmware of 4.1
    Ok and do I run the TinyUmbrella server first when shift-restoring? In other words how do I make sure the SHSH blobs are being broadcast?
    2011-07-26 02:15 PM
  13. xtacy's Avatar
    Yes.
    2011-07-26 02:44 PM
  14. SideCharacter's Avatar
    Ok so I did the whole process... redsnow into pwned dfu, shift-restored into the snowbreeze firmware, etc etc... confirmed that it's running 4.1 and is jailbroken.

    I left the apps to sync (I restored the backup on one computer, it didn't sync the apps, so I sync'd it on my main computer) and it appeared to be working. Then it came up with a bunch of errors, saying that 52 apps couldn't be installed "because an unknown error occured (0x8008001)

    Also:

    "Attempting to copy to the disk "My Iphone" failed. An error occured when reading from the device."
    and
    "Could not copy "Weather Vane" because file is corrupt and could not be read
    and
    "The phone "My Iphone" cannot be synced. An error occured when writing to the device."
    and
    "The phone cannot be synced. The required disk cannot be found"

    Advice?? Some of the apps were transferred, none of the music was transferred.
    Last edited by SideCharacter; 2011-07-26 at 04:42 PM.
    2011-07-26 03:33 PM
  15. SideCharacter's Avatar
    Hey guys --

    Well I got it figured out, I installed the software, everything works on the phone, except... today I called AT&T to get it switched over and it has NO SERVICE.

    They are blaming it on the software version, basically telling me I must update or they can't help me anymore.

    Suggestions? Any help is much appreciated.
    2011-07-28 04:30 PM
  16. xtacy's Avatar
    Hey guys --

    Well I got it figured out, I installed the software, everything works on the phone, except... today I called AT&T to get it switched over and it has NO SERVICE.

    They are blaming it on the software version, basically telling me I must update or they can't help me anymore.

    Suggestions? Any help is much appreciated.
    Why wud u tell them it's on this firmware?
    Tell em u already on latest lol
    She call me Mr. Boombastic say me fantastic, touch me in me back
    she say I'm Mr. Ro...mantic
    2011-07-28 05:04 PM
  17. SideCharacter's Avatar
    EDIT: I read another post that mentioned how you shouldn't hacktivate your phone if you are on the default carrier. Maybe snowbreeze hacktivates it in it's "simple" option? Not sure but I'm creating another custom firmware now and going to redo the whole process (Sigh - it took forever to get it the way I wanted it)



    EDIT 2 ....

    I tried to update it .. iTunes came back with "cannot recover... unknown error 14"

    It is now in "recovery mode loop" and every time I try to turn it off with it plugged in, it reboots again back into recovery mode! In other words I can't turn it off again to re-enter "pwned dfu" with redsnow, and I assume that's different than just plain dfu. What do I do now? I tried hitting "exit recovery" with tinyumbrella, it doesn't seem to work.
    Last edited by SideCharacter; 2011-07-28 at 06:14 PM.
    2011-07-28 05:19 PM
  18. xtacy's Avatar
    Put it in normal dfu and then use redsn0w to put it in pwned
    She call me Mr. Boombastic say me fantastic, touch me in me back
    she say I'm Mr. Ro...mantic
    2011-07-28 06:11 PM
  19. SideCharacter's Avatar
    This must be one of the most frustrating things...

    Ok so I did that, got it into DFU, went through redsnow again, ran the TSS, went into iTunes and tried to restore, and it said "The iPhone "iPhone" could not be restored. An unknown error occurred (14)."

    Edit -- I seem to have gotten past this error... stay tuned lol, thanks for all the help guys
    Last edited by SideCharacter; 2011-07-28 at 06:58 PM.
    2011-07-28 06:28 PM
  20. SideCharacter's Avatar
    Situation is solved -- apparently, the "hacktivate" option on the phone was the problem. I also had to re-do a bunch of the stuff I did previously. Huge pain in the *** but it's done, the carrier works, everything works and I'm satisfied.

    Thanks everyone for your help
    2011-07-29 07:40 AM
LINK TO POST COPIED TO CLIPBOARD