1. josephvb10's Avatar
    Well this is a little complicated story:

    Let's say i have an iPhone 3GS, iOS 4.3.3, old bootroom, with BASEBAND 06.15.00. Recently i have a problem with my iphone, it was stuck in the apple logo. So my only way to fix that was restoring.

    But i didn't want to update to iOS 4.3.5 (because the jailbreak) so i used my SHSH blobs and started the TSS server from tinyumbrella. Then I builded a custom firmware with Sn0wBreeze with "preserve the baseband" mode (because i am in 06.15.00 baseband, i only can restore to a custom firmware). I restored the firmware with itunes normally, with both Tiny Umbrella's TSS server running and iREB (to restore to the custom firmware created by Sn0wBreeze).

    The restore was normal, it didn't show any error, but when it came the part where the iPhone reboots, the iphone stucked in DFU Mode. iTunes keeps saying that the iphone is in a restore mode and needs to be restored. When i restart the iphone (pressing home + power) it still comes to DFU Mode.

    So what can i do? I really dont want to lose my iphone
    Last edited by josephvb10; 2011-08-09 at 01:04 AM.
    2011-08-06 05:01 AM
  2. iYeow's Avatar
    Did you use snowbreeze 2.7.3 to build your cfw of 4.3.3 ?
    2011-08-06 07:04 AM
  3. josephvb10's Avatar
    Did you use snowbreeze 2.7.3 to build your cfw of 4.3.3 ?
    I used the latest version avaiable in the official website
    2011-08-06 05:45 PM
  4. Mes's Avatar
    A couple things you can try:
    1) Snowbreeze again. Maybe the build is corrupt. Likely you've done this....
    2) Start with the existing cfw created by snowbreeze. Use the latest Redsnow to 'just enter pwned-DFU', then iTunes to shift load the cfw.

    Note: when the phone is in DFU mode, it can be a bit tricky to get it powered off to start over. I find 'listening' to the computer sounds helps. Connect the phone, then press power+home until the high-low sound (maybe 5 sec). Now you know it's truly off to begin a fresh Redsnow pwnd-DFU process.
    Last edited by Mes; 2011-08-06 at 05:58 PM.
    2011-08-06 05:52 PM
  5. josephvb10's Avatar
    Nothing works.... I think i readed somewhere that the problem of being stuck in DFU mode in the middle of the restore is caused by TinyUmbrella. I think there may be a problem when combining code from one person (Sn0wBreeze) and code from another (TinyUmbrella).

    Another idea?
    Shoulld i wait to sn0wbreeze to be compatible with 4.3.5, so i will not need tinyumbrella?
    2011-08-07 08:51 PM
  6. iYeow's Avatar
    Not true, I have the old bootrom too except I don't use iPad bb, I always restore to snow breeze custom fw of 4.3.3 . I would say , build another one and restore again.
    2011-08-07 09:23 PM
  7. Mes's Avatar
    +1 Ditto. Old bootrom 3GS 5.13.xx BB. Used both sn0wbreeze and pwnagetool with TinyUmbrella. Not a single issue.

    BTW: Don't expect a jailbreak for 4.3.4 or 4.3.5. They're worthless updates.
    The next jailbreak is likely to be for 5.0 or higher.
    2011-08-08 05:28 AM
  8. josephvb10's Avatar
    SO why happens this?

    I realized that the restore process is divided in two steps: first itunes deletes all data, then reboots the device, and finally it updates the software.

    iTunes deletes all data correctly with no errors, it reboots the device, that's all, it never updates the software, so i have an empty iphone that only works on DFU. I can do the custom FCW again and again but the same problem.

    Maybe because i didnt select the correct option on sn0wbreeze? (i used Preserve my baseband only, i currently have 06.15.00, should i check "Install iPad Baseband"?)

    Full info:
    -iPhone 3GS
    -Old bootroom
    -06.15.00 baseband
    -Has no firmware (read above)
    -I have SHSH to any firmware from 4.0 to 5.0b5.
    -iTunes 10.3
    -Started TinyUmbrella 5.0.0.09 TSS server
    -Using Sn0wBreeze 2.7.3
    -Selecting "Preserve baseband mode" on Sn0wBreeze
    - A curious thing: when i try to restore the firmware after sn0wbreeze puts the device in pwned dfu i get an error (1600), so i have to reboot my iphone and use iReb R4
    - iPhone in DFU Mode, shift-clicking restore button and selecting custom firmware created by sn0wbreeze
    -When iTunes finishes erasing all data, it reboots the iPhone, but it doesn't continue the update, it shows me again the "Detected a device in restoration mode" screen.
    Last edited by josephvb10; 2011-08-08 at 07:03 PM.
    2011-08-08 06:56 PM
  9. Mes's Avatar
    .......Maybe because i didnt select the correct option on sn0wbreeze (i used Preserve my baseband only, i currently have 06.15.00, should i check "Install iPad Baseband"?)
    "Baseband Preservation Mode does not jailbreak or unlock the device. All other modes (Simple and Expert) still preserve the baseband". Frankly I have no idea what the first option is used for ... I wouldn't use it Use Expert Mode instead.

    Your iPad BB is already installed. No reason to install again.
    2011-08-08 07:03 PM
  10. derickchow's Avatar
    I will try to use pwned to make a custom firmware than try again.
    2011-08-08 09:09 PM
  11. iYeow's Avatar
    Use redsn0w to put iPhone into pwned dfu.
    2011-08-08 09:35 PM
  12. josephvb10's Avatar
    Thanks!! It worked

    I just selected the Simple Mode in sn0wbreeze instead of selecting Preserve baseband mode.

    2011-08-09 01:03 AM
  13. Mes's Avatar
    Congratulations. Glad it worked.
    2011-08-09 01:08 AM
  14. bustah's Avatar
    how did you fix it? i tried but it still goes back into dfu mode after it finished restoring. I made a new custom with snowbreeze as well.
    2011-08-11 04:50 AM
  15. Mes's Avatar
    Did you select 'Simple Mode' in Snowbreeze. Version 2.7.1?
    2011-08-11 04:53 AM
  16. bustah's Avatar
    2.7.3, i usually use expert, but I made a simple mode custom. I was able to get both of them to restore but it still reboots into dfu. I have everything same as the user above except for new bootrom.
    2011-08-11 07:26 AM
  17. iYeow's Avatar
    Try this : go to desktop > computer name> .shsh folder and rename your 4.3.3 shsh file to something else but don't delete it in case you want it back.
    Now run tiny umbrella and request your 4.3.3 blob from cydia, do this in adv tab and click save shsh.
    Do your restore using tss server again .
    See if it works
    2011-08-11 08:20 AM
  18. bustah's Avatar
    No luck with that, it goes right back into dfu after it finish. That was exactly how I restored the first time, the 2nd time i had it unchecked.

    I am using itunes 10.4 btw, not sure if that make a difference.
    2011-08-11 04:15 PM
  19. bustah's Avatar
    DFU MODE, not recovery.
    2011-08-12 02:41 AM
  20. bustah's Avatar
    any1 know how?
    2011-08-13 02:12 PM
31 12
LINK TO POST COPIED TO CLIPBOARD