1. AClear's Avatar
    Hi everyone,

    First time posting. Love the site...anyhoo....I'm at my wits end.

    I have an iPhone 3gs that I bought last year.

    Newer bootrom
    Computer-iMac(intel) running tiger 10.4.11

    So, I've searched EVERYWHERE!..I wouldn't post if I hadn't. For the life of me, I can't get it to baseband 6.15....and yeah, I'm aware of the pitfalls. But I want my phone back!

    I've tried pwnagetool unlock edition 4.1.3. My IPSW's were right(I used my 4.1 firmware and ipad firmware 3.2.2) and I tried cooking up a custom IPSW. It installed fine through iTunes....BUT the baseband did not upgrade.(I can't see it in 'Settings'- firmware stays at 05.14.2) I tried this numerous times. It just won't do it. Ah!!! But the custom IPSW installs fine, no errors or anything, just no 6.15 baseband at the end!

    Secondly I tried a whole bunch of Redsn0w's and the only one that I found that recognized my 4.1 IPSW was 0.9.6b2. But it CRASHES my Mac everytime! I tried 0.9.5b5-3, -4 and I think -5(hard to keep track of all these), but they wouldn't recognize IPSW 4.1...I even tried updating the baseband FIRST, before Jailbreaking, and still, CRASH! Wha!!!???...0.9.6b2 didn't even have an "ipad baseband" option this morning and I think it did last night, so somethings buggy(or I'm losing it-definite possibility!). I know I have the right IPSW, because it factory restores perfect, meaning baseband 6.15 isn't there, because I wouldn't be able to perfectly restore it if 6.15 WAS on my device(from what I've read), plus that shows my IPSW is legit, because it factory restores perfect. I guess?

    I even thought of upgrading my firmware to official 4.2.1 through iTunes, then cooking up an IPSW for that to see if it would go through. But nopers. iTunes says the 'build'(I guess 4.2.1) is not compatible with my device or something like that. I'd rather keep 4.1 anyway. Was desperate though!(still am!).

    Limera1n app. jailbreaks the device fine, but I can't unlock it without the 6.15 baseband upgrade.

    I even tried a different pwnagetool to Jailbreak first, then upgrade baseband with Redsn0w, but like I said, Redsn0w always crashes when it starts doing it's thing.

    Please help!
    I've restored my phone back so many times I think I might ruin it.

    I should be able to do this from what I've gathered, but I suck I guess.

    Any help would be amazing.

    Thanks ahead guys and gals!!

    Last edited by AClear; 2011-08-13 at 06:29 AM.
    2011-08-13 01:12 AM
  2. Simon's Avatar
    2011-08-13 01:32 AM
  3. AClear's Avatar
    thanks so much Simon! I followed your instructions and it worked!!! At first it kept on giving me an 'unknown error' message, so I plugged into the usb ports on the actual machine(I use a 7 port external hub) and boom!...It worked.

    Some advice for those who have similar issues:

    a) DO NOT plug your phone into an external USB hub for baseband upgrading or jailbreaking. Plug right into the USB port on your compu. This is what was giving me 'unknown error' messages. Also, whatever you do first(I installed iPad baseband first, then Cydia), unplug it from the USB after it's done, then plug it BACK into the USB port to start your second operation.

    b)If you're running 10.4.11 Tiger on your machine, use redsn0w 0.9.6rc8 to update your 4.1 3gs baseband to 6.15. Pwnagetool 4.1.3 unlock edition doesn't install the 6.15 baseband upgrade(at least on my machine). It'll act like it has, but if under 'Settings-General-About-modem firmware' your number hasn't changed, it's a no go.

    c) Listen to Simon.

    Another quick question if you don't mind?...now that I'm up and running, should I use pwnagetool to cook up the back up ipsw for this? it would be a custom 'iPhone 4.1 firmware+iPad 3.2.2 baseband ipsw'...I'm thinking yes, as this is technically what's running on my phone. Seems sketchy though.

    thanks again Simon!...I've always liked Simons

    AClear-now running 4.1 on baseband 6.15 on iPhone 3gs compromised with redsn0w 0.9.6rc8.

    ps....might avoid the lake throw.....for now....oh how I love to hate this thing.
    Last edited by AClear; 2011-08-13 at 06:24 AM.
    2011-08-13 03:43 AM
  4. Simon's Avatar
    Glad to hear it worked for you.
    If you want a backup custom firmware that you can restore to if you need to then you should make one without the ipad baseband installed in it. You already have the ipad baseband installed so from now on you will need to use custom firmware that has no baseband installed otherwise you will get an error 1015 when restoring.
    2011-08-13 03:50 AM
  5. AClear's Avatar
    awesome!!...thanks again man...

    one more question......nah just kidding!

    was a little tricky finding redsn0w 0.9.6rc8 though....all the links are dead.

    managed to find one here if anyone else is having problems tracking it down.

    2011-08-13 04:06 AM
  6. Simon's Avatar
    Thanks, good link to share. I know that version of redsnow is a little hard to get a hold of these days.
    2011-08-13 04:09 AM
  7. Stray's Avatar
    I couldve linked you to a mac version
    2011-08-13 05:14 AM
  8. Mes's Avatar
    ^You were to busy searching for spam (Haha
    2011-08-13 05:20 AM
  9. Stray's Avatar
    Haha probably
    2011-08-13 05:22 AM