1. rhaos's Avatar
    Hi modmyi, new member with a tricky problem (or hopefully not :P)

    (I'm sorry if this topic has already been posted, I searched like a madman all over the internetz without success)

    So my problem is that I bought a iphone 4 with 4.0.2 fw thinking that it wouldn't be much hassle to jailbreak (mainly for ultrasn0w, the bb is compatible).

    But this of course proved to be a bit more tricky then I expected.
    The device has never been jailbroken but I managed to get the shsh for 4.0.2 with help of iFaith, the problem is that the only way I can seem to use the blob is with just Ifaith and I need to get the fw jailbroken to be able to use the phone i czech republic (the phone is at&t)

    So my question is as following; is there any way to upload the blobs on cydia so I'm able to use cydia instead of apple as signer of the fw? I don't mind using 4.0.2 for now as long as I get it to work/until they release a working version of ultrasn0w for 4.3.5 (or the firmware that apple signs for that moment in the future when things work out my way)

    I know that I could use the _____ (insert name of 112 simcard spoof device) but it feels kind of uncool to use a way that's actually illegal, and is illegal for good reasons i guess.

    So any help would be hugely appreciated

    I tried to get the shsh with tinyumbrella but without success (i guess the device has to be jailbroken?)

    I know that I should have done my research a bit more proper before just buying things, but when the "new-electronics" nerve gets pumping, things just happens

    who's the goose...
    Last edited by rhaos; 2011-08-19 at 07:20 PM.
    2011-08-19 07:16 PM
  2. Mes's Avatar
    The best (maybe the only) way to activate using an iFaith pre-signed ipsw is buy an AT&T sim off ebay.
    However, I would try redsnow anyway. Nothing to loose

    Note: No way to update Cydia's SHSH cache
    Last edited by Mes; 2011-08-19 at 07:33 PM.
    2011-08-19 07:30 PM
  3. xtacy's Avatar
    I have a question.why do u need ifaith to jailbreak?
    U can just jailbreak it straight away.
    2011-08-19 07:46 PM
  4. rhaos's Avatar
    Thanks for a quick answer

    So you don't think there's any way to use the blob's from iFaith to allow me to restore to a jailbroken 4.0.2?

    The phone is activated at the moment, only problem is that i need ultrasn0w to be able to use another carrier then at&t

    And if I use redsn0w to update, the baseband will be update as well? which kinda defeats the purpose of me trying to work some shsh 4.0.2 magic trying to get it unlocked.?

    But I'm not in a super hurry really, I still got my old 3g (that's so madly slow after I decided to try 4.x out without saving my shsh first :P) so I guess the safest bet is to wait for sn0wbreeze to be updated, and then wait for ultrasn0w to support 4.3.5...

    And again, thanks alot for a fast answer, it's much appreciated
    2011-08-19 07:48 PM
  5. Mes's Avatar
    Redsnow does not update the baseband

    Restoring (or updating) with a stock Apple firmware changes the baseband
    2011-08-19 07:50 PM
  6. xtacy's Avatar
    NOr can u use redsn0w to update .
    2011-08-19 07:51 PM
  7. rhaos's Avatar
    Because the way I understand it, if I actually want to be able to use the phone within my vodafone network I have to use a version of ios supported by ultrasn0w, and for now 4.3.5. is not.

    And there for I thought that I should be able to use the shsh blobs from iFaith to allow itunes (cydia) to "sign" and let me use a jailbroken 4.0.2.

    Or am I missing something? Jailbreakme.com is a no-go for 4.0.2 and the only way I understand that I can restore to something else besides 4.3.5 is if I have the blobs for that specific fw, and for now 4.0.2 is the only shsh i got.

    Thanks for your reply
    2011-08-19 07:53 PM
  8. Mes's Avatar
    Since you already have 4.0.2 installed and working ... It's simple. Jailbreak w/redsnow and install Ultrasnow via Cydia. Done.
    2011-08-19 07:56 PM
  9. rhaos's Avatar
    Oh, then I must have misunderstood something, I'm a bit slow (hungover) today

    So if I were to use redsn0w to do a tethered jb on 4.3.5 the baseband will be the same. But the phone will not be activated, unless if i get a At&t sim (do they have "cash-versions" of their sims? i got a friend arriving from there in a few days, and she might be able to pick one up)

    Redsnow does not update the baseband

    Restoring (or updating) with a stock Apple firmware changes the baseband
    2011-08-19 07:58 PM
  10. Mes's Avatar
    Redsnow doesn't update anything. It installs Cydia and opens the iOS for non-Apple apps, like ultrasnow
    2011-08-19 07:58 PM
  11. xtacy's Avatar
    Why restore to 4.0.2 when u r already on 4.0.2?
    And as far as I know there was no untethered for 4.0.2.. Correct me if I am wrong.
    2011-08-19 07:59 PM
  12. Mes's Avatar
    Wait. Are you running 4.0.2 ..... Or 4.3.5. You mentioned both now

    The newer versions of redsnow open the phone to springboard, whereby Ultrasnow can be installed
    Last edited by Mes; 2011-08-19 at 08:02 PM.
    2011-08-19 07:59 PM
  13. rhaos's Avatar
    ohhhh....now I starting to feel a bit stupid

    I'm on 4.0.2, I just think i've misunderstood how redsn0w actually works, I thought it was iTunes dependent (spits out a costum fw for use with itunes, and hence would give me signing griefs) This sounds brilliant! (and makes alot of sense) I'll try it and get back to you guys.

    Awesome!
    2011-08-19 08:06 PM
  14. Mes's Avatar
    Ahhh. You're thinking about Pwnagetool or Snowbreeze. They create custom firmwares, not redsnow
    2011-08-19 08:12 PM
  15. rhaos's Avatar
    That explains it, I'm having problems getting redsn0w to recognize the ipsw, i guess I'm just using the wrong version for the iphone 4 version of the ipsw, at the moment i've tried 0.9.8b3 and the older 0.9.5b5-5, and the older one recognizes the 3g version of the ipsw, so i guess i just need to find the proper version, and the hunt continues
    2011-08-19 08:34 PM
  16. Mes's Avatar
    Search Dev-Team Blog back a few pages.

    Sorry, I'm a little busy ATM.

    Check out http://theiphonewiki.com/wiki/index.php?title=Limera1n
    Last edited by Mes; 2011-08-19 at 08:51 PM.
    2011-08-19 08:43 PM
  17. rhaos's Avatar
    Don't worry about it, you've been a great help

    I'll check dev blog out, and the wiki as well
    2011-08-19 08:58 PM
  18. Mes's Avatar
    You're welcome. Good luck
    2011-08-19 09:03 PM
  19. rhaos's Avatar
    Awesomeness!!! Limera1n fixed it a few seconds, you're the hero of the day!

    I feel like this at the moment
    2011-08-19 09:23 PM
  20. Mes's Avatar
    You wweeerrrry welcome
    2011-08-19 09:25 PM
LINK TO POST COPIED TO CLIPBOARD