1. sak_uk's Avatar
    This is for anyone who feels they might be able to help, I have an iphone 4 which was actually given to me by a friend. He gave it to me when it was stuck in recovery mode and I tried everything to restore it, update it and even jailbreak it to no avail.

    I did some research and found that I can only restore it to a firmware it has previously been on and using trial and error, it was restoring on iOS 4.1 and then itunes gave an error message during restore while the bar on the phone was 75% full and then the phone started and looked like it was working normally. But then when I go to update it manually via itunes to 4.3.3 it doesn't work and gives me the "this device isn't eligible etc..." message. I tried to work around this changing the host settings on BOTH my windows pc and macbook and still no luck hasn't changed anything.

    So i then went and decided to try put custom firmware by using redsnow on my mac to put into pwned dfu mode, and then when i tried to put the 4.1 custom firmware on it, still no luck and another error message.

    Ideally I want to get this phone to 4.3.3 so I can use jailbreak me to jailbreak it and unlock the phone but nothing seems to work. I have spent HOURS and am hoping there might be someone here who might have some advice they can offer or help?

    Much appreciated guys
    2011-08-28 10:12 PM
  2. BenderRodriguez's Avatar
    Have you tried DFU mode?
    To enter it:
    Plug it into a computer
    Turn it completely OFF
    Hold the home and power button at the same time when u see the Apple logo release the power button, keep holding the home button

    It should now say please connect to iTunes now try

    If you are getting an error code please tell us the code
    2011-08-28 10:31 PM
  3. sak_uk's Avatar
    I have tried DFU mode and I get the message saying "The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build"
    2011-08-28 10:39 PM
  4. i.Annie's Avatar
    It can't be restored to anything besides 4.3.5 without SHSHs. I'm guessing you don't know if those SHSHs exist or not. There should be only one thing you should be trying: get the phone to restore to a stock 4.3.5 fw then in a functional state, attempt to see if SHSHs are available for a downgrade to attain a reliable jailbreak if desired.

    So what happens when (if you tried it) you restore to 4.3.5? If you haven't tried it, I suggest trying.
    2011-08-28 10:42 PM
  5. sak_uk's Avatar
    I used tinyumbrella to see the previous SHSH and have also attached a screenshot so you guys can see. When updating to 4.3.5, iTunes goes beyond the point of "extracting software" to the point where if I let it run, I can tell it will update the phone, but its on UK vodafone, and as I said I got it off a mate and I wanted to try and get it to 4.2.1 or 4.3.3 to be able to jailbreak and unlock so I can use it on my preferred network.
    Attached Thumbnails iPhone 4 won't update/jailbreak/restore...TRIED ALL METHODS...SOMEONE HELP PLZ :(-screen-shot-2011-08-28-21.45.25.png  
    2011-08-28 10:48 PM
  6. i.Annie's Avatar
    Glad to see you were able to retrieve the SHSHs

    You can restore to 4.2.1, thats the highest point bc no SHSHs for 4.3.3 are shown.

    Is it possible for you to access the device's modem firmware (aka baseband)? If it is at 1.59.00, it's necessary to preserve that. If it isn't, there's no point in using a custom FW. so if it is, create a custom fw for 4.2.1. Use pwnagetool to do so, set it into pwned dfu with pwnagetool, run TU's TSS server, open iTunes and option+restore to the custom 4.2.1. You should not be erroring out with these steps if done correctly.
    2011-08-28 10:54 PM
  7. sak_uk's Avatar
    I checked the baseband when the phone was somehow working and yes it is at 1.59.00. Can I use redsnow to put it into pwned dfu?
    2011-08-28 11:00 PM
  8. i.Annie's Avatar
    Sure RS works just fine too.
    2011-08-28 11:14 PM
  9. sak_uk's Avatar
    Still no luck, got an iTunes error message. I attached the screenshot
    Attached Thumbnails iPhone 4 won't update/jailbreak/restore...TRIED ALL METHODS...SOMEONE HELP PLZ :(-screen-shot-2011-08-28-22.26.59.png  
    2011-08-28 11:28 PM
  10. i.Annie's Avatar
    I have never seen error 2006 before and I can't locate it in the iPhone error wiki. I've gotten 2002 before but never 2006 ... Let me do some more research

    Edit: meanwhile, do you have another computer to try it on? If so try, if not try switching USB ports after restarting your computer. If you have a spare USB cable, try that too. Turn off all firewalls, antiviruses, instant messengers, anything running in the background that isn't necessary. Then try it all again. Also it might be good to create a fresh new custom fw as well. I'll look more into what 2006 specifically means.
    Last edited by i.Annie; 2011-08-28 at 11:47 PM.
    2011-08-28 11:45 PM
  11. iYeow's Avatar
    Run TU
    Make sure set hosts file to cydia is checked.
    Start TSS server
    If your current firmware is above 4.2.1 on your iPhone
    Put iPhone into normal dfu mode
    Run iTunes: shift + restore to OFW 4.2.1 fw
    Error 1013 pops up
    Now iPhone in recovery mode and iTunes error is1013
    Put iPhone into normal dfu mode
    Run an executable file called fix recovery 43 should get you out of loop and your BB remains as it was before.
    2011-08-29 12:06 AM
  12. i.Annie's Avatar
    The closest I've found for error 2006 that was actually resolved by 2 users was that it is USB related. So my previous statement should work, if you could use a direct USB port, and if you are already, to switch USB ports after restarting your computer. Someone else mentioned to do an SMC (you're on Mac right?) as well. I don't know if it is necessary but give it a go if you'd like.
    2011-08-29 12:10 AM
  13. sak_uk's Avatar
    iYeow, The current firmware according to TU is 4.1, should I follow the same steps but using 4.1 instead?

    i.Annie, the macbook air I am using only has 1 usb, my windows vista machine just says preparing to restore and never goes beyond that point so I stick to using the mac, I tried a different USB cable and I got this message on iTunes.
    Attached Thumbnails iPhone 4 won't update/jailbreak/restore...TRIED ALL METHODS...SOMEONE HELP PLZ :(-screen-shot-2011-08-28-23.15.27.png  
    Last edited by sak_uk; 2011-08-29 at 12:17 AM.
    2011-08-29 12:11 AM
  14. iYeow's Avatar
    Then if you are in recovery mode, you can do ur restore to stock fw of 4.2.1 if that is what u want

    Don't need dfu mode
    2011-08-29 12:21 AM
  15. i.Annie's Avatar
    I wouldn't do stock 4.2.1 at risk of losing the 1.59.00 baseband if you're sure it is still on that baseband.
    2011-08-29 12:24 AM
  16. iYeow's Avatar
    If you are able to restore to 4.2.1, jailbreak with redsnow rc8 to get tethered jailbreak, then run GreenPoison rc5 over it to go untethered

    Running TSS server will not update bb for iPhone 4 only
    Last edited by iYeow; 2011-08-29 at 12:27 AM.
    2011-08-29 12:25 AM
  17. sak_uk's Avatar
    i.Annie, I did what you told me to except I tried it with a custom firmware built using snowbreeze on iOS 4.1 and it worked! I'm guessing it is because the phone had 4.1 on it previously. No error message or anything, but now will it be safe to try and get it up to either 4.2.1 CFW or even 4.3.3 OFW (by restoring and updating manually on iTunes) and then using jailbreakme.com on 4.3.3?
    2011-08-29 12:30 AM
  18. i.Annie's Avatar
    You won't be able to get it to 4.3.3. You have no SHSHs for it.

    But with a custom firmware you're already jailbroken, is there a particular need for you to be on 4.3.3 and to use jailbreakme?
    2011-08-29 12:39 AM
  19. sak_uk's Avatar
    It was because I wanted to have the hidden fixes like airplay etc. I spoke to a friend and he said if I download CFW of 4.3.3 and use iTunes manual restore it should work since I am already on CFW?
    2011-08-29 12:46 AM
  20. i.Annie's Avatar
    You would still need SHSHs for 4.3.3 which you don't have.
    2011-08-29 12:48 AM
21 12
LINK TO POST COPIED TO CLIPBOARD