1. mindyish's Avatar
    I was following the advice on another post on here about saving shsh blobs that apple is no longer signing using ifaith. I have an iphone 3gs running 4.3.3 I was considering rejailbreaking and getting a fresh start since I had a few too many cydia tweaks and such. After some reading I decided I needed to save my blobs. I followed this tutorial here: iClarified - iPhone - How to Dump the SHSH Blobs of Your Current Firmware Using iFaith
    For saving my blobs.

    I got the the very beginning where you are entering DFU mode and things were going okay, it said it was"exploiting with limera1n" then "scanning for iboot" but I never made it past that, it said unrecognized ios and aborted leaving me in recovery mode!!!!!

    Where do I go from here? Itunes says the phone is is recovery and I must restore. Before doing this and rejailbreaking (losing all my stuff) I wanted to make sure this wont further harm my device.

    I not only know what I did wrong but how to fix it. Someone please help, I am home alone with kids with NO phone now

    FIXED: as stated in my last post using tinyumbrella recovery fix (link in my last post)
    Last edited by mindyish; 2011-09-03 at 11:25 PM. Reason: fixed
    2011-09-03 08:01 PM
  2. iYeow's Avatar
    If a hard reset or exit recovery doesn't get yout out, I am afraid a restore is needed. Sometimes ifaith cannot complete it's shsh dump and ends in recovery mode .
    2011-09-03 09:13 PM
  3. mindyish's Avatar
    My question is, if i must restore, will it upgrade me to 4.3.5? I need to stay at 4.3.3 or under as I want to jailbreak, unlock and reinstall all cydia apps n tweaks How do I restore but not end up stuck at higher ios?
    2011-09-03 09:37 PM
  4. iYeow's Avatar
    Without 4.3.3 shsh blob, you are going to restore to 4.3.5
    2011-09-03 10:50 PM
  5. mindyish's Avatar
    I tried restoring (using custom firmware) before I got your last message, of course, it failed. So, I tried running ifaith again and got it past DFU but when it tried to recognize IOS it would just sit there running for 20 mins so I just exited as I googled and found others had this issue but couldn't find an answer. I found a blog about tinyumbrella's recovery loop fix. I downloaded it from here :

    The Firmware Umbrella - TinyUmbrella

    Tried running it but it said I was missing zlib.dll file. So after googling that, I downloaded the .dll into the same folder as the extracted recoveryfix. Ran it, and it gave me itunes errors, but then it asked me to put it in DFU (well duh!) so the second it entered DFU it did some magic and I got my hopes up but itunes popped up again saying recovery, I needed to restore and the iphone screen said some message about exploited with green poison but looked like it was just sitting there stuck so I was about to exit itunes again when I noticed that all my info was back on itunes and the phone magically woke up! It unlocked as if it had just been powered down. Glad this worked (though I feel like I stumbled upon my fix by dumb luck)

    Now I know I NEED to save my SHSH blobs for this very kind of thing but am scared to use ifaith again since this is what cause my issue in the first place. Any suggestions as to an alternate method or should I risk trying again
    2011-09-03 11:16 PM
  6. iYeow's Avatar
    No other method, Try again, no risk no gain
    2011-09-03 11:22 PM