1. Ozzie5374's Avatar
    Hi folks. I've been on 4.2.1 bb 03.10.01 for a while now since JB with GreenPoison. Great setup.
    In the last couple of days I'm unable to either install new iTunes Apps directly onto iphone 4 AND I can't download on Mac/itunes then install via sync. Same for a few Apps I tried. I'm guessing this is because I'm incompatible on 4.2.1. I am given the option of upgrading to 4.3.5 in iTunes - but there appears to be NO untethered JB available yet for that. Is that correct? Does this mean no more Apps till I upgrade? Is anyone else in this boat? I dont want to upgrade just for the sake of it but is this a clever Apple ploy to stop JBers running older FW? Suggestions please.
    2011-09-04 07:29 AM
  2. Mes's Avatar
    Currently 4.3.3 is the maximum fully jailbreakable iOS. Anything higher is tethered. You will get a incorrect version message if an AppleStore app requires it. Check the error message more closely. I am surprised you're seeing this. At 4.2.1 almost everything works.

    Note: SHSH blobs are required to restore to 4.3.3. Use Tiny Umbrella to find yours
    2011-09-04 07:39 AM
  3. Ozzie5374's Avatar
    Thanks Mes. NO Apps will install either newly purchased ones or ones I've just checked to be synced to iphone. That is Apps I've bought previously but un-checked on iTunes.
    Message on phone - have done re boot, un checked all in Winterboard but can't think of anything else??
    Attached Thumbnails Can't install Apps on 4.2.1-imageuploadedbymodmyi1315121722.142873.jpg   Can't install Apps on 4.2.1-imageuploadedbymodmyi1315122531.592487.jpg  
    2011-09-04 09:54 AM
  4. skiptowncat's Avatar
    If you have your shsh for 4.2.1 stored, try a fresh restore and rejailbreak.
    2011-09-04 12:16 PM
  5. Ozzie5374's Avatar
    Yes, I have saved all in Cydia and also tinyumbrella. Can you point me in the direction of a walk through of how to do a fresh restore to 4.2.1. So your suggesting it to be not so much a compatibility thing (old FW) but a bug in my phone? Thanks for your help
    Last edited by Ozzie5374; 2011-09-04 at 01:21 PM.
    2011-09-04 01:13 PM
  6. skiptowncat's Avatar
    Yes, I have saved all in Cydia and also tinyumbrella. Can you point me in the direction of a walk through of how to do a fresh restore to 4.2.1. So your suggesting it to be not so much a compatibility thing (old FW) but a bug in my phone? Thanks for your help
    There are guides on here, in the "guides" section

    Download aptbackup or pkg backup and do a backup, then sync with iTunes
    Download 4.2.1 firmware (google that)
    Open tiny umbrella and start TSS server
    In iTunes hold shift and click restore then point to your downloaded firmware.
    Rejailbreak and download apt/pkg backup again, sync with iTunes, run apt/pkg backup and do a restore.

    Profit!!
    2011-09-04 01:34 PM
  7. Ozzie5374's Avatar
    Thanks. I've realised my prob was not running TSS server in tu. Also found Modmyi guide. Will try after work. Geeze work always gets in the way of the important things in life!
    2011-09-07 12:10 AM
LINK TO POST COPIED TO CLIPBOARD