1. Sariccia's Avatar
    I recently bought an iPhone 3g off ebay. It was running 3.1.2 and I tried to upgrade it to 4.1.2, but I got error 1015. I'm not downgrading... I'm upgrading. I downloaded recboot, but that didn't kick it awake. I'm trying to unlock it. Can I unlock it in 3.1.2 and how do I fix this upgrading error?

    Thanks,
    Sa
    2011-09-22 07:58 PM
  2. Mes's Avatar
    I'm confused. Error 1015 updating to 4.2.1, but question about unlocking 3.1.2?
    2011-09-22 08:10 PM
  3. i.Annie's Avatar
    Yeah what are you trying to attempt? An iPhone 3G is best kept on 3.1.3 and far away from iOS 4. anyhow you got error 1015, the upgrade was successful, you upgraded the baseband and lost the unlock. Check the baseband with f0recast to see if the baseband is 6.15.00 or 5.15.xx
    2011-09-22 08:18 PM
  4. Sariccia's Avatar
    essentially whenever I try to restore the iPhone, I get error 1015.
    2011-09-23 12:03 AM
  5. i.Annie's Avatar
    It's a baseband change failure, which is expected. 1015 isn't a problem really; you should really check the baseband so that we can give you proper instructions on how to get your phone up and running.
    2011-09-23 12:05 AM
  6. Mes's Avatar
    As Annie said, Error 1015 is common. It can be bypassed with Tiny Umbrella ' exit recovery ' (not fix recovery).
    2011-09-23 12:07 AM
  7. i.Annie's Avatar
    ^ yes, and with that on 4.1 or below.

    I'm asking for the baseband version is bc if the iPad bb is installed on it, it'd be easier to determine whether you should stay on 4.2.1 and upgrade the bb if it isn't already, or to take it back down to 3.1.x because the baseband upgrade can't occur on 3.1.x.
    2011-09-23 12:08 AM
  8. Mes's Avatar
    Sorry, you're right. A different iOS requires a different 'fix'
    2011-09-23 12:09 AM
  9. i.Annie's Avatar
    Why sorry? Was just adding on to my previous comment
    2011-09-23 12:10 AM
  10. Mes's Avatar
    2011-09-23 12:11 AM
  11. Sariccia's Avatar
    the camaraderie here is fantastic.
    the iphone is running firmware 3.1.3 with baseband 6.15.00
    tiny umbrella kicked it awake, but I still can't access the home screen.
    2011-09-23 02:10 AM
  12. Mes's Avatar
    So you're on 3.1.3 now. .... Did you use redsn0w to jailbreak?
    2011-09-23 02:13 AM
  13. iYeow's Avatar
    You must be at emergency screen , jailbreak with redsnow 0.9.4 but browse to stock 3.1.2 ipsw , it hactivates and jailbreak for you.
    2011-09-23 02:14 AM
  14. i.Annie's Avatar
    +1. follow what they said. You would use a 3.1.2 ipsw bc redsn0w doesn't recognize 3.1.3 but your phone can still be on 3.1.3 to get past the emergency call screen.
    2011-09-23 02:21 AM
  15. Sariccia's Avatar
    Okay so I downloaded resn0w and 3.1.2 and successfully jailbroke it. I can access the home screen now no problem, the cydia icon is there. But, cydia is not behaving. It only says loading data, no cydia homescreen. I tried re-installing cydia, but the same thing happened.
    2011-09-23 04:04 AM
  16. i.Annie's Avatar
    That sounds normal. It can take Cydia anywhere between 30 minutes to an hour to load the first time. The iPhone 3G is dated and Cydia keeps getting updated for newer devices.

    Unless you waited an hour and nothing happened? And you probably shouldn't "reinstall" Cydia unless you mean you restored and rejb. Running a jb over itself is more trouble than help.
    2011-09-23 04:08 AM
  17. iYeow's Avatar
    Use ifunbox or any third party software , go download cydia version either 3366 or 1.1.1 deb file and put the file in cydia/ autoinstall, reboot iPhone
    You may have to create a folder if you don't have the autoinstall folder.

    Second option, restore to 4.1 and jailbreak with redsnow 0.9.6 b6 to b8. This cydia version will definitely work.
    Last edited by iYeow; 2011-09-23 at 04:14 AM.
    2011-09-23 04:10 AM
  18. Mes's Avatar
    ...And you probably shouldn't "reinstall" Cydia unless you mean you restored and rejb. Running a jb over itself is more trouble than help.
    +1 So true. Re-installing Cydia is likely to cause problems. Might need to start over.
    2011-09-23 04:10 AM
  19. Sariccia's Avatar
    awkward re-installed a third time and worked like a charm. I really appreciate all the help, and won't rejb again. I'm a little less newb each day, thanks.
    2011-09-23 04:19 AM
  20. Mes's Avatar
    Third times a charm. Congrats
    2011-09-23 04:20 AM
LINK TO POST COPIED TO CLIPBOARD