1. roly01's Avatar
    hello everyone, a couple of days ago my friend came to me with his iphone 3gs stuck on the apple logo. he said he went into settings and tried to do a complete reset and erase all content because he wanted to sell it. after trying to reset it the phone would never fully boot up staying stuck on the apple logo. thinking all i needed to do was was full restore and we would be back in business, i asked him what firmware he was on and he said he this he remembers me telling him he had 4.2.1 with the ipad baseband (i had unlocked the phone for him a few months back) so i go ahead and run tiny umbrella and do a restore to 4.2.1 custom ipad baseband. everything was going fine till rite about the end, it had maybe 25% left and the phone shut of by itself and i got and 1015 error on itunes. so i try to restart the phone to no avail, it is stuck in dfu. i try the tiny ubrella fix recovery and i get the limerain exploit screen but nothing after that, also downloaded fixrecovery 421 431 nothing also. tried restoring to stock 4.2.1 again nothing. tried upgrading to 4.3.1, 4.3.3 nothing. so last night i gave up just did a normal iphone restore which would upgrade it to 4.3.5 and still i get another unsuccessful try.

    ive searched every forum up and down and have tried everything ive read upon and cant seem to find a fix. this is my last resort so im hoping maybe some one has had this problem and been able to over come it please any help would be greatly appreciated.

    thanks in advance!
    2011-09-26 06:21 AM
  2. iYeow's Avatar
    Build a custom firmware of 4.2.1 , run tiny umbrella ,start TSS server ( 4.2.1 blob must be shown under general tab, put iPhone into pwned dfu mode , run iTunes and restore to cfw of 4.2.1 .
    2011-09-26 06:29 AM
  3. roly01's Avatar
    no info shows up in tinyubrella for the phone, on the left pane i get ?0 for the name of the phone, under genral tab i get invalid for device model and ecid shows up as 0. any other suggestions ?
    2011-09-26 06:47 AM
  4. harner818's Avatar
    Do you have any shah blobs saved that you know of? Ones that are already saved on the computer?
    2011-09-26 06:50 AM
  5. roly01's Avatar
    yes i manually saved the blobs through cydia i believe up to 4.3.3 but for sure 4.2.1
    2011-09-26 06:56 AM
  6. harner818's Avatar
    The device is in dfu mode after the restore and not recovery mode right?
    2011-09-26 06:58 AM
  7. roly01's Avatar
    yup stuck in dfu mode
    2011-09-26 06:59 AM
  8. harner818's Avatar
    Ok try this run redsnow and tell it to boot tethered and tell me what happens
    2011-09-26 07:01 AM
  9. iYeow's Avatar
    In dfu mode, follow this to retrieve your ECID and input into TU , request shs blob from Cydia , click save shsh.

    http://www.iclarified.com/entry/index.php?enid=9192

    http://www.iclarified.com/entry/index.php?enid=9190
    Last edited by iYeow; 2011-09-26 at 07:07 AM.
    2011-09-26 07:04 AM
  10. roly01's Avatar
    ok i was able to get it to restore to 4.2.1 through itunes , itunes claims restore was successful and the phone should reboot. nothing happend then pops up in itunes again as dfu mode, try the fixrecovery but no use. any other ideas thanks for all the help guys
    2011-09-26 07:11 AM
  11. roly01's Avatar
    ok i followed the iclarified link and i was able to find the ecid and i have all blobs from 4.1-4.3.5 except for 4.2.1 which i find very weird? what should i do next
    2011-09-26 07:25 AM
  12. iYeow's Avatar
    You either go for 4.1 or 4.3.3. If you choose 4.3.3, you need to create custom firmware, if you choose 4.1, you can just restore to 4.1 . So which one would you like ?
    2011-09-26 07:29 AM
  13. harner818's Avatar
    The reason I said to do the tethered boot is to find out if the problem is for sure just the blobs. If it boots tethered it's jus a problem with the blobs. If it does not then it could be something else.

    You either go for 4.1 or 4.3.3. If you choose 4.3.3, you need to create custom firmware, if you choose 4.1, you can just restore to 4.1 . So which one would you like ?
    Has to be custom cause it has the iPad bb.
    2011-09-26 07:31 AM
  14. roly01's Avatar
    trying 4.3.3 now lets see how it goes

    i also tried booting tethered but get stuck at pineapple screen
    Last edited by roly01; 2011-09-26 at 07:44 AM.
    2011-09-26 07:34 AM
  15. iYeow's Avatar
    Correct, it is either his blob is corrupted or he didn't have the blob but ran tss sever so ended with dfu mode.
    2011-09-26 07:44 AM
  16. roly01's Avatar
    yea dosent boot tethered tried but gets stuck on pinapple boot screen. 4.3.3 custom restore just started passed apple verification lets see how it goes wish me luck guys
    2011-09-26 07:49 AM
  17. iYeow's Avatar
    Best of luck to you , a hundreth times . I hate my laptop, keeps freezing up..
    2011-09-26 07:54 AM
  18. roly01's Avatar
    IT WORKED!!!!!! you guys are Awesome! thanks for all the help!!!! idk what i would do with out you guys. every one who cometed gets a tumbs up on each post! thank you, tank you, thank you!
    2011-09-26 07:57 AM
  19. iYeow's Avatar
    There you go, now you can sleep soundly, haha . Have a great night

    Wait, wait check your signal , are you using unlock ?
    Last edited by iYeow; 2011-09-26 at 08:02 AM.
    2011-09-26 08:00 AM
  20. harner818's Avatar
    Awesome! Always good to figure it out before midnight haha!
    2011-09-26 08:02 AM
27 12
LINK TO POST COPIED TO CLIPBOARD