User Tag List

  1. woowoodengy's Avatar
    Hi guys, Hope to help someone. I upgraded to 5.1 from 5.0.1 on my iPhone 4. I instantly had a signal problem. I preserved my baseband 01.59.00 and this was the problem with the signal. It seems i had a signal and was able to get 3g data and calls but the signal indicator stayed at 1 bar. never went higher. It even had no bars sometimes and still worked. I'm using a straight talk cellular sim card that leases the att network towers. (for those of you with locked iPhones this is the answer for you since the straight talk att sim works on locked iPhones even the 4s for $45 per month unlimited and 3g speeds, but thats another thread, google it if your interested) back to the downgrade process.

    Note: I used a custom baseband preserved firmware to upgrade to 5.1 you can downgrade the firmware but not your baseband.

    Note: I tried this with a Windows PC and could not stitch the SHSH blob to the custom ISPW with preserved baseband so I'm not sure you can do this with Windows.

    Note: you must have your SHSH blobs saved to do downgrade. If you dont this will not work. You should always save SHSH blobs.

    Step 1. Download the latest redsn0w 0.9.10b6 here or google redsn0w 0.9.10b6 its not hard to find
    Step 2. Download ios 5.0.1 firmware for iphone 4 GSM here
    step 6. Open redsn0w and click the button that says "Extras" everything else
    step 3. Click the Custom IPSW / preserve baseband with a custom IPSW button
    step 4. choose the downloaded 5.0.1 firmware and it will make a custom firmware without the baseband upgrade, the file will start with NO_BB_Iphone, redsnow will let you know where its saved
    step 5. go back to the extras menu on redsn0w
    step 7. Click "SHSH blobs" Fetch, verify or use SSH blobs
    step 8. this step may vary depending on where you have your 5.0.1 SHSH blobs saved. I save mine with Tiny Umbrella so all i had to do was click "Stitch" and choose the 5.0.1 firmware that was just made. MAKE SURE YOU CHOOSE THE ONE THAT SAYS NO_BB IF YOU CHOOSE THE WRONG FIRMWARE HERE YOU WILL BE SCREWED then choose your 5.0.1 SHSH blob. You may need to "Query" and get your blobs from cydia if you need more help on this i'm sure google can help or just post here and i'll explain.
    you just used the custom firmware that has no baseband upgrade and stitched your SHSH blob to it
    step 9. go back to extras in redsnow
    step 10. place phone in DFU mode
    Step 11. open itunes, it will give you a popup that says your iphone needs to get restored just dismis it
    step 12. hold the option key on you mac and while holding the option key click the restore button. you can then choose the file you made and restore. the file will start with numbers and have the NO_BB in it. looks like this XXXXXXXXXXXXX_NO_BB_iPhone3,1_5.0.1_9A405_Restore

    Thats it. you DO NOT have to edit hosts files or start tiny umbrella to do the restore. it will just work because you stitched your SHSH blob to the firmware. If you get an error after restore and get the connect to iTunes icon just use tiny umbrella to fix recovery and try to restore in DFU mode again.

    After I restored and jailbroke i still had very bad signal bars. I installed Ultrasn0w and now my signal strength is back. (i get 5 bars since I have a micro cell in my house) I'm sure this is caused by using the old 01.59.00 baseband without unlocking it. Although that makes no sense to me. I have always used Ultrasn0w to unlock after a custom restore. since i was with Tmobile. But this time since Ultrasn0w was not available yet and I didn't need the unlock because straight Talk does not need to be unlocked to work i had terrible signal or bad signal bars who knows. So I figure if i did a regular upgrade with a baseband upgrade it would of had good signal but i need my unlock since i travel.

    Anyways hope this helps someone cause it just saved my iPhone from a full upgrade into the trash.
    2012-03-10 10:00 AM
  2. ineedhelpwithiphone's Avatar
    I Have another problem, slightly different, i have no ios 5.0.1 shsh blob
    and i wanted to restore to ios 5.0.1 which i am currently running since my cydia disappeared on me.
    however, i keep getting errors 3194 but using TinyUmb i was able to bypass it.
    Now i'm receiving error 11. I googled it told me to change the ipsw to zip file and delete the BBFW file.
    I did tht but error 11 is still there. Any solution?
    2012-03-11 07:14 AM
  3. woowoodengy's Avatar
    As far as I know there is no way to downgrade without your blob. I tried to downgrade a few different ways using tiny umbrella even changing hosts file but no go. The only way that worked was stitching my blob to the custom IPSW and then it downgraded. if you had cydia installed it may have saved your blobs, try to fetch them using redsn0w or ifaith if your using windows.
    2012-03-11 07:57 AM
  4. atalk's Avatar
    It works.
    My situation was that I'm using it for tmobile, 1.59 baseband and 5.0.1 firmware and my phone was acting weird and cydia wouldn't open and I also started losing service. I tried restoring with a custom ipws but kept getting errors, even with tiny umbrella. after fetching from my phone and using that plist to stitch to the new ipsw that i created with Redsn0w, iTunes let me restore without any problems. THANKS FOR THE HELP GREATLY appreciate it.
    2012-03-14 04:40 PM