User Tag List

  1. Genericamel's Avatar
    howdy, i recently tried to rejailbreak. i had tried using redsn0w as usual but for some reason it wouldn't work (gave me an odd white screen followed by a black screen even though the program said it was finished to disconnect). its worked for em before and i have had my iphone 3G jailbroken with it but today i discovered the whited00r IOS so i restored my idevice to the firmware and i quickly learned (i didn't know prior) that it was a 3.X jailbreak, huge turn off so i went to restore which went fine then i went to try to jailbreak again with redsn0w to no avail. so i tried about 3 other jail breaking programs until finally sn0wbreeze finally worked for me, i was ecstatic that i had my iphone rejailbroken. but i went to go install SB settings and all the other good stuff it does this.

    Cydia Cannot comply-img_0002.png

    Cydia Cannot comply-img_0001.png

    i have never seen this before, i cant find mobile substrate anywhere in cydia, i thought i would come and ask a forum with experience before i went ahead and tried another jailbreak.
    2012-09-04 03:51 AM
  2. Simon's Avatar
    Looks like your sources are messed up. Or you haven't refreshed them under changes yet. Try that first.

    What version of redsnow were you trying and I assume you had your iPhone 3G on 4.2.1 right?
    2012-09-04 04:27 AM
  3. EVO's Avatar
    it is highly possible that the bigboss repo was experiencing some difficulties during the time you tried installing SBSettings

    try it again, you should be ok

    sometimes repos have hiccups
    2012-09-04 08:17 AM
  4. Genericamel's Avatar
    tried refreshing them to no avail.

    and correct, iphone 3G with 4.2.1

    i had tried to use redsn0w_win_0.9.14b1 and redsn0w_win_0.9.14b2

    something has to be corrupted. but i just have never seen this in all my years of jailbreaking.
    2012-09-04 11:51 PM
  5. cyb3rduck's Avatar
    Wow thats certainly a new one on me too. This is definately a fault with APT and the repositories.

    Can you check - do you have this list of repositories?
    Open Cydia > Manage > Sources
    BigBoss (
    Cydia/Telesphoreo (Index of /)
    Dev Team (
    ModMyI (
    ZodTTD & MacCiti (http://cydia/

    Once you've checked this, tap Manage at the top left corner and tap Settings. Change this to Developer mode. Change this back later to User mode. Remove any other repository for now.

    Tap search, then type in apt and install these:
    Apt 0.6 Transitional
    Apt 0.7 (Apt-Key)
    Apt 0.7 HTTPS Method
    Apt 0.7 Strict
    Apt 0.7 Strict (Lib)

    Also install MobileTerminal 520-2 (look for the NEW version of MobileTerminal and make sure it is compatible for your iOS version - the new version will run on iOS 4 and iOS 5).

    Hopefully you can install these console-only packages. If you manage to get these installed (these rely on the Cydia/Telesphoreo repo and BigBoss for MobileTerminal) then you can try this...

    Open the MobileTerminal app.
    Enter the command su (lowercase, press enter)
    You will be asked for a password - it is alpine
    Enter the command:
    apt-get update

    This manually updates your sources list. This should download the Packages and Release files from each repo and update Cydia and Apt with the available packages to download.

    From a security standpoint you may wish to change your root password from alpine to something else.
    If you want to do this, enter the command
    passwd root
    Enter a new password. You might also want to issue the command
    passwd mobile
    to secure the mobile account.

    You should when apt-get update runs see lines like
    [Hit] stable Release.gpg [189B]
    [Ign] Index of / ios/690.10 Release
    [Hit] stable Release
    Get: 2 stable Release [1314B]


    Fetched 54.9KB in 5s (10.8KB/s)
    Reading Package Lists.. Done.

    If this is the output Apt provides it will have manually refreshed the Sources data that Cydia requires to download packages like Winterboard, SBSettings and others, and should hopefully allow Cydia to run without issues.

    I'd recommend setting the Cydia mode back to user again (Manage > Settings > User) once you've attempted to add MobileTerminal and Apt.

    This is only going to work if Cydia was installed correctly in the first place when Cydia prepared the iOS file system and moved system files to accommodate the jailbreak.

    Failing this it might be time to re-jailbreak your iOS device again Best of luck!!
    2012-09-05 02:48 AM
  6. Genericamel's Avatar
    I'm sorry, I never replied.

    What @cyb3rduck said to do absolutely worked(:

    Thank you very much. (:
    2012-09-10 01:53 AM
  7. chiocken's Avatar

    I'm having a similar problem to the OP. I thought I'd join this thread to see if you guys can help before starting my own.

    I'm trying to install Ultrasn0w to unlock my carrier but get a "cannot comply" and dependency "iOS Firmware >= 3.0". I followed your instructions as far as installing MobileTerminal, but I get a "cannot comply" and dependency "iOS Firmware > 4.2" (I *think* it said 4.2; I forgot to bring the phone with me to work this morning, but I can recheck later).

    I have an iPhone 3G on 4.2.1 and 06.15.00. Any thoughts?

    Note, I'm a complete jailbreak noob. I got here after trying to restore the previously jailbroken device to factory settings, only to discover I needed the carrier unlock. I flashed 3.1.3 after getting error 1015, and then upgraded to 4.2.1.

    Thanks for reading.
    Last edited by chiocken; 2013-03-04 at 11:09 AM.
    2013-03-04 08:59 AM
  8. jenetic's Avatar
    great help!it really works.thank you very're a hero!
    2013-03-20 07:03 PM
  9. Ahmed6's Avatar
    you're a hero
    2013-05-10 10:45 AM
  10. kez1304's Avatar
    Just came across this thread as a buddy at work wanted his iPod 2G, 4.2.1 jailbroken, so naturally I agreed.

    I was getting exactly the same issue, which were solved by following cyb3rduck's instructions... With one exception:

    When it comes to installing MobileTerminal, I was running into the issue that it required iOS 3.0 or greater. So again, the cannot comply error.

    The solution?

    I downloaded the MobileTerminal_520-2_iphoneos-arm.deb file from:

    Then I downloaded and installed iPhoneBrowser from: iPhoneBrowser - Download

    Loading iPhoneBrowser up, with the troublesome iDevice plugged into your PC, you then create the folder(s) to have a path:


    Some of those folders might not exist, just create them.

    Drop your MobileTerminal_520-2_iphoneos-arm.deb file into that AutoInstall folder.

    Once that's successfully copied to your iDevice, restart it.

    You should now see the MobileTerminal app sat on your springboard, ready for use.

    You can then continue following the final parts of cyb3rduck's instructions, and you should be in business.
    2013-08-19 03:47 PM