1. thomstfu's Avatar
    I have no idea if i've posted this in the right section of these forums but hey.
    I accidentally updated my ios 4 3GS to ios 6 instead of a custom 5.1.1 (preserved baseband) firmware, and my unlock was lost. I then tried to downgrade to ios 4 which worked fine, i unlocked it and put the ipad baseband on it to get rid of ios6's unlockable baseband. Obviously as ios 4 is mega dated, barely any apps are supported and as such was pretty boring (i couldnt even install twitter/facebook) so i tried to put the intended 5.1.1 on the phone which eventually worked (if i recall, i had to make a custom firmware with the 'old bootrom' option ticked on ultrasn0w), which worked great for about 20 minutes (in this time i'd downloaded apps, made calls and texts etc) until the phone randomly crashed whilst it was in my pocket on the lock screen.
    I honestly can't remember the different ios's i installed (or tried to) following this, but basically the phone showed no signs of life except for a completely white screen when put into dfu mode (although ios 6 always seemed to install fine). After hopeless attempts using multiple pieces of software, i took the phone apart and removed the battery for an hour; when reinserted, the phone booted showing the pineapple logo, although this was the furthest it would go (an improvement on the white screen though). i then reinstalled ios 5.1.1 'old bootrom' which went on fine, tethered jailbroke it and put my music back on, made calls etc, although it crashed again and i'm left back were i started (sort of)
    any ideas? sorry for the long post lawlz.
    2012-10-01 06:30 PM
  2. Orby's Avatar
    Is your 3GS actually an old-bootrom model (serial number check: if the third digit of the serial number is 9, and the fourth and fifth digits are 40 or lower, you have an old-bootrom device; any other digit combination, you probably have a new bootrom)?

    If you have an old-bootrom model, you shouldn't need to use a tethered boot or jailbreak at all--the beauty of the old-bootrom models are that they are a permanently untethered jailbreak.

    Also, the iOS 5.1.1 jailbreak administered by redsn0w is designed to to be untethered for all 3GS units--old and new bootroms alike.

    The most likely explanation I can think of is you actually have a new-bootrom 3GS. (Even if you have an old-bootrom unit, the new-bootrom firmwares will work just fine on the old-bootrom units). Try pwned-DFU restoring a new-bootrom custom firmware to the 3GS then jailbreaking it and doing whatever baseband downgrading you need to.
    2012-10-01 10:16 PM