User Tag List

  1. awesomeman123's Avatar
    Hello,

    First I Apologize if this is in the wrong section, I haven't been on modmyi for some time.

    Problem: The problem is that my friend's iPhone 3G Has Broken Down. I Notice that it is in the recovery loop so i fix that with tiny umbrella and redsnow. However, I believe it did not work because of Error 21. I have tried a few methods to restore the device. First was DFU (Normal) Restore and DFU (Powned) Restore. Both fail me with error 21.

    Please Help
    Thanks,
    2012-10-13 09:22 PM
  2. Simon's Avatar
    What firmware are you trying to restore to?
    2012-10-13 09:36 PM
  3. awesomeman123's Avatar
    4.2.1 i believe it is compatible.
    2012-10-14 10:34 PM
  4. Simon's Avatar
    Is the phone unlocked with ultrasnow or have the ipad baseband on it or anything like that?
    2012-10-14 11:34 PM
  5. awesomeman123's Avatar
    No, It is nothing like that. Can you please just give me instructions? I haven't done anything with it except that installing a jailbreak program that probably was not meant for my device and so boom.
    2012-10-15 02:50 AM
  6. Simon's Avatar
    If you are just trying to restore to a regular 4.2.1 firmware then putting it in DFU and restoring in itunes should work fine. No reason I can see why you are getting error 21, that is usually a error associated with custom firmware. Maybe try restoring it on a different computer.
    2012-10-15 12:07 PM
  7. awesomeman123's Avatar
    I have tried that but as it turns out my phone was unlocked. I had unlocked my device once again after i restored my device last month. I apologize for that. May i please get the directions on restoring my device from an unlocked 3G? I do not know its previous IOS firmware. I only know that it is unlocked, a 3G, and that i am restoring it to 4.2.1 Please Reply ASAP I need This phone repaired by tomorrow
    2012-10-16 12:09 AM
  8. Simon's Avatar
    I suggest downloading 4.1 firmware and try restoring to that. Let me know if you get any errors and the exact number if you do when trying that.
    2012-10-16 12:25 AM
  9. awesomeman123's Avatar
    2012-10-16 12:27 AM
  10. awesomeman123's Avatar
    I fixed it, I Restored it to 4.1 then jailbroke it because their is no sim. Thank You All SO MUCH!!!!!!
    2012-10-17 09:50 PM
  11. Simon's Avatar
    2012-10-18 12:43 AM
LINK TO POST COPIED TO CLIPBOARD