1. papasnorkle's Avatar
    Hi all,

    How's yourselves? I'm hoping someone here might be able to help me or at least point me in the general direction of what I need to do to get my iPhone up and running again.

    The Situation
    Currently the iPhone is stuck in the restore loop and while I can get it into DFU mode, I can't get it into Pwned DFU mode to restore it with a custom ipsw. Attempting a normal restore in iTunes also fails - 'The iPhone "iPhone" could not be restored. An unknown error occurred (36)'. Attempting to restore with a custom ipsw results in 'The iPhone "iPhone" could not be restored. This device isn't eligible for the requested build'.

    How did I get here?
    Well I bought a refurbished iPhone 3GS (new bootrom) a few days ago for my wife's xmas, but it was locked to Vodafone (UK) and she uses Giffgaff. As there was no unlock available on the installed iOS (6.0.1) I followed a tutorial to downgrade to 4.1 by installing the iPad baseband using Redsn0w 0.9.6rc18, then downgraded the iPad baseband using Redsn0w 0.9.14b2 (or so I thought).

    At that stage I used Ultrasn0w to unlock and had a working unlocked iPhone on 4.1. I probably should've stopped there, but I wanted to make sure she could use iMessage (her friends and family all use it) so I decided to upgrade following a linked tutorial to upgrade to 6.0 whilst preserving the baseband so I could still unlock. After attempting this, I realised I had no blobs for 6.0, but I did for 6.0.1, so I stupidly tried that instead. Something went wrong, it didn't work and I was left in this restore loop. Can't boot up, can't restore, can't enter Pwned DFU.

    What have i tried?
    I've tried restoring in iTunes 11, 10.4.1 and 9. I've tried restoring to iOS 3.0, 3.1.3, 4.1, 4.2.1, 4.3.5, 5.0.1, 6.0 and 6.0.1. (Note: I only have blobs for both 4.1 and 6.0.1 - I realise anything above 4.1 with the exception of 6.0.1 was bound to fail due to this, but I tried anyways with fingers crossed). I tried restoring with TinyUmbrella 6.01.01 both on and off. I've used Redsn0w 0.9.6rc18, 0.9.14b1, 0.9.14b2, 0.9.15b2, 0.9.15b3 and PwnageTool 4.1.3 Unlock Edition. I've tried restoring, creating custom ipsws, the recovery fix in Redsn0w, custom ipsw in PwnageTool, Exit Recovery and Fix Recovery in TinyUmbrella, I've also tried the additional Tiny Umbrella fix recovery 'fixrecovery43' in terminal, but I just end up back in the recovery loop after various fails.

    Some fails are 'iTunes Error 36', others say 'No successful firmware download after 60000 ms!! Giving up...' others just ask me to try a clean power off - which I can't do as I'm in the restore loop.

    I've even tried creating a custom ipsw in PwnageTool with both iOS 4.1 and iPad iOS 3.2.2 as I suspected my fails were due to the fact that my iPhone still appears to be on the iPad baseband, but that didn't work either.

    More Info
    TinyUmbrella says I'm on iOS 4.1 with a baseband of 06.15.00-6.4_M352. Serial number shows that the phone is from the 45th week of 2010 indicating new bootrom which is confirmed by using Identify on Redsn0w which states [iBoot-359.3.2] -- NEW BOOTROM.

    At this stage, even a clean install back to 6.0.1 would be fantastic, as I can just call Vodafone to unlock.

    Need to know more? Just ask, I'll do my best to find out and let you know. I'd really appreciate any help I can get as I don't have a clue what to try next. At this stage, even a clean install back to 6.0.1 would be fantastic, I can just call VodafThanks in advance.
    Last edited by papasnorkle; 2012-12-02 at 12:59 PM.
    2012-12-02 12:50 PM
  2. iYeow's Avatar
    Ineligible for the required build is because Itunes cannot verify your 6.0.1 blob and you may have your hosts file pointed towards Cydia Server.
    Go to your hosts file in this directories : Cwindows\systems32\drivers\etc\hosts and use Notepad to edit out any reference to gs.apple.com.
    You will also need to change the ipad baseband back to 05.13.xx first using redsn0w before proceeding to stock 6.0.1 restore.
    Reboot your computer and restore to 6.0.1 using the latest itunes from Recovery mode.
    2012-12-02 10:12 PM
  3. papasnorkle's Avatar
    Hi iYeaw, many thanks for the reply. Ah yes, I forgot to mention that I had already tried removing references to gs.apple.com from my hosts file, yet I still managed to get the ineligible error, could there be another reason for this error?

    Regarding using redsn0w to downgrade the baseband, I have also tried this multiple times without success.

    Is there still hope?
    2012-12-02 11:35 PM