1. bhakta0007's Avatar
    Greetings everyone,

    I bought a unloced+jailbroken 3GS when I was in the US. I am now using this phone in India with a local carrier and it works fine. I do not know the initial carrier the phone was on or how it was jailbroken.

    Specs:

    iphone 3GS
    iOS: 4.1 (8B117)
    Model: MC137LL
    Serial: 889297******
    Modem firmware: 06.15.00


    I have a few questions and I hope to get some answers. I have tried to do my diligence of reading up on various places but that has left me even more confused as it appears that a set of steps that works for one user hasn't worked for another with similar phone/model/ios).

    1. I have read that GPS has issues with 06.15.00. However, the GPS functionality seems to be working on my phone (When I open maps, it shows my current location map and I am able to search for places and I see the results [dropped pins].). Does my test conclude that GPS is indeed working or am I missing something?

    2. I want to upgrade to 5.1.1 as there are some apps I want to use which don't work on 4.1. Cydia has shsh saved for my phone for (4.1, 5.1, 5.1.1, 6.0.1). What is the best way to upgrade to 5.1.1 and still have my phone working (i.e. it should continue be unlocked + jailbroken on 5.1.1). I see a lot of tools and am confused on what to use.

    3. Do I need to downgrade the baseband to 5.13.04 during the jailbreak process?

    4. if something goes wrong while trying to upgrade, is it possible to brick the phone for good? Or is there a way to restore it back to 4.1 and jailbreak + Unlock it again?

    This is the only phone I have, so am scared to try something and brick for ever.


    Thanks for reading my post..

    cheers
    -bhakta
    Last edited by bhakta0007; 2013-01-01 at 12:00 PM.
    2013-01-01 11:58 AM
  2. iYeow's Avatar
    Use redsn0w 0.9.15b3 to downgrade your baseband which fixes your GPS issues.
    Run redsn0w again to restore to 5.1.1 with your saved blob.

    There is always a risk of bricking your device when flashing baseband, so do it with caution.
    2013-01-01 02:36 PM
  3. iYeow's Avatar
    Your 6.0.1 jailbreak will be untethered if you want IOS 6.0.1 as you have old bootrom.
    Remember once you have downgraded your BB, you want to restore to custom firmware either stitched or non stitched depending whether you want apple to verify your restore to preserve BB for Ultrasn0w unlock.
    2013-01-02 02:18 AM
  4. bhakta0007's Avatar
    Thanks iYeow. Would you recommend IOS6 on a 3GS? I read about performance issues on 3GS hardware?

    -bhakta
    2013-01-02 05:14 AM
  5. iYeow's Avatar
    IOS 6.0.1 is fine and it has Do not disturb feature which is quite useful . Speed wise is the same as 5.1.1.just close apps not in use to free RAM .
    2013-01-02 08:07 AM
  6. bhakta0007's Avatar
    iYeow.. Thanks for all the help. I managed to downgrade the baseband and move to 5.1.1 and jailbreak/unlock it all with redsn0w_win_0.9.15b3

    cheers
    -bhakta
    2013-01-02 10:36 AM
LINK TO POST COPIED TO CLIPBOARD