1. pottyvick's Avatar
    Im usually really good at understanding how to upgrade or downgrade but i havent been able to find a definitive answer to this. I have an iphone 4s on 5.0.1 jailbroken. Can i upgrade it to 5.1.1?

    I know it has something to do with shsh blobs but i dont understand how or if its possible.

    And the only reason i am looking to update it is some apps require 5.1.1 at least...
    2013-06-07 09:40 PM
  2. Orby's Avatar
    Im usually really good at understanding how to upgrade or downgrade but i havent been able to find a definitive answer to this. I have an iphone 4s on 5.0.1 jailbroken. Can i upgrade it to 5.1.1?

    I know it has something to do with shsh blobs but i dont understand how or if its possible.

    And the only reason i am looking to update it is some apps require 5.1.1 at least...
    Definitive answer (and you're going to hate me for this): maybe.

    The way to check if you're eligible for 5.1.1 is to grab redsn0w 0.9.15b3 for OS X or Windows and use the Query Blobs... function (Extras -> SHSH blobs -> Query). If you see 5.1.1 on the list of blobs returned, you're doing well! Almost there.

    The next thing is go to Extras -> Even More -> Restore in redsn0w. Select a 5.1.1 IPSW for the 4S when asked... if redsn0w allows you to start the restore, you'll be in good shape. If redsn0w grumbles about "invalid ramdisk" or "invalid SHSH blobs" (or generally throws an error message at you) then your only option for a restore would be 6.1.3.
    2013-06-07 10:25 PM
  3. pottyvick's Avatar
    If i do that and it fails will i still be on 5.0.1 or will i have to restore to 6.1.3?
    2013-06-07 10:30 PM
  4. Orby's Avatar
    If i do that and it fails will i still be on 5.0.1 or will i have to restore to 6.1.3?
    You should still be on 5.0.1, if memory serves the restore will fail pretty early in the process if you don't match the eligibility criteria.

    However, as I haven't used this restore technique since iOS 6.0 came out, I cannot say with certainty.

    How did you get to iOS 5.0.1 on your device right now? Did you get the phone from Apple that way, did you do a restore, did you do an upgrade (OTA/iTunes)? Weirdly, this is what determines eligibility if you have the SHSH blobs...
    2013-06-07 10:59 PM
  5. pottyvick's Avatar
    Oh I have Been on it for a while. Never updated. And I've been in cydia it says shsh5.1
    2013-06-07 11:41 PM
  6. Orby's Avatar
    Oh I have Been on it for a while. Never updated. And I've been in cydia it says shsh5.1
    If you've been on it since you've purchased the telephone, then it's probably not too likely you'll be able to use redsn0w's "Restore" trick. Sorry about that.
    2013-06-08 12:07 AM
  7. pottyvick's Avatar
    Well no, i purchased it with 5.0... I updated via itunes to 5.0.1
    2013-06-08 12:52 AM
  8. Orby's Avatar
    Well no, i purchased it with 5.0... I updated via itunes to 5.0.1
    Did you update it via "Update" or "Restore" in iTunes?

    If you used the former, then we're back to square one. If it's the latter, then you should be good to go on the redsn0w "Restore" path.
    2013-06-08 06:24 AM
  9. pottyvick's Avatar
    Yeah it didnt work .... It needs the shsh blobs for ios 5.0.1 too... which i don't have
    2013-06-10 06:25 PM
LINK TO POST COPIED TO CLIPBOARD