User Tag List

  1. ryefield's Avatar
    ok, where do I being.. a few hours ago I downloaded iBlackList 6 from cydia. However, instead of a normal "install" in option it said something about mobilesubtrate and the option to delete (if I recall) with a message stated that this was NOT SAFE and the option "don't change (this is safe)". well, guess what I did.

    then came a lengthy process bar (like all cydia download screens) but this one wasn't about donwloading the app but again, about removing mobilesubtrate. only after it had finished, iBlacklist downloaded and installed. I thought "hmm, that's weird but whatever". the device respringed and since then it is PROPER F*CKED UP. first thing i noticed was that, well, iblacklist didn't work (I blocked my gf and sent a text to myself from her phone- came through) I wanted to uninstall it only to notice Cydia icon had gone MIA. same for iFile. I panicked and tried downloading cydia .deb file, emailing it to myself and open the attachment on the iphone - that worked in a sense because it gave me the option to "open in iFile", but then reinstalling the cydia didn't do anything, cydia was still gone. I then downloaded the latest version i could find on the net for MS and did the same- and since then the phone is in a constant loop of "exit safe mode". I rejailbroke using Evasion, I switched off all MS addons using STSettings.. nothing helps.
    Tried restoring to 6.1.2 i downloaded - error 3194 even though I'm using Tinyumbrella TSS server.

    Hell, I even tried upgrading to 6.1.4 (i'd hate not being JB but..) - same error.

    Please, Experts, sort me out of this mess


    update: I've also cleared all cydia's lists and repos via ifile. it still won't start (crashes upon loading) but that may be just bc I'm still (constantly) in safe mode, right?
    2013-06-18 04:47 AM
  2. DC_Dave's Avatar
    Hi, have you tried searching for Cydia with spotlight search?
    2013-06-18 05:00 PM
  3. ryefield's Avatar
    I did and couldn't. BUT I took the device to a shop today where they played with it for a few hours, attempting to restore using redsn0w (failed) and ran Evasi0n jb again and again. nothing helped yanking the phone out of the safemode loop BUT CYDIA IS NOW WORKING, as well as terminal and ifile.

    A few more clues that might help:
    1. the phone enters safemode as soon as I slide to open from lockscreen, which leads me to think something has gone terribly wrong with MS (mobilesubtrate).
    2. switching all MS addons off (via sbsettings) doesn't help.
    3. when I try to install anything from cydia I get the following message: "I wasn't able to locate file for the com.saurik.subtrate.safemode package. this might mean you need to manually fix this package"

    any leads? how do I fix mobile substrate?
    2013-06-18 10:08 PM
  4. DC_Dave's Avatar
    Hi, hope you have backed up any important stuff first.

    Here are the links for Saurik's Mobile Substrate and safe mode. If you haven't got them installed, you can use iFile.
    You switched off the"MS addons" with SBSettings, it might be worth checking their folder
    And checking that the MobileSafety.dylib has not been renamed .disabled as this is the com.saurik.substrate.safemode package.

    Also check you don't have a .disabled and a .dylib of the same files in that folder.
    I would make sure that if there is a iBlacklist.dylib, that you rename that .disabled too.
    Most .dylib files can be disabled by renaming then .disabled. But I would avoid changing the following
    Any which are coloured blue (shortcut links)
    any lib??????.dylib

    Note, if you reinstall/uninstall anything, make sure their .dylib has been renamed back from .disabled to .dylib first or turn it back on in MS addons.
    2013-06-18 11:12 PM