1. Bustamo's Avatar
    Hey guys, i would like some much needed assistance

    System: Windows 7 x64
    Lenovo x200s
    iPhone 4
    was 5.1.1, 6.1.3 according to redsn0w

    Background: Sisters iphone, she did an OTA update which ended in a recovery mode. Tried tinyumbrella, recboot, redsn0w etc, you name it! in order to kick it out of recovery mode - no luck

    Tried jailbreaking it with redsn0w too

    Anyways, she doesnt back up, last time was in december - lotta stuff happens in between

    I used this tutorial: Guide Data Recovery and Fix crash bug Apple's iPhone, iPod
    - Ramdisk'd into the iPhone 4 using DFU Mode
    - used putty to mount partitions (typed mount.sh)
    - and then winscp to browse the iphone locally.

    DCIM folder, notes, calender, texts I've managed to transfer but...


    Winscp keeps throwing up when trying to copy over touchy subject files, i.e my contacts sqlite, or the whatsapp convo files, and loads more other files, particularly ones located in the mnt2/mobile/application folder

    Permission denied.
    Error code: 3
    Error message from server: Permission denied
    Request code: 5

    Im denied from changing permissions to these files too, they are a tease - i can see 'em, but not touch 'em, bah!

    After reading the restore.log, it said the phone ran out of disk space at 90% [ patchd: patch(2781): prepared update at '/mnt1/var/MobileSoftwareUpdate/softwareupdate.8839/' failed to apply (must-replace files) ]

    I was going to replace the whole of current /mnt1/ partition with the filesystem from 6.1.3 ipsw, but cannot properly decrypt them - if i did, the plists come up as 0kb.

    Can anyone shed some light on this, or provide me a command that allows full read/write/copy access that wont throw up an error when i want to copy files over to my pc? (ive tried some fsck_hfs command too)

    p.s I've been searching for a while over the web, found no solutions, its 6:20am over here in the UK

    cheers guys!
    Last edited by Bustamo; 2013-08-01 at 08:29 AM.
    2013-08-01 08:21 AM
  2. skiptowncat's Avatar
    You done a fresh dfu restore and update?
    2013-08-01 09:37 AM
  3. Bustamo's Avatar
    Nope. thats one thing im wanting to avoid at the moment, because I assume a dfu restore wipes the data partition?
    2013-08-01 04:19 PM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.