1. GreenMagic's Avatar
    Hello forum.

    My phone is stuck in an endless Boot Loop and I cannot get it out of it and don't want to wipe out the phone with iTunes Apple recovery mode.
    Having major problem on my iPhone 4. It died mid call and went black and has not come back since. I had not recently installed anything, although it was jailbroken for nearly a year with Redsn0w.
    I've installed almost nothing at all app wise etc... on the phone. I installed VLC app with no trouble.
    I also DID try to install a Cydia app bootloader app in an effort to change my boot logo. I activated it, uploaded proper gifs and it never worked anyway. SO this is what I think is interfering and not letting me boot now!

    I've tried to DFU boot it, re-Jailbreak it with multiple versions of Redsn0w on multiple computers. Tried new and old macs, old and very old PC computers. I've tried a few other things too.
    I ran the JAR RamDisk tool from MSFTGUY and it gets to 'Almost there...' message and still cannot boot through the Apple icon, Apple icon always pops up for 2-5 seconds and screen goes black and repeats endlessly, until I kill the phone.

    I'm trying to just get into my phone, either to boot it and fix it, or SSH in and recover 1000 pictures.
    I was not allowed to backup my phone thanks to ever updating requirements from Apple and my older working hardware (note my main laptops are (2) PPC PowerBook G4 laptops - yeah, old).

    So please save the backup lectures about this issue. I posted on another awful forum and had no real suggestions and over 1000 views so clearly other people are experiencing this problem.

    The phone can only do two things:
    - go into Recovery mode when plugged into a Mac via USB. (Or I can force it into DFU mode with a modern Mac laptop I borrow)
    - it will kind of boot up if plugged into the wall and gets to the activation screen.

    Yes, I've tried multiple USB ports, cords, the stock dock that came with the iPhone etc etc...
    It's a boot loop hell and I don't want - really i refuse - to go Apple way and recover with iTunes and therefore wipe out all my data on the phone. So again, that won't be a good suggestion either.
    I'm using an ancient slow iPhone 3G as temp phone for now.
    Both phones I use with T Mo. 3 had factory unlock, the above 4 I jailbroke and unlocked off AT&T to run with T Mobile for a year before it died.

    Any suggestions at all? Thank you!
    2014-05-01 10:52 PM
  2. bbrks's Avatar
    I can hardly believe, that you don't have any backup saved on your PC. That boot loop happened to me once......but solved it actually very easy......I put the phone to DFU mode and than took it out off it and it came alive again, without any problem. Did you try that?
    2014-05-01 11:47 PM
  3. GreenMagic's Avatar
    Yes of course. I've done all the easy stuff first. The volume up during boot trick, the white stock headphone vol up during boot trick, DFU reboots galore. Nothing works to get it to stop boot looping.
    2014-05-02 07:07 AM
  4. bbrks's Avatar
    Do you have openSSH installed....if so, you could try semirestore

    2014-05-02 10:20 AM
  5. GreenMagic's Avatar
    Thank you for suggestion.

    However watching video it looks like this is not a solution. It appears it will wipe out my phone photos video text etc.... That's the #1 thing I am trying to avoid.
    Keeping iOS and jailbreak would be nice but I just want my pics off the phone.
    The app also starts with phone running and recognized by Mac. I can only have my brick iPhone recognized officially in Recover mode and I can use other apps to have it show up in DFU mode and that's it.

    I DO have a Cydia SSH installed on the phone. One thing about it, perhaps, is that by default I always kept Wifi off to save battery life. It was almost certainly in off position when phone blacked out and died.
    Maybe silly question, but does that matter?
    I've tried to get into phone with CyberDuck app to no avail. Ssh and SFTP and used Terminal too.
    Last edited by GreenMagic; 2014-05-04 at 09:31 PM.
    2014-05-04 09:26 PM
  6. bbrks's Avatar
    Here is another one...and not to forget, it can be done only on Windows based PCs.

    Semi-Restore for iOS 5.0 to 7.0.6 - Restore while Jailbreak Preserve

    As for your photos, I don't think you can save them......if you don't have any backup......bad luck, sorry
    2014-05-04 10:16 PM
  7. GreenMagic's Avatar
    I don't know if this is common for being stuck in a boot loop,
    BUT if I plug phone into wall AC outlet I get to "configure" screen or "activation" it may be called and can hit home button and get to "emergency calls" page. I've tried that dial and hang up 911 or 112 trick and it doesn't work. It deletes numbers.
    The odd thing is that my OLD screen saver is there - just as it was before my phone went crazy.

    Does this mean anything? Anything else i can do or try? I have also tried to locate the phone with SSH client like CyberDuck and terminal to no avail.
    2014-05-05 10:19 PM
  8. GreenMagic's Avatar
    I was also wondering if there was an issue with using msftguy's automatic ramdisk SSH tool since I had jailbroken with Redsn0w using iOS 5.1.1 Is 5.1.1. Causing the issue with this tool?
    Do I need to make a custom ipsw 5.1.1 ?

    And is it important to have current SIM card (T Mo) in or original pre jailbroken carrier SIM card (at&t) in phone?
    Last edited by GreenMagic; 2014-05-06 at 07:11 AM.
    2014-05-06 07:06 AM
  9. bbrks's Avatar
    I would suggest, that you do a clean restore. Only question is, would you like to stay on 5.1.1, or upgrade to 7.1.1.
    You probably have SHSH blobs for 5.1.1, so no problem of making a custom IPSW 5.1.1. However, I would recommend to upgrade to 7.1.1.
    Latest firmware, support for all apps and on the top of that, special privilege of jailbreak with Geeksnow. Works perfectly.....but semitethered.....so, if you have problem with that, than you should stay on 5.1.1
    2014-05-06 11:20 AM
  10. GreenMagic's Avatar
    Well the restore would wipe out all my phone's saved data so I've been avoiding that route.
    I may try the automatic ramdisk tool with T Mo and AT&T SIM cards loaded next and then try to see if my JB phone running 5.1.1 is causing an issue but I doubt it.

    The damn phone won't go 2-5 seconds past booting up with apple logo and goes to black for 5-10 seconds and repeats over and over.
    Unless I plug into wall power cord and then I get activation screen or recovery iTunes choices. That is it.
    It won't do a thing not plugged into a computer or wall on its own.
    Last edited by GreenMagic; 2014-05-06 at 08:11 PM.
    2014-05-06 08:06 PM
  11. bbrks's Avatar
    Well than, you might have a problem with battery.......replacement, I guess will do the trick
    2014-05-06 10:53 PM
  12. GreenMagic's Avatar
    I don't think it's a battery issue based on research. (Would be nice if that was it).
    I've read about many people have the exact problems and it wasnt hardware, some sort of software error.
    I cannot seem to correct this, its very frustrating.
    2014-05-08 12:19 AM
  13. bbrks's Avatar
    Well, if you say so, we are than back to restore option again.
    2014-05-09 10:01 AM
  14. GreenMagic's Avatar
    Maybe. Hoping not. The thing is from researching here I can't figure out if I must make a custom ipsw 5.1.1 version and then manually place it into the automatic ramdisk tool from msftguy or what. I don't know if that's the source of my phone not making the final boot and finishing the SSH method of connecting to recover files. (Recall my phone was last running 5.1.1 iOS not 4.x).

    I would LOVE to get SSH access on this phone to get my files and then worry about restoring phone to working condition.
    Anyone here use that automatic Ramdisk tool with newer than iOS 4.1 recently?

    Also could be that I could "re- jailbreak" the phone with Redsn0w with a custom ipsw and get phone back without erasing contents.

    OR, perhaps I can option restore in iTunes a custom ipsw partial restore that may or may not - I can't figure out which - erase all my data that way.

    These are three other things to think about before throwing in the towel and wiping it all out
    Last edited by GreenMagic; 2014-05-10 at 07:55 PM.
    2014-05-10 07:52 PM
  15. bbrks's Avatar
    Don't you have any backup from before?
    2014-05-10 11:34 PM
  16. Orby's Avatar
    Okay, here's a thought: tried booting it tethered via redsn0w passing a -v argument for verbose boot? It might shed a little light on where our hangup may be.

    Run this from a root shell (in your redsn0w.app/Contents/MacOS/ directory) on your Mac, starting with your iPhone in Pwned DFU:
    ./redsn0w -j --bootArgs=-v
    with redsn0w 0.9.15b3 (so you'll need an Intel Mac).

    If we've got the recovery/SSH ramdisk made, we can try sending it through redsn0w with a
    ./redsn0w --ramdisk=<path/to/ramdisk>
    command... but that may require an accompanying no-restore IPSW. Haven't experimented much with sending custom ramdisks...
    2014-05-11 06:29 AM
  17. GreenMagic's Avatar
    Unfortunately I don't have any backup of the phone. The laptops I have are too old to accept the OS that will accept a current enough version of iTunes. In fact I had to jailbreak this phone on a family members mac and synced it only the first time with a friends mac that had late enough iTunes version.

    The only thing I had done on occasion is SSH into my phone and manually copy out some pictures and video. So I am currently missing a lot of content.

    I will have to look more into your suggestions Orby, thank you for chiming in. I'm not incredibly adept with command line stuff and that's probably putting it very nicely. I can do certain things in Terminal but not a whole lot generally. I have heard of but don't really know what verbose mode is or means for example. It's something I could do yes, but Im mostly just following instructions.
    2014-05-11 07:00 AM
  18. GreenMagic's Avatar
    Tried to re jailbreak it, DFU boot it etc with older and new version of Redsnow on friends Intel Mac again. Again no luck. Re ran msftguy's automatic ramdisk tool and same exact result as many times before - wont finish because the phone refuses to boot.
    (NO I don't want to restore it. )
    2014-05-18 06:23 AM
  19. GreenMagic's Avatar
    Phone still a dead lump.
    Had another idea. I have the 30 pin dock to USB and dock to SD card adapters.
    Could I make a OS like Linux or Mac OS on an SD card and get the phone to boot externally and get in there and be able to read anything / copy / recover from the phone?
    Anyone ever done this?
    2014-07-22 11:07 PM
  20. Orby's Avatar
    Phone still a dead lump.
    Had another idea. I have the 30 pin dock to USB and dock to SD card adapters.
    Could I make a OS like Linux or Mac OS on an SD card and get the phone to boot externally and get in there and be able to read anything / copy / recover from the phone?
    Anyone ever done this?
    Long story short, not in the way you're hoping. Some folks have valiantly sacrificed loads of braincells getting Android or a pared-down version of Linux running on the device, but as a rule they can't touch the iOS partitions and data. It's also worth noting that the drivers that control the dock connector and the filesystem access are loaded in as part of the devicetree and userspace OS, respectively. Since the device isn't booting, we probably won't have accessory-level support with the OS.
    2014-07-23 10:48 PM
27 12