1. tomdz32's Avatar
    Did not update my itunes or update anything what so ever and message pops up saying "Repair needed iphone cannot make or receive calls" what is this?? need help guys!!!
    2007-10-11 05:16 AM
  2. Kyle Matthews's Avatar
    If you have changed nothing and this started happening, then have Apple replace it.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-10-11 06:45 AM
  3. tomdz32's Avatar
    oh yeah guess i should say its unlocked
    2007-10-11 07:14 AM
  4. Kyle Matthews's Avatar
    Have you tried simply restoring it? Have you already powered it off and back on? You sure you didn't try to update to 1.1.1?
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews
    2007-10-11 07:22 AM
  5. visualdeath's Avatar
    I had a simalar problem. but it happened when I was tring to update 1.1.1 and unlock it. I ended up really messed up. I tried a recover and it failed. I finally got ride of it though. It happened while the ieraser was running and putty froze.

    What I did to get back was:
    1. put the phone in recovery mode because the itunes would not let me do anything.

    2. I did a restore to 1.1.1 and it failed and put me right back in the recovery mode.

    3. I loaded up ibrickr and told it to boot the phone.

    4. When the phone boot up I then followed the ibrickr instructions to downgrade the phone.

    5. when it booted into dfu mode (The White Screen) I did a shift restore and installed the 1.0.2 firmware.

    6. The restore to 1.0.2 finished without error and I was back with Incorrect Sim.

    7. I then unlocked the phone again and all is well.
    2007-10-13 09:04 AM
  6. samaxe's Avatar
    which version u were using.

    i'm facing same problem with my iphone, version 1.1.2 & baseband is 4_02_13_G.
    getting an error as "repair needed. iphone cannot make or receive calls"
    i tried by upgrading to 1.1.2, also 1.1.1 still not working.
    same error message is shown & imei & iccid is Unknown.

    can anybody please give me pointers on this? i'm stucked at this point. jailbreak also doesn't work neither itunes recognises iphone.
    2008-01-21 07:28 PM
  7. eurom3r's Avatar
    try restoring your iphone on itunes.. thats what i did.. just my .02 cents
    2008-01-22 05:37 AM
  8. medafor's Avatar
    USE IBRICKR
    2008-01-22 07:22 PM
  9. jayc7176's Avatar
    USE IBRICKR
    i ran into this before.as well

    Thats the best advise..! try ibrikr .. it will tell u to downgrade via itunes to downgrade . then choose a msg it will give u 3 options ... if non matchs chose the closest one ..(make sure ur on 7.5 or earlier i tried on 7.6 didnt work for me) . let ibrikr boot ur phone
    you will see activation screen
    Perfom jailbreak ..

    after jailbroken successfully.

    get the lockdown file from here -- palce it useing ibrikr in -- user/lexe something similar to that thats the only lexee folfer under user..

    reboot your phone ...
    phone should be activated


    now check ur baseband and go from there mate.
    2008-01-22 09:24 PM
  10. elay12's Avatar
    i ran into this before when i was trying out the 1.1.2 upgrade

    What i did was downgrade everything you can including firmware and virginizing your phone. that did it for me.
    2008-01-22 09:42 PM
  11. samaxe's Avatar
    I used ibrick also.
    ibrick tell me to downgrade to 1.0.2, but always itunes stuck at "waiting for iphone" message & after some times abort with some error code.
    again after reboot using ibrick, ibrick takes me to same loop (downgrade to 1.0.2).
    i'm using itune version 7.4

    so, i'm in infinite loop of trying to downgrade to 1.0.2 & nothing happens.

    and whenever i restore to 1.1.2 or 1.1.1 then getting message as "repair needed. iphone cannot make or receive calls."
    2008-01-23 08:15 PM
  12. Oranges's Avatar
    I'm in the same boat as samaxe.

    I have a OTB 1.1.2. happened to me before, I upgraded to 1.1.3 (not using jailbreak) It restored it.

    BIG MISTAKE, because if this happens again, you can't do anything except wait for the new FW to come out.

    I tried downgrading to 1.1.2, but keeps failing at firmware.
    Still no communications (its locked BTW).

    Trying ibrickr 0.91 now.
    It displayed the connect to itunes pic on the phone, but with green background.
    ibrickr says to wait 10 mins.
    phone screen turned off.
    I turned it back on. this time "connect" pic with blue background then changed green again (ibrickr still at modifying phone screen).

    I think its just gonna loop.

    How do you downgrade from 1.1.3 to 1.0.2 on a OTB 1.1.2 phone on a iphone in this situation? I think if I can get it down to 1.0.2, I can restore the baseband somehow.

    Update-

    After a couple restarts after the phone shuts off from what ever ibrickr was doing, I would get the apple load screen and it would cycle threw the kernal loading in command line and restart. It would just continue to loop this. I just gave up and tried to load 1.1.3 the normal dfu way.

    Still fails halfway threw teh firmware install and throws a 1011 error.

    I assume that mean that the firmware was unable to be loaded. But software loads fine. Same thing happens with 1.1.1, where the software loads fine but firmware fails. 1.1.2 fails at the beginning, throwing a "1" error, inless loaded in dfu mode.

    So I'm back where I started. I just gave up and called apple to send it in for repair. No apple stores in alaska ~sigh~

    BTW anybody have ifuntastic with the purchased stuff that I can mess with to try to fix my phone?
    You can PM. I just want my phone working.

    Update

    So I was wondering around ifixit.com and It seems that they sell comm board replacements. This would be another alternative to the fix to this problem, but at $150 per board, its mighty steep.

    If apple figures that I cracked open my phone (did a pretty good job not to damage the casing) and refuses to repair under warranty then this is what I have to do, in less those of you out there have a spare comm board you guys want to give/sell me

    Or wait for a new firmware to come out. Which ever is first.

    So what ever you do, NEVER RESTORE WHEN THIS HAPPENS. If you have terminal, BSD system, and the bbupdater files, You can restore communication through terminal.

    I wish I found that out BEFORE i restored to 1.1.3

    Update

    SO I finally shipped my phone off to apple today. HOpe to get it back in working aorder in a few days.
    Last edited by Oranges; 2008-01-31 at 10:24 AM. Reason: Automerged Doublepost
    2008-01-31 10:24 AM
  13. Oranges's Avatar
    Update

    SO apple received my phone and deemed it tampered. So looks like I need a new comm board.

    So I'll be buying another iphone soon.

    What I will do is jailbrake the new one load all the files on there and then swap comm boards and run the necessary commands in terminal to restore/downgrade the base band and swap them back.

    I'll be selling one phone once I have successfully completed HW hacking both phones.
    2008-02-02 08:07 AM
  14. samaxe's Avatar
    2008-02-02 09:13 AM
  15. /\/\@D /\/\@/\/'s Avatar
    Did anything actually worked? because my keeps looping. itunes says waiting for iPhone forever. can you be more specific and tell us more...like which itunes version did you used?
    2008-02-02 10:02 AM
  16. Oranges's Avatar
    Nope. doesn't work for me. It crapped out on me when I was on 1.1.3. No way to fix except

    1. update to NEW firmware.
    2. So what I described before .

    Did anything actually worked? because my keeps looping. itunes says waiting for iPhone forever. can you be more specific and tell us more...like which itunes version did you used?
    I think you are trying to load firmware 1.0.2 on a OTB 1.1.2/1.1.3 phone. it isn't going to work. You need to downgrade to 1.1.1 and then jailbrake and upgrade using the guides on this forum.

    As far as activation goes, there aren't any software unlockers working for the 1.1.2-newer phone. ONly way to get it working is to sign up with ATT, get a XXX-sim chip, or hardware hack it.
    Last edited by Oranges; 2008-02-03 at 02:51 AM. Reason: Automerged Doublepost
    2008-02-03 02:51 AM
  17. secretmrx's Avatar
    If you have 3.9BL? maybe you could try to run ieraser which will downgrade your baseband, then you can downgrade, and after you downgrade you shouldnt get the 1015 error because itunes will be able to "update" your firmware. If you do get the error, open up apptapp installer on windows and it should kick you out of recovery. Also ibrickr will do the same
    Want some help PM me and ill answer it asap
    2008-02-03 05:22 AM
  18. Oranges's Avatar
    If you have 3.9BL? maybe you could try to run ieraser which will downgrade your baseband, then you can downgrade, and after you downgrade you shouldnt get the 1015 error because itunes will be able to "update" your firmware. If you do get the error, open up apptapp installer on windows and it should kick you out of recovery. Also ibrickr will do the same
    You don' need to use ieraser on 3.9BL. You use ieraser/irenew on the 4.6BL, thats the whole reason why one would use the ieraser, to downgrade to bootloader to 3.9BL. I highly advise against this since it can really EFFF up you phone and be in tha same place as I am now.
    2008-02-03 11:14 AM
  19. secretmrx's Avatar
    You don' need to use ieraser on 3.9BL. You use ieraser/irenew on the 4.6BL, thats the whole reason why one would use the ieraser, to downgrade to bootloader to 3.9BL. I highly advise against this since it can really EFFF up you phone and be in tha same place as I am now.
    i know but if the phone is f*ked then u might as well try anything. anyway if you run ieraser and restore in itunes you will get a fresh load of modem firmware so i rekon it would work. thats what id do in that situation
    Want some help PM me and ill answer it asap
    2008-02-04 04:31 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.