1. whizkid's Avatar
    Does anybody know how to correct this

    The user name or password for "imap.apple.mail.yahoo.com" is incorrect.

    I m using unlocked iphone with t mobile and edge is working fine with 5.99 t zones internet connection and its working fine...

    Thanks
    2007-10-15 04:37 AM
  2. hanz0e's Avatar
    try removing the "apple" in the imap address, see if that works.
    2007-10-15 04:41 AM
  3. whizkid's Avatar
    how do i do that
    2007-10-15 04:58 AM
  4. billchase2's Avatar
    i'm having the same issue. it worked fine in 1.0.2... but after upgrading to 1.1.1, i get this same error message. any advice?
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2007-10-20 07:08 AM
  5. dannyben's Avatar
    same issue here.... 4 other email account all setup and work perfectly, but not yahoo. if i save anyway & then go back in and re-enter password it authenticates, but still doesnt get mail.

    thinking something went wrong with the jailbreak process and need to redo.

    redid the complete install with simple to use iFunstastic 4.6.1

    Still had all my email accounts setup (but did need to re-enter passwords & reload messages), but now confirmed that yahoo mail (and others) work perfectly.

    Had to be something with the original iNdependence method.

    Not an easy answer, but one that works
    Last edited by dannyben; 2007-10-25 at 08:27 PM. Reason: Automerged Doublepost
    2007-10-25 08:27 PM
  6. filippb's Avatar
    open safari from the phone. log into the yahoo account then log out. then try the mail application.
    2007-10-25 08:38 PM
  7. acaijr73's Avatar
    I noticed that when i unlocked my iphone in 1.0.2 my yahoo mail wasnt working and neither was my You tube but when i activated my you tube and tried setting up my yahoo mail it worked one time... ive noticed this in to other iphones ive unlocked as well..... make sure you tube is actvated if not see if you can activate it by goin off of tutorial on here or borrow a friends iphone that has it activated and ssh into their phone back their activation files on to you computer them put them into your phone and reboot.. yahoo should work after that
    1) 16Gig 1ST GEN IPHONES 3.0 Unlkd /PWND/BNeutered

    1) 16Gig 3G IPHONE BLK PWND, 3.1.2 F/Unlkd

    1) 32Gig 3G(s) IPHONE 3.1.2 F/Unlockd/Blackra1nd
    2007-10-26 11:45 AM
  8. truenorth's Avatar
    open safari from the phone. log into the yahoo account then log out. then try the mail application.
    Thanks, that worked for me!
    Sydney, Australia
    If you received help, click on the Thanks button!

    2007-10-29 10:57 AM
  9. StrictlyBusiness's Avatar
    I've upgraded to 1.1.3 using the dev teams approach and my email wont work either, I need help bad!
    2008-02-01 08:08 PM
  10. dennisd's Avatar
    Same Yahoo issue here under 1.1.3... I need it badly too...
    Last edited by dennisd; 2008-02-01 at 11:55 PM.
    2008-02-01 11:52 PM
  11. StrictlyBusiness's Avatar
    2008-02-02 05:58 AM
  12. dennisd's Avatar
    I tried lots of things and Yahoo is finally working again .

    I was in the impression Yahoo is working fine with FW 1.1.2. (because I have used it succesfully before). So I downgraded 1.1.3. again to 1.1.1 -> 1.1.2. I set up my Yahoo, and surprisely Yahoo didn't work, neither with FW 1.1.2.

    Because it was not working, I decided to upgrade 1.1.3. again (using DEV team p3) and I used the Youtube fix (under install.app), because I couldn't use the Youtube feature.

    I really think that did the trick! Because Yahoo is working fine now.

    I suppose this yahoo issue might have something to do with activation of some programs on the Iphone (?).

    happy joy!
    Last edited by dennisd; 2008-02-02 at 02:44 PM.
    2008-02-02 10:46 AM
  13. StrictlyBusiness's Avatar
    2008-02-03 02:13 AM
  14. burdell1's Avatar
    If you apply the youtube fix, then your yahoo mail will work too
    2008-02-10 08:31 PM
  15. ahmed615's Avatar
    StrictlyBusiness thank you so much that worked for me buddy
    2008-02-12 07:50 AM
  16. superwtc's Avatar
    I tried lots of things and Yahoo is finally working again .

    I was in the impression Yahoo is working fine with FW 1.1.2. (because I have used it succesfully before). So I downgraded 1.1.3. again to 1.1.1 -> 1.1.2. I set up my Yahoo, and surprisely Yahoo didn't work, neither with FW 1.1.2.

    Because it was not working, I decided to upgrade 1.1.3. again (using DEV team p3) and I used the Youtube fix (under install.app), because I couldn't use the Youtube feature.

    I really think that did the trick! Because Yahoo is working fine now.

    I suppose this yahoo issue might have something to do with activation of some programs on the Iphone (?).

    happy joy!
    Thanks! Worked for me...
    3G jailbroken 2.2.1 w/ swirly MMS.
    2008-02-12 03:38 PM
  17. freaksrock62's Avatar
    Im using 1.1.3 and I have it jailbroken.
    Im using Installer to install my apps.
    My email is all screwed up too...
    Where do I find this YouTube fix?
    2008-02-27 12:10 AM
  18. neontronix's Avatar
    yahoo mail problem solved with youtube fix. worked for me
    2008-05-01 11:31 AM
  19. althaur's Avatar
    I can't seem to get any of the Youtube fixes to work. Nor can I access my Yahoo. I get the same message everyone else has gotten. I'm on 1.1.4. Used iLiberty. Not sure what else to try.

    Anyone have any ideas?
    2008-05-04 06:01 PM
  20. fully08's Avatar
    mine still doesnt seem to work.

    I can't seem to get any of the Youtube fixes to work. Nor can I access my Yahoo. I get the same message everyone else has gotten. I'm on 1.1.4. Used iLiberty. Not sure what else to try.

    Anyone have any ideas?
    same exact problem except I jailbroke w/ zip.
    Last edited by fully08; 2008-05-05 at 08:04 PM. Reason: Automerged Doublepost
    2008-05-05 08:04 PM
23 12
LINK TO POST COPIED TO CLIPBOARD