User Tag List

  1. ViperJPB's Avatar
    I Finally got my iPhone Jailbreaked. I set up OpenSSH and was able to follow a guide to use FUGU to login to my iphone via ssh. It worked perfectly the first time but now I can't get in! I get Connection Refused!? The IP address is right and the port is 22...but I have tried 21 and 20 just in case. I had tried installing macfuse but couldn't get it to work so I searched my system and removed any trace of it. So I continue to get "Connection Refused". I have restored the phone twice and uninstalled and re-installed OpenSHH and the BSD Subsystem. Any help or ideas on how to get connected to ssh to my iphone again would be greatly appreciated. I'm on a Mac.
    2007-10-30 10:06 AM
  2. gravy604's Avatar
    Did you make sure the username is "root"?
    2007-10-30 10:51 AM
  3. ninepins's Avatar
    a couple of possibilities:

    *make sure you're using
    username: "root"
    pwd: "alpine"
    (unless you changed the password)

    *Delete the host keys for your FTP program and let them re-compile the next time you try to log on to your iphone.
    (This solved my a search on the forums for a good way to do it..I can't remember)

    *Make sure you don't have SSH disabled via the Services App if you have it installed.
    2007-10-30 02:34 PM
  4. jmcool's Avatar
    I was having a problem with this too, it took me forever to figure out...

    You have to install OpenSSH on the iPhone/iTouch first.

    Go to on Safari and install apptap and whatnot. Next, go into the installer and install "Community Sources" under sources. Restart the ipod and go back into the installer, and go into System -- now OpenSSH will be there. Install that.

    Now you should be able to login using ssh! The password is alpine for macs if you're using terminal.
    2007-10-31 07:09 PM
  5. RC_OZ's Avatar
    If you sure all else is correct, username, password, ip, etc. but still can't login via ssh then delete known_hosts file from .ssh directory. and try again. 1st time login will take 30-40 seconds to generate new key.
    2007-10-31 07:14 PM
  6. ericidle's Avatar
    I was trying to SSH into my phone to test it out prior to trying the method and I met with a problem hopefully one of you good people can help me with

    I cannot get SSH (dropbear) to appear in my 1.0.2 iphone I've tried to install it with ibrikr but no luck. Thinking back I had a batter drain problem with it and tried to switch it off with that did not solve the batter drain problem so I uninstalled it with ibrickr

    could it be that I uninstalled it when had it turned off and now it will not show in my phone even after re installing. would there be a fix for this ?

    Can anyone advise how else I could get ssh into my phone and working so that I can test and use winscp prior to attempting jailbreakme
    2007-10-31 07:33 PM