1. AstrA's Avatar
    Hi guys,

    I will start by describing what happened to my Iphone. I plugged it to the charger and after a while the screen was flicking, I unplugged it, turned it off and then on and the phone wouldn’t start anymore. After a while (3 days later) I turned it on (don’t know how I managed to do that) I got the pics out and tried to restore, and that’s when the real trouble started. The screen lights up (the apple and the circle) only after the itunnes starts the restore. The phone gets block during the restore, the restore process goes quite well (on the screen I see the apple and the small circle spinning) and when it reaches preparing phone for restore after a while the phone blocks and the circle stops spinning. I tried everything, all of the firmware’s, ibrick, iliberty, ziphone non of them work on it they just say DFU mode.

    I was searching for posts in this forum and I didn’t see that anyone has similar problem, that’s why I’m posting this.

    Please help
    2008-04-24 10:29 AM
LINK TO POST COPIED TO CLIPBOARD