1. iphoneluva's Avatar
    My iphone is unlocked and has 1.1.4 firmware...it was working perfectly fine the last few weeks but starting yesterday I haven't been able to make any calls. I can do any and everything else i.e. receive calls, send and receive SMS's, surf the internet, and iTunes works when connected to computer. When I dial a number it says "calling" then .5 second later it says "call ended" . I don't know what to do..I took out the SIM and put in another phone and it worked fine. I turned on and off the iphone and uninstall the emulators I had on. I don't know what else to do..I contemplated restoring it through iTunes but I'm fearful that that may lock the phone. Can someone please help if they can??? Thanks
    2008-06-01 06:50 PM
  2. Clemons003's Avatar
    Down load iliberty from the mmi downloads...Restore your phone through itunes and then jailbreak/unlock using iliberty...
    2008-06-01 06:59 PM
  3. iphoneluva's Avatar
    Thank you!! Downloading as I type..I don't know much about apple/iphone so I was starting to freak out
    2008-06-01 07:10 PM
  4. Clemons003's Avatar
    No problem...The program is pretty easy to use...So goodluck...
    2008-06-01 07:17 PM
  5. iphoneluva's Avatar
    Should I put back in the AT&T SIM for it to be unlocked again?
    2008-06-01 07:26 PM
  6. Clemons003's Avatar
    You can put any active GSM sim in there and it should work....
    2008-06-01 07:28 PM
  7. iphoneluva's Avatar
    It worked!! Thank you
    2008-06-01 07:45 PM
  8. Clemons003's Avatar
    No problem...Just hit the thanks thing on my post....Happy To Help....
    2008-06-01 07:57 PM
LINK TO POST COPIED TO CLIPBOARD