1. berry_lthird's Avatar
    My iPhone came new from the factory with firmware 1.1.1 and baseband 04.02.13_G. (I've read this wasn't possible but I swear this is how it came. Please don't ask if I modified the phone to this point.)

    Whenever I try to downgrade the firmware to 1.0.2 using iTunes, the process hangs at Waiting for iPhone and goes no further.

    I have used tools like iBricker and iNdependence to get the phone into DFU mode. I have used the 10-seconds method with the power + home button then only the home button, respectively.

    I have tried this on both the PC and Mac exhaustively, uninstalling and re-installing several older versions of iTunes in the process to no avail.

    Is there an alternate method of downgrading the firmware without iTunes?

    On a further note, I am also unable to downgrade the baseband using SSH. After I chmod +x ieraser, I run ieraser and the terminal hangs at that point and goes not further.

    I have searched the forums before asking this and if I have missed something I do apologize: In that case I just need to be pointed in the right direction and I can figure out the rest from there.

    P.S. Contrary to my post count, I am not a total noob at this, so please don't assume.

    Thanks in advance!
    2007-12-09 01:23 PM
  2. imstuck's Avatar
    I've racked my brains about this for a while [12 hours] and I know alot of you are having these same troubles, especially Windows XP users.

    What I've come to realise is that the iPod's data has become corrupted somehow. The only way to get around this is to reformat it. Yes folks, you're gonna have to LOSE ALL YOUR FILES ON THE IPOD.

    I was very adamant at first, but if you've exhausted the entire Support Troubleshooting pages and none work... this is the only way.




    To DELETE ALL DATA and REFORMAT, do this:

    ****Make sure the iPod is not connected to PC.


    Uninstall iPod and iTunes programs on your PC.


    Make sure any non essential system utilities like anti-virus, IE, Firewall, Internet connectivity, MSN, AIM, whatever is OFF.


    Make sure any existing iPod and iTunes services are off by CTRL+ALT+DELETE and clicking Processes. End Task 'iTunesHelpers', 'iTunes', 'ipod service'.


    On the iPod, press and hold the 'Menu' and 'Centre' buttons for longer than 6 seconds. The Apple Logo will appear.


    Then press and hold 'Play Pause' and 'Menu' buttons for longer than 6 seconds to go into 'Disk Mode'


    Now plug your iPod into your USB.


    Wait for the computer to load profiles, this may take awhile so do not do anything until its finished. It may seem like its hanging but bear with me.


    Right Click 'My Computer'> Manage > Disk Management
    You'll see your iPod Volume there. Again it may hang but let it work its magic.


    Right click the iPod drive [absolutely make sure it's the iPod and not your PC hard drives!] and click 'Format'


    Ignore the 'Volume Label' and 'Allocation unit size'
    Change File system to "FAT 32".


    Make sure 'Perform a quick format' and 'Enable file and folder compression' are unticked.


    Then click OK.


    This may take a long time to reformat on USB 2.0. Roughly an hour.


    When the Status is 100%, you will notice in 'My Computer' that you can access the thing and it will not hang or crash.


    Eject the iPod.


    Now restart the PC.


    Install iPod Updater and restart again. Don't install iTunes.


    Now plug the iPod back in the PC.


    Open the iPod Updater software and it will actually recognise the iPod this time.


    Click on 'Update' to update the firmware. This will take 5 minutes, you can see after 2 minutes the Apple logo on the iPod and a progressive bar. YOU MUST NOT DISCONNECT, EJECT, TURN OFF PC, OR CRASH THE IPOD EVER AT THIS POINT OR YOU WILL **** UP ROYALLY.


    When the 'Update' is complete, click on 'Restore' to restore it to factory settings. This will take a few mins.


    VOILA, YOUR IPOD IS NOW FULLY WORKING AND UPDATED BACK TO HOW IT WAS WHEN YOU BOUGHT IT [IF NOT BETTER]

    Now re-install your iTunes or whatever programs and refill it

    Be wary about what you put on it though, maybe it was something dodgy before that could trigger the fault again.


    Good luck
    2008-01-07 05:59 AM
  3. macog's Avatar
    I'm having the same problem with mine, I've just got it with with firmware 1.1.2 and baseband 04.02.13_G and whenever I try to downgrade the firmware to 1.0.2 using iTunes, the process hangs at Waiting for iPhone!!!

    How did you solve this??
    2008-01-11 08:18 AM
  4. biganold's Avatar
    I must ask if this works, I am in extreme need of repair and this is exactly my problem.
    2008-08-06 10:27 PM
  5. dino2620's Avatar
    I also want to know if this method works, I beleive my baseband is damaged beyond repair and would just like to reformat my iphone.
    2008-08-13 01:27 AM
LINK TO POST COPIED TO CLIPBOARD